Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
tray icon keeps disappearing
#1
On my Movie Player PC client the tray icon with app control keeps disappearing, but the machine continues to run CQC as far as i can tell. For example, the MyMovies database is on this machine and remains accessible via the CQC driver (although the MyMovies driver doesn't live on this PC but on my CQC server PC).
Any ideas on why this might happen? I occasionally RTP into the Movie Player PC, having done the hack that enables multiple session RTP in Windows 7. Could this be the culprit?
All that said, is there an easy way to restart the tray icon/app control, without restarting CQC?
Thanks
Mike
Reply
#2
It's possible I guess that using RDP could be an issue. Always use different Windows accounts and CQC accounts to log into the console versus RDP to avoid these types of issues.

You can restart the tray app via the start menu. It should be in there. You should generally right click on it and select Run as Admin to make sure it has the appropriate rights to start/stop services and such.

First though, see if it's in the task list still, i.e. it didn't actually die but got knocked out of the tray visually. If so, let me know, then go ahead and kill it and start it again via the Start Menu. That would tell me things to look for.

Are you actually using it for app control? What types of things are you doing?
Dean Roddey
Explorans limites defectum
Reply
#3
It could be leaking memory and crashing. I think that was the problem I had long time ago before removing it.
--Kill all the serial ports--
Reply
#4
I think that was related to having iTunes support enabled but not having iTunes installed, right?
Dean Roddey
Explorans limites defectum
Reply
#5
Same issue for past year(tray icon with app control keeps disappearing). It seems to happen after server is running for 3-4 weeks. In fact just checked my CQC server and icon is gone. I have Itunes installed and it works. Dean is there a log that may help before I re-start up the tray app?
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#6
The tray app logs to the regular CQC logs. So if it's not in there, then it won't be anywhere. I've still got to port the iTunes panel for 5.x, so I'll be digging into it again here at some point in the next weeks. I'll take another whack at what could be going on.
Dean Roddey
Explorans limites defectum
Reply
#7
Dean Roddey Wrote:I think that was related to having iTunes support enabled but not having iTunes installed, right?
That rings a bell. Maybe you can add a registry check or something to work around it.
--Kill all the serial ports--
Reply
#8
bbrendon Wrote:That rings a bell. Maybe you can add a registry check or something to work around it.

If I remember correctly, I now just check once. If that fails, it doesn't try again until it's restarted.
Dean Roddey
Explorans limites defectum
Reply
#9
Yup Dean looks like you have a handle on the issue.
Even Though Itunes was running the driver was not connecting. killed iTunes and started tray app(and it started iTunes). Tray app is now running.


07/12 11:47:16-CQC-PC, CQCServer, CIDOrbSrvWorkThread_3
{
CQCKit, CQCDriver_DriverBase.cpp.4551, Failed/Not Ready, Error: 906/0/0
Driver 'kmusic' is not currently connected to its device
<CQCServer> CQCServer_ThisFacility.cpp - 345
<CQCServer> CIDOrb_ThisFacility.cpp - 536
<CQCClService> CQCKit_CQCSrvAdminClientProxy.cpp - 359
<CQCClService> CQCClService_ThisFacility.cpp - 401

}
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#10
Actually I imagine that had more to do the with underlying failure. The issue I mentioned above is if you enable iTunes support in the tray app, but iTunes isn't installed, something in the underlying COM stuff seemed to leak each time the tray app tried to connect to iTunes. So if folks just enabled it and left it running, constantly trying to connect, it would eventually run the system out of some resource.

I had to change it to only try it once and stop if it couldn't load iTunes, on the assumption it's not installed on that machine.

If you actually have iTunes installed there, then that shouldn't have been an issue for you even before I made that change.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Tray Monitor hangs/crashes out of sleep mode Bugman 5 2,840 01-18-2016, 02:51 PM
Last Post: Bugman
  Tray Application issue Bugman 4 2,767 03-30-2015, 03:32 PM
Last Post: Bugman
  4.6.0 - Weather Channel Icon Mark Stega 9 4,750 11-11-2014, 06:31 AM
Last Post: DaveB
  iTunes via Tray? jkmonroe 7 3,583 01-02-2014, 04:25 AM
Last Post: gacevich
  Reinstall Tray Monitor for Itunes Support CMorrow 1 2,214 12-18-2013, 10:54 AM
Last Post: Dean Roddey
  Tray Monitor zra 35 8,093 04-27-2013, 11:17 AM
Last Post: Dean Roddey
  Anyone using the Tray Monitor on XP? Dean Roddey 15 5,394 01-30-2013, 05:20 PM
Last Post: DaveB
  Tray Icon Issue karenlee 22 6,174 12-20-2012, 02:02 PM
Last Post: Dean Roddey
  iTunes Track Count vs Tray Mon Tracks DaveB 3 2,070 11-15-2012, 03:01 AM
Last Post: DaveB
  Tray Monitor hangs when loading iTunes date DaveB 8 3,450 11-14-2012, 04:05 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)