Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Weather Underground Issue?
#1
I suddenly am not getting any information on the weather underground driver. The driver is connected, but it has all 0 for information.

If I look at the http://api.wunderground.com/api/[yourid]/conditions/forecast10day/astronomy/q/[yoursource].json page, it does fill with information as expected. But the driver isn't capturing that information.

I searched the forums and didn't see anything related to this issue. I'm not sure if it is on my end, or if WU changed their format and nothing is getting through.

Anyone else having issues?
Brian - a long time user that rarely messes with the system now
Other systems used:
SageTV w/ cablecard tuner & multiple extenders for viewing
BlueIris and IP cameras for CCTV
Incredible PBX for home phone
Reply
#2
Here is just a portion of the output when I pull up the json page.
Code:
{
  "response": {
  "version":"0.1",
  "termsofService":"http://www.wunderground.com/weather/api/d/terms.html",
  "features": {
  "conditions": 1
  ,
  "forecast10day": 1
  ,
  "astronomy": 1
  }
    }
  ,    "current_observation": {
        "image": {
        "url":"http://icons.wxug.com/graphics/wu2/logo_130x80.png",
        "title":"Weather Underground",
        "link":"http://www.wunderground.com"
        },
        "display_location": {
        "full":"Greenville-Spartanburg International, SC",
        "city":"Greenville-Spartanburg International",
        "state":"SC",
        "state_name":"South Carolina",
        "country":"US",
        "country_iso3166":"US",
        "zip":"29650",
        "magic":"4",
        "wmo":"99999",
        "latitude":"34.89555740",
        "longitude":"-82.21861267",
        "elevation":"293.00000000"
        },
        "observation_location": {
        "full":"Greenville/Spartanburg, South Carolina",
        "city":"Greenville/Spartanburg",
        "state":"South Carolina",
        "country":"US",
        "country_iso3166":"US",
        "latitude":"34.88388824",
        "longitude":"-82.22083282",
        "elevation":"971 ft"
        },
        "estimated": {
        },
        "station_id":"KGSP",
        "observation_time":"Last Updated on April 1, 8:53 PM EDT",
        "observation_time_rfc822":"Fri, 01 Apr 2016 20:53:00 -0400",
        "observation_epoch":"1459558380",
        "local_time_rfc822":"Fri, 01 Apr 2016 21:16:53 -0400",
        "local_epoch":"1459559813",
        "local_tz_short":"EDT",
        "local_tz_long":"America/New_York",
        "local_tz_offset":"-0400",
        "weather":"Mostly Cloudy",
        "temperature_string":"64 F (18 C)",
        "temp_f":64,
        "temp_c":18,
        "relative_humidity":"84%",
        "wind_string":"From the SSW at 13 MPH",
        "wind_dir":"SSW",
        "wind_degrees":210,
        "wind_mph":13,
        "wind_gust_mph":0,
        "wind_kph":20,
        "wind_gust_kph":0,
        "pressure_mb":"1008",
        "pressure_in":"29.77",
        "pressure_trend":"+",
        "dewpoint_string":"59 F (15 C)",
        "dewpoint_f":59,
        "dewpoint_c":15,
        "heat_index_string":"NA",
        "heat_index_f":"NA",
        "heat_index_c":"NA",
        "windchill_string":"NA",
        "windchill_f":"NA",
        "windchill_c":"NA",
        "feelslike_string":"64 F (18 C)",
        "feelslike_f":"64",
        "feelslike_c":"18",
        "visibility_mi":"10.0",
        "visibility_km":"16.1",
        "solarradiation":"--",
        "UV":"0","precip_1hr_string":"-9999.00 in (-9999.00 mm)",
        "precip_1hr_in":"-9999.00",
        "precip_1hr_metric":"--",
        "precip_today_string":"0.55 in (14.0 mm)",
        "precip_today_in":"0.55",
        "precip_today_metric":"14.0",
        "icon":"mostlycloudy",
Brian - a long time user that rarely messes with the system now
Other systems used:
SageTV w/ cablecard tuner & multiple extenders for viewing
BlueIris and IP cameras for CCTV
Incredible PBX for home phone
Reply
#3
If you put the driver into verbose mode, what is it logging? It may take it some minutes before it tries again because it tries not to hit the server too fast.
Dean Roddey
Explorans limites defectum
Reply
#4
works for me.
------------------------------------
Some of my devices: Sonos, Aeotec zWave, Nest, Rain8Net, Various H/T
What's next: CQC-Voice, Brultech GEM
My vlogs: https://www.youtube.com/c/IVBsHomeAutomation
Reply
#5
Code:
04/02 08:32:33-whs, CQCServer, CQCDrv_WeatherThread31
{
    WundergroundS, WundergroundS_DriverImpl.cpp.329, Status/App Status
    Starting a polling HTTP query pass
}
04/02 08:32:45-whs, CQCServer, CQCDrv_WeatherThread31
{
    CIDSock, CIDSock_IPAddr.cpp.586, Failed/Cannot Do, Error: 5506/1038/0
    Cannot convert the textual address 'api.wunderground.com' to an IP address
      CIDNet_HTTPClient.cpp - 2246
      CIDNet_HTTPClient.cpp - 1406
      WundergroundS_DriverImpl.cpp - 487

}
04/02 08:32:45-whs, CQCServer, CQCDrv_WeatherThread31
{
    WundergroundS, WundergroundS_DriverImpl.cpp.493, Failed/App Status
    An error occurred while doing the HTTP query
}

So it looks like an internet issue on my CQC server. I'll have to dive into it further.
Brian - a long time user that rarely messes with the system now
Other systems used:
SageTV w/ cablecard tuner & multiple extenders for viewing
BlueIris and IP cameras for CCTV
Incredible PBX for home phone
Reply
#6
There's a name resolution issue for the WU server. It may be a temporary DNS issue at your ISP.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Open Weather Map - CurIcon zra 2 138 11-08-2019, 12:45 PM
Last Post: zra
  Slider issue on WebRiva NishanF 4 350 07-03-2019, 05:47 PM
Last Post: NishanF
  Weather tom 69 6,278 06-12-2019, 12:08 PM
Last Post: Dean Roddey
  Admin interface and CML IDE interface issue lleo 5 950 01-11-2019, 03:07 PM
Last Post: Dean Roddey
  WebRIVA password special character issue? batwater 10 1,940 09-30-2018, 02:07 PM
Last Post: batwater
  A big issue with use the Elk M1 and CQC, cant use the IP dialer ghurty 1 844 08-05-2018, 08:56 AM
Last Post: Dean Roddey
  WebRiva, Android, scaling issue IVB 2 1,100 07-15-2018, 01:47 PM
Last Post: IVB
  WebRIVA disconnect issue dlmorgan999 11 3,087 05-09-2018, 09:38 AM
Last Post: Dean Roddey
  Radio RA driver issue dogman 7 1,975 04-22-2018, 08:33 AM
Last Post: Dean Roddey
  Onkyo receiver volume issue dlmorgan999 26 5,289 03-07-2018, 09:44 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)