Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Diagnosing lost connections to ISY?
#1
Everyone once in a while I notice a field change not taking effect, or a timed change not taking the 2nd value. In looking at my logs, I occasionally see entries like this:

Code:
CQCKit, CQCDriver_DriverBase.cpp.1446, Failed/Not Ready, Error: 906/0/0
    Driver 'ISY' is not currently connected to its device
      <CQCServer> CIDOrb_ThisFacility.cpp - 536
      <CQCEventSrv> CQCKit_CQCSrvAdminClientProxy.cpp - 679
      <CQCEventSrv> CQCKit_StdCmdTargets.cpp - 179

How can I diagnose this and improve reliability of the system? It sucks to turn on a garage light automatically and then come back a day later to see it still on because the timed field change failed to turn it off.
Reply
#2
if you put into verbose mode it should log stuff about losing the connection. Though it'll have to happen with 24 hours or it will revert back out of verbose mode, so you may have to put it back into verbose mode once a day until we get something.

How often is this happening?
Dean Roddey
Explorans limites defectum
Reply
#3
I manually noticed it on two days recently, but only because I happened to have the log server open while I was creating some new events. I've set ISY to verbose High and will see how often it happens overnight.
Reply
#4
BTW, there is a statistics field that indicates how many times it's lost the connection, so you can look at that as well. If you leave it in high, it will log so much stuff that it will push out useful stuff. I think that low is good enough to have it log stuff like connecting and reconnecting, or possibly medium. The stats field (which you can see in the host admin dialog when you select that driver) will show how many, but the logs will show us when, which is very useful.
Dean Roddey
Explorans limites defectum
Reply
#5
I didn't grab any logs yet. From Stats, load time of Feb 15 03:33. Lost Comm = 55. Lost Connection = 26.

I may try re-locating to connect it on a different wired network port to see if that helps.
Reply
#6
Well it could be cycling because it's getting back something it doesn't understand. The logs would show that. If it gets back something it really can't grok it will recycle just to be sure it styles in sync and doesn't miss anything. So it may not be a networking issue.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Lost TTS with Win 10 and V5.4.920 George M 27 618 02-28-2021, 06:20 AM
Last Post: George M
  Lost Power - Elk connection problem Ron Haley 7 2,181 03-05-2019, 08:20 PM
Last Post: Ron Haley
  Computer lost server availability George M 6 2,530 04-25-2016, 05:38 AM
Last Post: George M
  (RA2) driver lost connection lleo 17 4,991 03-30-2015, 02:48 PM
Last Post: Dean Roddey
  Sonos - Dropped Connections karenlee 29 5,453 03-27-2015, 10:34 AM
Last Post: karenlee
  Testing Autogen am lost dogman 3 1,984 10-05-2014, 10:24 AM
Last Post: Dean Roddey
  Interface editor - lost transparent button zra 1 1,519 01-26-2014, 12:07 PM
Last Post: Dean Roddey
  iTunes Media Repo Connections issues jt76 11 2,765 03-06-2012, 03:18 PM
Last Post: DaveB
  Diagnosing event trigger problem Ishmael 24 3,770 11-14-2011, 12:42 AM
Last Post: Dean Roddey
  Lost Comm Res vs Lost Connection znelbok 1 1,541 08-15-2011, 05:02 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)