Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(RA2) driver lost connection
#11
How frequently the driver is polling the device?
Have no access to it as I write, but in my recollection the RA2 main repeater powers up and is ready within 20-30 seconds, and its network may be up way before fully ready, so very well can be that after a brief 1-2 second power out is back before the next poll, thus the driver will never notice.
I have also before turned off the main repeater for some time as I was installing devices and than programmed it, and did not notice this behavior. So perhaps if the downtime of the repeater is long enough, the driver will time out and restart connection, but not in case of very brief outages...

PS: can confirm for sure that no inbound or outbound traffic was seen, while the driver showed connected status.
Reply
#12
lleo - are you able to open up access to your RR2 repeater for Dean? I'm having some issues opening ports behind ATT's Uverse gateway router as well as my internal PFSense router. If not, I'll likely remove PFSense and go back to the Uverse router temporarily so we can get this sorted out since I've been dealing with this on and off for the past two years. Thanks.

David
Reply
#13
I was going to see if I could replicate it with my little test system, by very quickly unplugging it and plugging it back in, or just quickly flipping the power strip button I guess would be better. But I was feeling to bad from a cold that I didn't get to it yesterday. I'll try to do it today.
Dean Roddey
Explorans limites defectum
Reply
#14
OK, I tested this on my test system today, and actually the mistake was my own. The problem was that, yes it does ping the device if it hasn't heard anything from it in 30 seconds, but the msg reading method was resetting the 'last msg time' stamp even if it didn't get a msg, so that 30 seconds would never arrive.

Sorry about that. That was one of those so obvious it was hard to see ones. So now it should recover within 30 seconds.

I've attached a driver pack. I can't promise this will work with the regular 4.6 release since it may use some underlying system stuff introduced since then. Import this package and the do a reconfigure.

If you are on a version too early, then it's going to get stuck in Waiting for Init mode, because the CML won't compile on your system. But you will have overwritten the shipped version, so the only way back is to run the installer and refresh your system. So don't try it unless you are on the latest betas or have a little time to recover if you need to.

If absolutely necessary we can get a driver pack done for 4.6.0.


Attached Files
.cqcdrvpack   LutronRA2_V2_3_3.CQCDrvPack (Size: 29.91 KB / Downloads: 0)
Dean Roddey
Explorans limites defectum
Reply
#15
Thanks Dean, I am glad that you found it. I have power outages very infrequently, so not a major issue. And the towel warmer and bathroom fan that ran for a week while on vacation did survive... :-)
I am getting emails on power outages from my UPS, so will keep an eye on it, and can wait for the next final or when have some time will move to the latest beta, which will include the fixed driver.
Reply
#16
Thanks Dean! Really looking forward to putting this issue behind me.
Reply
#17
lleo Wrote:I have also before turned off the main repeater for some time as I was installing devices and than programmed it, and did not notice this behavior. So perhaps if the downtime of the repeater is long enough, the driver will time out and restart connection, but not in case of very brief outages...
Note to self, never trust recollection. As is, the driver could have never recovered after me tinkering with the main receiver, except I also tinkered with CQC in the same sitting. My recall of one time when I perhaps did not touch CQC and the power outage, after which things did not work as expected, directed me to the a wrong conclusion...
Perils of small sample size and spurious associations...
Reply
#18
These changes and some related to the reading of the config file (and the correct reporting of file format errors) are in the 4.6.917 beta.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Lost TTS with Win 10 and V5.4.920 George M 27 613 02-28-2021, 06:20 AM
Last Post: George M
  ClickPLC driver now failing after upgrade znelbok 2 393 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 1,022 08-02-2020, 11:29 PM
Last Post: kblagron
  Marantz receiver driver (IP) dlmorgan999 6 1,006 05-15-2020, 03:32 PM
Last Post: dlmorgan999
  Variables Driver Client gReatAutomation 4 818 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  Reconfig of Driver Causes Built In Triggers to Fire gReatAutomation 2 632 03-25-2020, 04:09 PM
Last Post: gReatAutomation
  Lutron RadioRA2 Driver and Lutron Visor Control gReatAutomation 29 7,557 03-19-2020, 01:03 PM
Last Post: gReatAutomation
  Timers Driver / Field Time Image / Seconds gReatAutomation 1 599 03-16-2020, 05:48 PM
Last Post: Dean Roddey
  Problem with Accesssing Variables Driver Client Interface kblagron 5 1,143 03-05-2020, 02:24 PM
Last Post: kblagron
  ISYv2 Driver - FanLinc simplextech 4 1,260 02-04-2020, 06:55 PM
Last Post: simplextech

Forum Jump:


Users browsing this thread: 1 Guest(s)