Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
(RA2) driver lost connection
#1
What I report here was observed in conjunction with the Radio RA2 v2 driver on my CQC install. It is not clear if this is due to the driver or my setup.

My single-server CQC server has no active clients, so user interference/change can be eliminated. The role of the server if to perform actions based on triggers received from the RA2 driver (and others).

Recently I have had a brief power outage. My server rack is on UPS, so the network and computers were not affected, but the power circuit where my RA2 main repeater is plugged in is not on back-up power and the main repeater was power-cycled. After the power was back the RA2 system restored itself and worked just fine, no devices are lost or missing and the core RA2 functionality is there. However, the conditional actions driven by CQC were missing.
I opened the CQC admin interface and the driver showed a connected status, and no errors in logs. The CQCEventDump did not show any events being received and also no errors. After I paused the RA2 driver and restarted it, the connection has been fully restored and everything worked again.

For now, it is not possible to put my RA2 main repeater on UPS, but will evaluate this possibility.

Is the behavior above expected? I speculate that after the RA2 main repeater came back online, it simply swallowed the commands from CQC with no error codes. Other drivers, like my Brultech ECM also lost power but came back alright.
Is there a housekeeping code/program to run from time to time to cause drivers to pause/reconnect? If so how frequently? Any examples?

I recall in the early days of programming my RA2 setup, a similar event, but back then I attributed this to my code, and for most my CQC complementing the RA2 has been solid. But I now have several important loads switched by CQC, and I will now be concerned whether the loads have been turned off as expected or not.
I am also concerned that the driver showed connected status, so most error checking or alerts would have failed.
Reply
#2
Not sure if relevant but CQC server version is 4.6 final.
Reply
#3
I'll take a look at the driver to see if maybe the paranoia level can be cranked up a bit so that it is sure to cycle if something like that happens.
Dean Roddey
Explorans limites defectum
Reply
#4
This sounds like the same behavior I've seen. As a matter of fact, CQC is not communicating with my RadioRa2 system right now but I haven't had time to connect in and reset the driver. If you want to take a look Dean, I can let you in.
Reply
#5
Sure, if you want to do that. Is it possibly your RA2 repeater power cycled recently? Otherwise, it may not be related to what he is seeing.
Dean Roddey
Explorans limites defectum
Reply
#6
Looking at the driver, for the most part of course we depend on async reports from the device. If we don't get one for some period of time, then we just do a simple ping of the device to make sure it's there. The device pretty much has to be responding, since any exception during poll returns a 'lost comm resource' error and that would cause the driver connection to recycle.

So do you see the driver as offline, or does it show online but changes are not showing up in CQC? If the latter, do outgoing commands from the driver work?

Now, if the device cycled in some way that allowed the network connection to stay up, but it caused the async reporting enablement settings to go back to defaults, then the driver would think everything is fine. The device would respond to our periodic ping and to outgoing commands from the driver, but it would never send us any reports of changes. It seems unlikely it could power cycle without the network connection being lost, but I guess stranger things have occurred. Or perhaps we reconnect to it quickly and it resets them after we reconnect as it continues it's booting up process or something.

If you just see it as offline, then that has to be something else altogether though.
Dean Roddey
Explorans limites defectum
Reply
#7
I know in other instances of power outages being the cause but I'm often out of town so I don't always know. Not sure of the current issue. But if I had to guess, my bet is on a power outage being the cause and when CQC loses connection to RadioRa2, it doesn't try again. Or CQC doesn't realize it lost connection to RadioRa2 but no longer has a connection. That's my guess. I'd be glad to turn on super logging with my system too if that will help figure this out since I've been experiencing this for quite a while.
Reply
#8
Check the above things I mentioned. Does it respond to outgoing commands from the driver? If so, then I'm betting that the async reporting got recycled back to off, but we never saw the connection get lost. If so, that's something that we can hack around.
Dean Roddey
Explorans limites defectum
Reply
#9
CQC shows the RadioRa2 driver as Connected but it isn't seeing the lighting changes as it normally does. This is the same behavior I've noticed every time I've mentioned having issues with CQC and RadioRa2. I'm emailing you remote access info now.
Reply
#10
Dean Roddey Wrote:Check the above things I mentioned. Does it respond to outgoing commands from the driver? If so, then I'm betting that the async reporting got recycled back to off, but we never saw the connection get lost. If so, that's something that we can hack around.

Inbound and outbound commands/communications from CQC don't do anything until I recycle the driver.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Lost TTS with Win 10 and V5.4.920 George M 27 611 02-28-2021, 06:20 AM
Last Post: George M
  ClickPLC driver now failing after upgrade znelbok 2 393 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 1,022 08-02-2020, 11:29 PM
Last Post: kblagron
  Marantz receiver driver (IP) dlmorgan999 6 1,006 05-15-2020, 03:32 PM
Last Post: dlmorgan999
  Variables Driver Client gReatAutomation 4 818 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  Reconfig of Driver Causes Built In Triggers to Fire gReatAutomation 2 632 03-25-2020, 04:09 PM
Last Post: gReatAutomation
  Lutron RadioRA2 Driver and Lutron Visor Control gReatAutomation 29 7,557 03-19-2020, 01:03 PM
Last Post: gReatAutomation
  Timers Driver / Field Time Image / Seconds gReatAutomation 1 599 03-16-2020, 05:48 PM
Last Post: Dean Roddey
  Problem with Accesssing Variables Driver Client Interface kblagron 5 1,143 03-05-2020, 02:24 PM
Last Post: kblagron
  ISYv2 Driver - FanLinc simplextech 4 1,260 02-04-2020, 06:55 PM
Last Post: simplextech

Forum Jump:


Users browsing this thread: 1 Guest(s)