Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying CQC, need help with buttons
OK, it's not responding. So most likely:

1. The baud rate isn't actually set correctly
2. Maybe you have an older one and we are dependent upon more recent functionality
3. Maybe you have an older one and the protocol has changed somewhat since then.

I can connect directly to your VRCOP if want to let me, and see what it is doing. But, just to know for sure, do you have a +3 VRCOP or an older model?
Dean Roddey
Explorans limites defectum
I have an older model. It's a Vizia RF+ but not +3 on it. It's 6 or 7 years old.
That may be the problem. Assuming the baud rate is set correctly, I'm guessing that we aren't getting any response because we are asking for something it doesn't understand. Since the +3 version is required for things like locks, I'm guessing all of our existing customers have those and so we wouldn't have ever noticed any issue.

As I said, I can connect to it and see what find out. I poked around a bit, though it's hard to find answers for these types of things. I noticed that the Elk VRCOP support indicates it must be +3 and that older models are not compatible, so presumably that means that there have been changes.
Dean Roddey
Explorans limites defectum
I leave it up to you as to whether or not you poke around. I'm perfectly happy with that. I know you have plenty on your platter, so I don't want to lead you into anything that is a waste of your time.
I need to go off line for an hour or so and check on my Mother at the Memory Care unit. She's 103.
It won't take long. What you would need to do is:

1. Open the CQC Command Prompt (from the start menu), since the program you are going to run isn't a normal one that's started from the start menu.
2. Run CQCRPortSrv, which will bring up the remote port server.
3. You will need to Enable it using the button towards the top
4. Pause any CQC or Elve drivers so they aren't holding the COM port
5. Set up a port forward on your router, for the port selected in the remote port server (the default one is fine, and it will be displayed at the top.)
6. Let me know your public IP address and the serial port that the VRCOP is on.

Then I can connect to it as though the serial port is local to me, and bring up the driver in the debugger and see what is going on. Have you ever set up a port forward on the router before? If not, that might be a stumbling block but it's usually not very hard. You just tell the router the (internal) IP address of the machine that the VRCOP is connected to, and the port to forward. If it asks for a protocol, select TCP.
Dean Roddey
Explorans limites defectum
Deane Johnson Wrote:I need to go off line for an hour or so and check on my Mother at the Memory Care unit. She's 103.

OK, I haven't had anything to eat today so I need to grab some lunch as well.
Dean Roddey
Explorans limites defectum
OK, port forwarding should work if I didn't leave anything out.

[Removed sensitive info]
So it does look like it's some sort of difference in the way it responds. The problem is that, when you send a command to a Z-Wave unit, you get back first an acknowledgement from the VRCOP that it received your request, then you get another one that says it's been sent, then you get actual reply (if it works.)

Yours is sending the reply first, and then the final acknowledgement. The driver waits for the final acknowledgement to be sure that the msg has been sent, and then it waits for the actual reply. But the reply has already arrived and (since no one was waiting for it) it was discarded. So now it goes to wait for the reply and that is not going to happen now.

I have no idea why yours work would that way. It's not supposed to. It makes no sense to get the ack that the message has been sent after the reply has already been received. I can't see how your old Elve driver worked at all, unless he just never bothered to wait for transmission acks or something, which I wouldn't want to do because it can allow the driver to try to do things too fast. I've tried it a number of times in a row and it's consistently doing this, so it's not some sort of short term glitch or anything.

So, much as I hate to say it, you might be screwed unless you pick up a new +3 one. I know may be the straw that threw the camel under the bridge for you with CQC, but I can't see any alternative. The up side is that you could then support locks and other newer module types, such as battery powered devices that are always listening which is nice as well.
Dean Roddey
Explorans limites defectum
Dean, I appreciate your taking the time to examine this.

So that you know where I stand at this time, I'm determined to become a CQC user, if you'll have me. I've seen enough already to know it's of the professional level I love to be involved with. Yes, it's more complicated to learn than some others, but it does 10 times as much, IMO. With my needs being fairly simple compared to many others, I should be able to get it going without being too much bother to you and others on the forum. Well, maybe that's not completely accurate.:-)

I'll get a new VRC0P on order. Unfortunately, Amazon doesn't included this in their Prime, so I'll have to wait a day or two.

In the meantime, I'll move on to getting the GC-100 operational. Once that's done, it will allow me to work towards getting the iPad operational, so I'll have plenty to do while waiting for the VRC0P.

After that, I'll move on to getting an IZY for the X-10.

The relays will be the toughest because Carl doesn't always have some built up and I hate the thought of building these kits. I need 12 relays, so it takes 2 of them.

Thanks for your help today.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Controlling Insteon Scene Controller buttons ellisr63 8 5,953 10-14-2014, 11:38 AM
Last Post: SomeWhatLost
  Toolbar and buttons ellisr63 1 1,811 09-19-2013, 06:36 PM
Last Post: Dean Roddey
  Touchpanel with hard buttons IVB 4 2,306 12-18-2007, 03:31 PM
Last Post: LesAuber
  Variable problem with 2 buttons ellisr63 0 1,399 08-01-2007, 01:43 PM
Last Post: ellisr63
  hopefully my last silly question (mapping mouse buttons) willplaice 1 1,496 01-31-2007, 03:36 PM
Last Post: Dean Roddey
  Getting name of widget in the action for that widget? and q on exclusive buttons. Sendero 10 4,148 01-15-2007, 04:03 PM
Last Post: Sendero
  How do I have one set of control (on/off) buttons for multiple devices? Sendero 16 4,084 11-29-2006, 12:13 PM
Last Post: Sendero
  Looking for "action" help for buttons. rodaaent 8 3,258 10-29-2006, 09:42 AM
Last Post: rodaaent
  How are you emulating radio buttons? IVB 3 2,305 10-28-2006, 09:53 AM
Last Post: ellisr63

Forum Jump:

Users browsing this thread: 1 Guest(s)