Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Zone Player V2?
#1
Hi Dean - I was just wondering, do you have any plans to bump the SZP to V2, like the Sonos media renderer? I use both, so of course if would be useful to not have separate commands, one sending 'mute' and the other sending 'aud#mute', depending on whether I am playing albums or radio.

Thanks
K
Reply
#2
It hasn't been done yet because there were other V2 interfaces it would require that weren't done. That may not be the case now, I'd have to look back into it. It would use the Audio and Media Transport device classes, but we only recently worked out a non-media renderer means of dealing with metadata in the Now Playing device class. I'm not sure if it would need any others. I don't want to do it, and then have to do a completely separate one again to introduce more V2 interfaces to it later.
Dean Roddey
Explorans limites defectum
Reply
#3
Okay, thanks.

BTW, I've just loaded up the latest version of CQC, and I can't play any albums. I can play radio, and I can play a Sonos playlist, but my albums are freaking out.

When I select an album, nothing happens in terms of audio, and when I go to check the queued songs, I can just glimpse them all being deleted one after another...

I'm picking through it now, but if the problem is familiar, please let me know - I played an album on Sunday, and I don't think I've messed with it since then...

K
Reply
#4
You mean the renderer player? You are queuing them up and then the queue just empties back out? If so, put it into verbose mode and queue up some songs and see what it's complaining about. It would have to mean that the driver thinks that the songs are immediately ending.

Does the first song actually start playing on the Sonos? If not, it would seem that it's actually not playing.
Dean Roddey
Explorans limites defectum
Reply
#5
Yes, that's exactly what's happening - the queue just empties. When I switch to the 'view queue' page, I can just see the last 3 or 4 being deleted.

No, the first song doesn't get played at all.
Reply
#6
I thought it might have something to do with the manifest (remember, I had that issue about a year ago, which was similar - radio was playing but albums weren't - and the fix turned out to be having to change to this:

<CQCCfg:FixedValItem CQCCfg:Name="LocPattern" CQCCfg:Value="x-file-cifs://%(L)"/> )


Anyway, here is the log file - I queued a long album and managed to click on one song before it got erased - see the error msg: (log file chopped for brevity, but all the songs were erased)


10/28 21:50:39-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCMedia, CQCMedia_StdRendDrv.cpp.1109, Status/App Status
Removing failed item from playlist. Moniker=SonosCQCZone3
Party Like Cowboyz [Galactic Version][Version]
}
10/28 21:50:40-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCMedia, CQCMedia_StdRendDrv.cpp.1109, Status/App Status
Removing failed item from playlist. Moniker=SonosCQCZone3
Lay It All On Me
}
10/28 21:50:44-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCKit, CQCDriver_DriverBase.cpp.6635, Failed/Not Found, Error: 2016/0/0
The value written to field SonosCQCZone3.MREND#SelPlaylistItem was rejected by the driver. Reason=ValueRejected
Value Rejected
<CQCServer> CQCDriver_DriverBase.cpp - 8021
<CQCServer> CIDOrb_ThisFacility.cpp - 536
<CQCIntfView> CQCKit_CQCSrvAdminClientProxy.cpp - 2053
<CQCIntfView> CQCKit_StdCmdTargets.cpp - 276

}
10/28 21:50:44-AutoServer, CQCIntfView, CQCRunActionThread6
{
CQCKit, CQCKit_StdCmdTargets.cpp.283, Failed/App Status
Failed to write to field SonosCQCZone3.MREND#SelPlaylistItem
16
}
10/28 21:50:44-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCMedia, CQCMedia_StdRendDrv.cpp.1109, Status/App Status
Removing failed item from playlist. Moniker=SonosCQCZone3
Never Far Away
}

Adding another two I managed to click on first:


10/28 22:05:45-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCKit, CQCDriver_DriverBase.cpp.6635, Failed/Not Found, Error: 2016/0/0
The value written to field SonosCQCZone3.MREND#SelPlaylistItem was rejected by the driver. Reason=ValueRejected
Value Rejected
<CQCServer> CQCDriver_DriverBase.cpp - 8021
<CQCServer> CIDOrb_ThisFacility.cpp - 536
<CQCIntfView> CQCKit_CQCSrvAdminClientProxy.cpp - 2053
<CQCIntfView> CQCKit_StdCmdTargets.cpp - 276

}
10/28 22:05:45-AutoServer, CQCIntfView, CQCRunActionThread6
{
CQCKit, CQCKit_StdCmdTargets.cpp.283, Failed/App Status
Failed to write to field SonosCQCZone3.MREND#SelPlaylistItem
26
}


10/28 22:06:10-AutoServer, CQCServer, CQCDrv_SonosCQCZone3Thread23
{
CQCKit, CQCDriver_DriverBase.cpp.6635, Failed/Not Found, Error: 2016/0/0
The value written to field SonosCQCZone3.MREND#SelPlaylistItem was rejected by the driver. Reason=ValueRejected
Value Rejected
<CQCServer> CQCDriver_DriverBase.cpp - 8021
<CQCServer> CIDOrb_ThisFacility.cpp - 536
<CQCIntfView> CQCKit_CQCSrvAdminClientProxy.cpp - 2053
<CQCIntfView> CQCKit_StdCmdTargets.cpp - 276

}
10/28 22:06:10-AutoServer, CQCIntfView, CQCRunActionThread6
{
CQCKit, CQCKit_StdCmdTargets.cpp.283, Failed/App Status
Failed to write to field SonosCQCZone3.MREND#SelPlaylistItem
46
}



It seems it is rejecting the number (16, 26 and 46 respectively) - what do those numbers represent?
Reply
#7
There's nothing magic about the numbers. There's not really enough logging there to be sure what is going on. I.e. whether it's failing at the Sonos player which is returning an error, or if it's failing in terms of the driver just rejecting the value.

Have you upgraded since we made that change? If this is the first upgrade since then, then it would have likely gotten overwritten, since it's not that way in the manifest file as it stands. So you might have to make the change again to your copy, I don't remember the details and whether we decided that that was something that should be done in the shipped version or not. I.e. would it work for everyone.

But, in the meantime, to test whether that's it, you will probably need to make that change again. You'll have the restart the master server after making the change. If the driver is running on the MS that should be sufficient, else unload and reload the driver again after the MS is cycled.
Dean Roddey
Explorans limites defectum
Reply
#8
Yes, I had already modified the manifest, and restarted the server. I just restarted the server again for good measure, and I'm getting the same results.

To verify I didn't have anything weird in my templates, I also used your auto template generator, and had the same results with that.

I think I will need to roll back to my previous version and see if that still works so that I can try to pinpoint the timeline of the error.
Reply
#9
I can confirm that rolling back has corrected the issue (from 4.5.24 to 4.4.934).
Reply
#10
Hmmm.... That doesn't make much sense. Did you do a reconfigure on the drivers after making the change to the manifest file? That would be required because they cache that manifest info (with user selected options) and would only reload the manifest itself if you reconfigure or remove/reinstall. Sorry, I should have warned you about it, but I didn't remember it until I went back and looked at the previous thread where we discussed this issue.

So, if you didn't do the reconfigure, that's probably why. Do it one more time and, if that fixes it, I promise we'll come up with a way to make it stick for 4.7.

Actually, wait for the 4.5.25 version I'll put up here in a bit. I'll try to get more logging into it to help figure this out. One issue here is that it's UPnP based, so it's a lot more of a black box to CQC than it might otherwise be.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Sonos Log Message karenlee 5 772 10-24-2021, 04:18 AM
Last Post: karenlee
  Sonos Zone Player - Win10 zra 9 3,277 09-26-2019, 10:00 AM
Last Post: zra
  SONOS Driver Question gReatAutomation 13 5,547 08-23-2019, 12:37 PM
Last Post: Dean Roddey
  Sonos - PlayFovorite command NightLight 22 6,601 05-10-2019, 09:32 PM
Last Post: kblagron
  Sonos batwater 4 2,014 01-24-2019, 05:20 AM
Last Post: batwater
  Sonos Update Error (Again) karenlee 39 13,527 12-04-2018, 10:15 PM
Last Post: Dean Roddey
  Sonos PlayFavorites kblagron 8 3,951 10-22-2018, 08:46 PM
Last Post: Dean Roddey
  Sonos Driver zra 3 2,379 09-01-2018, 03:09 PM
Last Post: Dean Roddey
  Sonos stops after CQC restart batwater 1 1,666 05-18-2018, 10:12 AM
Last Post: Dean Roddey
  Sonos Driver with Sonos Connect Amp zra 5 3,681 05-05-2018, 09:43 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)