Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Cannot find any UPnP devices?
#11
Sadly not dean

It accepts the command (But says it's changing to "netsh advfirewall firewall")

Still have the problem of not finding drivers unless I disable the firewall. I am going through it with a fine tooth comb at the moment but having no luck.
Is it just the CQCClient.exe I need to allow or does the UPNP device search use another exe file that I should look at allowing?
Reply
#12
It's not any CQC programs that are the issue, I don't think. It would just be enabling the UPnP protocol ports in general. As of Vista, I think that the UPnP falls under the 'Network Discovery' option in the Windows firewall. So go the control panel, then Firewall, then the allow programs option, and one of them should be Network Discovery. Enable that for the local network, if it's not already, restart the machine, and see if that does it.
Dean Roddey
Explorans limites defectum
Reply
#13
There are lots listed as network discovery, However I have gone through them all listed with UPnP. They are all enabled with "allow" for my private network.

Hmm, Need to keep digging. As soon as I turn the firewall off CQC works perfect.
Reply
#14
This may be a silly question but does the sonos app work from this machine?
Reply
#15
It's a good question, But Yes, The sonos desktop app works fine from this PC.
Reply
#16
The app of course isn't running in a service. So one thing to do, if you haven't already, is to set up the CQC service on that machine to run under a regular administrative account that you create, instead of the default one. It may be that a security policy isn't allowing UPnP for that standard service account.
Dean Roddey
Explorans limites defectum
Reply
#17
I fixed it! I'm just about ready to burn windows 8 now, Give me windows 7 back!

Within the "advanced" firewall, There is a "restore default policy" button. I pressed that, Having to reset all of my firewall settings and now it works fine!
I don't care about the rest of the settings, At least I know something was wrong in there.
Reply
#18
You should update the first post with a note as to the resolution, to help anyone coming along later doing a search.
Dean Roddey
Explorans limites defectum
Reply
#19
Hi Dean

Yes no problem, I will do that when I get home from work.

Cheers
Mat
Reply
#20
Quote:***FIXED***
This was a windows 8 firewall issue. Turning the firewall off made CQC work and found my sonos (UPnP device) quickly with no errors. However obviously you should not run a system without a firewall, But I was unable to find the problem so you need to reset your firewall to the default using the "Restore default policy" found in the advanced firewall screen.

Just a word of warning on this fix! I did this and it did fix the problem discovering UPnP on Windows 7 for me - However, it also cleared out all of the previous port settings that had been updated by CQC when installed, my lockdown of RDP to only allow certain computers, etc., and all of these had to be reset back to what they were before.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Variable Action "Find" command or alternate Shaky 3 464 11-02-2021, 08:19 PM
Last Post: Shaky
  [REQUEST] Z-Wave Devices simplextech 2 1,441 01-05-2020, 07:31 PM
Last Post: simplextech
  Scheduled Events - Cannot find the specified path gReatAutomation 4 1,608 08-16-2019, 12:21 PM
Last Post: Dean Roddey
  Zwave / Remove unused devices? gReatAutomation 2 1,184 07-25-2019, 02:27 PM
Last Post: gReatAutomation
  Can't find a rule/trigger IVB 5 2,211 12-10-2018, 06:03 PM
Last Post: Dean Roddey
  Can't Find a Couple of Documented Action Commands kblagron 7 3,858 10-02-2018, 05:47 PM
Last Post: kblagron
  Can't find CQCServer pjgregory 12 4,872 03-25-2018, 10:37 AM
Last Post: Dean Roddey
  Changing Field Values in Devices Tab TurboSam 3 2,268 01-01-2018, 02:47 PM
Last Post: Dean Roddey
  Incorporating zWave devices kjaerligkatt 4 3,223 08-14-2017, 08:56 AM
Last Post: kjaerligkatt
  where did the list of supported devices go? indygreg 8 6,228 06-08-2017, 02:21 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)