Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Oppo Driver Not Connecting to BDP-93
#1
I'm evaluating CQC v4.4.0 during the trial period and am having a problem with the driver for the Oppo player. I used the NetSerial COM port redirector to create a virtual COM port to communicate with an iTach Flex with a serial cable. Using the NetSerial Monitor, I can see that the port is opened when I start the Oppo driver. A #QPW command is sent to query the power state and the response "@ OK ON" is received. However, the control info "PURGE_RX" also appears twice. The sequence of query, response, and control info keeps repeating.

In the log server monitor the message "Driver 'Opp Blueray' is trying to connect to its device" keeps repeating.
Any suggestions for troubleshooting this? Is there a way to step through the driver (similar to a debugger) to see what it's doing?

I also noticed that there is no client side driver to choose in the dialog box for the client drivers. Is this correct?
Reply
#2
You can simplify things, assuming I understand your scenario, by dropping the Netserial stuff. We directly support the GC serial ports in our software. If you go to the Admin Interface, in the Administer menu, one of the menus in there lets you configure GC based serial ports, so they show up as available ports when you load a driver.

This will remove some moving parts from the picture and may get rid of your problem as well.
Dean Roddey
Explorans limites defectum
Reply
#3
Note that we can't set up the serial port parameters, so you'll need to do that via the GC web interface, so that it's set up correctly for the device's requirements.
Dean Roddey
Explorans limites defectum
Reply
#4
Did that help any?
Dean Roddey
Explorans limites defectum
Reply
#5
The message "Driver is trying to connect to its device" is still appearing in the log.

I uninstalled NetSerial. I then created a GC100 port named Oppo with address 192.168.1.21:4999 and port #1 selected. I installed the Oppo driver and selected COM port GC100/Oppo/COM1. In the list of ports Local/COM1 also appears - I don't know if this is an issue.
Reply
#6
/Local/COM1 is an actual physical local COM port most likely. Oh, and to go back to your original post, most drivers don't have a client side interface. It's only done when more extensive configuration is required.

A very common issue is that the device requires a crossover serial cable and you are using a straight through, or vice versa. Are you sure you have the right kind of cable? Presumably you do if the driver responds in a coherent way to the initial power query.

If you put the driver into verbose logging mode, does it spit out any more useful info?
Dean Roddey
Explorans limites defectum
Reply
#7
Oh, and reading through some of the Oppo thread in the beta drivers section, it appears there's been some firmware upgrades, so you may want to check that if you've had this unit for a while.
Dean Roddey
Explorans limites defectum
Reply
#8
The log verbosity was set to High. I installed the latest firmware last week. Is there any way to get further insight into this issue?
Reply
#9
Not without bringing it up in the IDE and debugging through it. You can do that, since the driver is shipped as source and the IDE is included in the product, but unless you have some development experience it might be more than you want to bite off.

Baring that, you could set up our remote port server, so that I could connect to the Oppo myself and see what is going on. You'd have to set up a port forward and give me a public IP address I can connect to.

There's a FAQ on the web site about the remote port server under Learn -> FAQs -> How To -> Remote Driver Development.
Dean Roddey
Explorans limites defectum
Reply
#10
BTW, generally verbose logging would get more useful info. That driver needs to be spiffed up a bit on that front to help with in the field debugging.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Driver for Amazon 4k Stick Darrie 3 508 01-15-2022, 02:21 PM
Last Post: znelbok
  CQSL Interface Driver connects but no control NightLight 3 566 10-26-2021, 01:12 PM
Last Post: NightLight
  ClickPLC driver now failing after upgrade znelbok 2 992 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 1,983 08-02-2020, 11:29 PM
Last Post: kblagron
  Marantz receiver driver (IP) dlmorgan999 6 2,077 05-15-2020, 03:32 PM
Last Post: dlmorgan999
  Variables Driver Client gReatAutomation 4 1,667 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  Reconfig of Driver Causes Built In Triggers to Fire gReatAutomation 2 1,234 03-25-2020, 04:09 PM
Last Post: gReatAutomation
  Lutron RadioRA2 Driver and Lutron Visor Control gReatAutomation 29 11,256 03-19-2020, 01:03 PM
Last Post: gReatAutomation
  Timers Driver / Field Time Image / Seconds gReatAutomation 1 1,152 03-16-2020, 05:48 PM
Last Post: Dean Roddey
  Problem with Accesssing Variables Driver Client Interface kblagron 5 2,128 03-05-2020, 02:24 PM
Last Post: kblagron

Forum Jump:


Users browsing this thread: 1 Guest(s)