Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
M1 lost connection and wont connect
#1
I have an M1 with a flat battery. Every time I trip an alarm and it is not acknowledged I seem to have the driver go off line. Tonight it was the tamper alarm when I opened up a panel. The driver is now off-line.

The only way I have managed to get it on line is to power down the M1 and power it back up - and that takes a minute or two to come back.

log is as follows

Code:
02/02 19:39:51-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.430, Status/App Status
    ->Elk: 06rr00
}
02/02 19:39:51-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.1735, Status/App Status
    Got command zc
}
02/02 19:39:51-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.2583, Status/App Status
    Querying M1 version number
}
02/02 19:39:51-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.430, Status/App Status
    ->Elk: 06vn00
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.2595, Status/App Status
    Error querying version. Err=Timed Out
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.2612, Status/App Status
    Elk version is: 0.0.0
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.430, Status/App Status
    ->Elk: 06cp00
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.1735, Status/App Status
    Got command cr
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.430, Status/App Status
    ->Elk: 06zs00
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.1735, Status/App Status
    Got command zs
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.430, Status/App Status
    ->Elk: 06as00
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.1735, Status/App Status
    Got command as
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCGenDrvS, MEng.System.CQC.Drivers.ElkM1.DriverImpl.2746, Status/App Status
    20 is not a valid ordinal for enum MEng.System.CQC.Drivers.ElkM1.Helpers.AlarmTypes
}
02/02 19:39:54-zeus.calderwood.net, CQCServer, CQCDrv_M1_Thread15
{
    CQCKit, CQCKit_DriverBase.cpp.2902, Status/App Status
    Driver 'M1' has lost its communcations resource
}

Dean, Can you please look at what needs to be done to correct this. Let me know what else you need from me.
Mykel Koblenz
Illawarra Smart Home
Reply
#2
Yeh, this has been reported before. It's some value that the driver is not prepared for that happens occasionally. I'll look at it today.
Dean Roddey
Explorans limites defectum
Reply
#3
That is not a defined value in my protocol document. I was going to go see if they have a newer one but they evidently trashed all the old signup info and you have to re-register, so I'm waiting to get approved. In the meantime, I did add some exception handling there to just put the field into error if an unknown value is found in the future, instead of falling over. That was correctly being done in other places, but it somehow got missed in that case.
Dean Roddey
Explorans limites defectum
Reply
#4
Just in case it is somthing - I have a Ness M1, not an Elk M1. I dont think Ness have custome code in their, but there is always the chance they do.

If the documentation still does not show it I will chase up Ness and see if they have indeed made changes.

They have always linked to the Elk web site for downloading the doc.

Mick
Mykel Koblenz
Illawarra Smart Home
Reply
#5
Actually, I think it was my fault. I've updated it, so if you want I can send you a driver pack to give a try.
Dean Roddey
Explorans limites defectum
Reply
#6
Please send - it is an easy condition to reproduce

Mick
Mykel Koblenz
Illawarra Smart Home
Reply
#7
OK, I sent it.
Dean Roddey
Explorans limites defectum
Reply
#8
Did that take care of the problem?
Dean Roddey
Explorans limites defectum
Reply
#9
I won't get to it until later this morning (Saturday) I can't test at night because it will wake the kids

Mick
Mykel Koblenz
Illawarra Smart Home
Reply
#10
What is the best way to do this?

I have loaded it, but can;t find it in the list unless you left the manifest as it was at V2.0.

I have a lot of triggers on this driver so how can I upgrade the driver without losing them all?

I was going to load it as a separate driver but until I can find it in the list of drivers I cant.

If the M1 can't handle two connections at once how can I turn off the other driver.

Mick
Mykel Koblenz
Illawarra Smart Home
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Lost TTS with Win 10 and V5.4.920 George M 27 618 02-28-2021, 06:20 AM
Last Post: George M
  CQC Server Closing Connection gReatAutomation 1 735 12-19-2019, 01:53 PM
Last Post: Dean Roddey
  Denon x3600H won't connect dangerlong 8 1,596 12-09-2019, 06:15 AM
Last Post: dangerlong
  IOS Homescreen Webriva fails to connect zra 5 1,726 10-05-2019, 12:26 PM
Last Post: zra
  Lost Power - Elk connection problem Ron Haley 7 2,181 03-05-2019, 08:20 PM
Last Post: Ron Haley
  With the ELK M1 does the Serial connection have more then the IP? ghurty 10 2,435 12-31-2018, 01:13 PM
Last Post: batwater
  Sonos Driver with Sonos Connect Amp zra 5 2,930 05-05-2018, 09:43 AM
Last Post: Dean Roddey
  Onkyo NR906 Reciever Connect Issue zra 6 3,516 08-11-2017, 08:49 AM
Last Post: Dean Roddey
  Polk Xrt12 Driver will not connect DaveB 4 2,849 04-03-2017, 05:39 PM
Last Post: DaveB
  Sonos Connect Problem kblagron 24 8,932 10-23-2016, 09:24 AM
Last Post: karenlee

Forum Jump:


Users browsing this thread: 1 Guest(s)