Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
itunes 10
#1
i just upgraded to itunes 10 (10.1.1.4) and it appears that the itunes helper can no longer connect so i've lost use of the driver. I'm pretty sure i am on 3.4.8.
Reply
#2
dman000000 Wrote:i just upgraded to itunes 10 (10.1.1.4) and it appears that the itunes helper can no longer connect so i've lost use of the driver. I'm pretty sure i am on 3.4.8.
I also have iTunes 10.1.1.4 and have no trouble invoking the helper and having it generate the cover art and the XML data for the repository. The only thing I can suggest is setting the logging verbosity to high and doing a manual invoke from the tray icon. Post the logs after doing that.
Mark Stega
Reply
#3
dman000000 Wrote:i just upgraded to itunes 10 (10.1.1.4) and it appears that the itunes helper can no longer connect so i've lost use of the driver. I'm pretty sure i am on 3.4.8.

I just checked my system and my Itunes helper was in an endless loop also. I put the itunes disk repository in verbose log level High and it appears a new Playlist "Recently Played" was causing the issue. there was only one item in that itunes playlist. it was a movie. not sure why it caused the endless loop. I deleted the "Recently Played" list and itunes helper now runs to completion.
I am sure it has to do with a movie I played on my ipad recently.

Mostly likely you have a playlist that is causing the helper to go into a endless loop also.

Kevin
Reply
#4
kfly Wrote:I just checked my system and my Itunes helper was in an endless loop also. I put the itunes disk repository in verbose log level High and it appears a new Playlist "Recently Played" was causing the issue. there was only one item in that itunes playlist. it was a movie. not sure why it caused the endless loop. I deleted the "Recently Played" list and itunes helper now runs to completion.
I am sure it has to do with a movie I played on my ipad recently.

Mostly likely you have a playlist that is causing the helper to go into a endless loop also.

Kevin
Can you post the log so I can see if there is something I can do to the helper to prevent the issue?
Mark Stega
Reply
#5
log dump:

01/14 22:15:04-HomeAuto, CQCServer, iTunes_DBLoadThread
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.532, Status/App Status
Got nak response from tray app while waiting for end. Moniker=iTunes
System.InvalidCastException: Unable to cast COM object of type 'iTunesLib.iTunesAppClass' to interface type 'iTunesLib.IiTunes'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{9DD6680B-3EDC-40DB-A771-E6FE4832E34A}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).
}
01/14 22:15:08-HomeAuto, CQCServer, CQCDrv_iTunes_Thread7
{
CQCKit, CQCKit_DriverBase.cpp.2734, Status/App Status
Driver 'iTunes' is trying to load its configuration
}
01/14 22:15:08-HomeAuto, CQCServer, CQCDrv_iTunes_Thread7
{
CQCMedia, iTunesRepo2S_DriverImpl.cpp.350, Status/App Status
The media repository load failed. Driver=iTunes
}
01/14 22:15:13-HomeAuto, CQCServer, CQCDrv_iTunes_Thread7
{
CQCKit, CQCKit_DriverBase.cpp.2734, Status/App Status
Driver 'iTunes' is trying to load its configuration
}
01/14 22:15:13-HomeAuto, CQCServer, CQCDrv_iTunes_Thread7
{
CQCMedia, iTunesRepo2S_DriverImpl.cpp.431, Status/App Status
Starting load of media repository from C:\Program Files\CQC\CQCData\Server\Data\iTunesRepo2\TrayDump_iTunes\
}
01/14 22:15:13-HomeAuto, CQCServer, CQCDrv_iTunes_Thread7
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.227, Status/App Status
Starting database load
}
01/14 22:15:13-HomeAuto, CQCServer, iTunes_DBLoadThread
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.384, Status/App Status
Attempting to contact tray app at 192.168.1.103:13600
}
01/14 22:15:13-HomeAuto, CQCServer, iTunes_DBLoadThread
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.417, Status/App Status
Request for file generation sent. Waiting for reply. Moniker=iTunes
}
01/14 22:15:13-HomeAuto, CQCServer, iTunes_DBLoadThread
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.483, Status/App Status
Got start reply, waiting for end reply. Moniker=iTunes
}
01/14 22:15:14-HomeAuto, CQCServer, iTunes_DBLoadThread
{
iTunesRepo2S, iTunesRepo2S_DBLoader.cpp.532, Status/App Status
Got nak response from tray app while waiting for end. Moniker=iTunes
System.InvalidCastException: Unable to cast COM object of type 'iTunesLib.iTunesAppClass' to interface type 'iTunesLib.IiTunes'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{9DD6680B-3EDC-40DB-A771-E6FE4832E34A}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).
}
Reply
#6
Quote:Got nak response from tray app while waiting for end. Moniker=iTunes
System.InvalidCastException: Unable to cast COM object of type 'iTunesLib.iTunesAppClass' to interface type 'iTunesLib.IiTunes'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{9DD6680B-3EDC-40DB-A771-E6FE4832E34A}' failed due to the following error: No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).
To me this says that your installation of iTunes is somehow corrupt since I have the same version and can invoke the COM object. You can try removing/reinstalling iTunes but if that doesn't work something is likely hosed in the registry and you are facing a system rebuild. Do you have another nachine that has iTunes where you could at least temporarily try the helper app?
Mark Stega
Reply
#7
The iTunes driver is now working with the tray app again. Here is the summary of what happened in case it is of help troubleshooting a smiliar problem for someone else:
  • I installed itunes 10.1.1 and lost the ability for the tray app to communication to itunes per the previous posts and log dump
  • Unistalling and reinstalling both itunes and the tray app did not resolve anything
  • I updraded to the latest 10.1.2 version of itunes today and it is working normally again now
  • The original 10.1.1 upgrade and the subsequent reinstalls were all done through remote desktop - I logged in directly to the machine for the 10.1.2 upgrade install. I have no idea if this is just coincidence but figured it was worth noting
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  iTunes Setup barbourm 12 4,164 01-12-2020, 06:01 PM
Last Post: Dean Roddey
  removing itunes indygreg 1 1,466 05-14-2018, 04:09 PM
Last Post: Dean Roddey
  itunes error every 5 seconds indygreg 3 3,054 01-03-2017, 03:45 PM
Last Post: Dean Roddey
  Anyone have a iTunes playlist browser already created? Sendero 34 13,626 01-28-2013, 04:42 PM
Last Post: Trioxide
  Itunes Control?? NightLight 31 14,180 09-03-2011, 05:12 AM
Last Post: DaveB
  iTunes Errors aerodoc 14 5,522 03-04-2010, 04:47 PM
Last Post: DaveB
  ITunes Driver eded9698 1 1,837 10-24-2009, 04:02 PM
Last Post: Dean Roddey
  Itunes Repo and Album Artwork BOTTOM LINE The Camper 2 2,101 03-04-2009, 07:06 PM
Last Post: Dean Roddey
  Music Repository (and iTunes) again froop 16 5,883 10-31-2008, 12:06 PM
Last Post: froop
  iTunes coverart Trioxide 6 2,698 03-19-2008, 10:21 AM
Last Post: robertmee

Forum Jump:


Users browsing this thread: 1 Guest(s)