Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 7 64 bit new install fails
Hi Dean,
I run into problems trying to install 3.3 on a brand new Windows 7 64 bit system.
I want to install the master server on this machine, and I point the install to live at c:\cqc
However, the install fails.
I have attached the errorinf file

Thanks for looking into this.

Attached Files
.txt   CQCInst_1272.ErrorInf.txt (Size: 1.1 KB / Downloads: 8)
I get that on occasion too but it has nothing to do with Windows 7, or CQC v3, I have had it for a long time on and off.

When I get that I delete the SavedInstall and TempNewDir, reboot and reinstall. There is some process somewhere that is still accessing a file so CQC's installer can't get rid of the old directory.
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]
There's nothing in the installer that's accessing it. But it seems that some folks have anti-virus stuff or something like that, which will immediately jump into newly created directories and start poking around. So it makes it impossible to delete or rename them. But the installer has to do so in order to complete. The installer was updated to retry the operation a few times, pausing in between, but if the other process stays in that directory, there's nothing that can be done.

It's kind of screwed up, and they shouldn't be doing that, but there's nothing I can do to stop them. I may have to change how the installer works. The problem is that it doesn't want to overwrite what's you already have, so that it can be gotten back to. So it creates a new set of directories. Only after they are checked and look good does it then swap the old and new directories. So the originals are untouched and can be put back if needed. It could do something like that create a new dated and version stamped directory for each new version, but that would break any short cuts every time.

I guess perhaps it'll have to create a backup directory, copy everything to there, then just overwrite the existing directory. The downside of that of course is that the current scheme also makes sure that you always get brand new files every time, so no old files can accumulate over time.
Dean Roddey
Explorans limites defectum
Here is what I think is/was happening:
Windows 64 bit new install, updates applied
Windows security Essenstials downloaded and installed.
CQC 3.3 downloaded and expanded to c:\temp
Started installing for new install with all default directories. Got error message.
Retried once, twice. Same result.
Fourth install, directed it to install to c:\cqc instead of c:\program files (x86)\cqc Got error and reported it to this forum.
When I try to delete c:\cqc it is in use. Download process explorer and find out that CqcAppShell.exe and all server programs are running, blocking access to C:\cqc But the program is not installed (or it does not show up under the Windows start button)
Cannot delete proccess (rights issue) Delete as many files in c:\cqc as allowed. Restarted.
Now the processes are not running, and I can delete c:\cqc
Reinstalled , here are the steps as I am doing them:
New install, agree, to c:\cqc
Select all, install master server here,
accept all defaults
add logic server, scheduler, master server,....
Installation status: WORKED

Once an install goes wrong towards the end, it is likely to screw up subsequent installs, because it locks required directories.
Remedy: FOR NEW INSTALLS only, delete as much stuff as you can from the install directory, reboot and start over.
or as wuench said:
Quote:When I get that I delete the SavedInstall and TempNewDir, reboot and reinstall. There is some process somewhere that is still accessing a file so CQC's installer can't get rid of the old directory.

So Dean you were right, except the process locking the directory is CQC...

Onwards with the show
You are talking about two different things. The error that happened was something that prevented an installation to complete. That wasn't an issue with C:\CQC but with the temporary directory that the installer created, which has nothing running in it or using it as a current directory. But if you are upgrading an existing system, then CQC would still be running, and that would of course keep you from deleting the CQC directory until you stopped the service.
Dean Roddey
Explorans limites defectum
I was not trying to upgrade CQC.
But if you run CQC install after a failed install, apparently in the background you are 'upgrading' a previously failed install.
When the cqc folder was blocked, I never had a start button entry that refers to CQC programs.
I guess the install process starts the server before the shortcuts in the start button are made, and that last process is where the rename went wrong, aborting the install.
Maybe I should have just rebooted after the aborted install, and reinstalled. It probably would all have been good.
It couldn't possibly be running CQC if that original error you reported had occured, because it couldn't have ever gotten that far. So there would have had to be another install attempt that did get there, or perhaps a previous install that was not stopped and removed before you tried the new one. The original error you reported was that it couldn't swap the new install directory. So if it was truely a new install, it couldn't have ever started the servers because they never got moved to their final location.

So something more complicated had to have happened there.
Dean Roddey
Explorans limites defectum
Sorry for bringing up an old thread, but I was having the same issues. Windows 7, x64, new install, just MSE on the box and it would error out.

What I ended up doing was going into MSE and adding c:\program files(x86)\cqc\ to the list of excluded directories.

I tried again and it worked great. I guess MSE was trying to scan the directory or something. Maybe this will help someone down the road.
Yeh, that was my suspicion that something was opening the directory. What is MSE? Whatever it is, it's not a nice person. Anyway, the installer will now retry the operation a few times, with a pause in between, to avoid these types of issues.
Dean Roddey
Explorans limites defectum
I am thinking maybe if you did a copy/delete instead of renaming the new directory people wouldn't run into these issues.
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]

Possibly Related Threads…
Thread Author Replies Views Last Post
  CQC and my Samsung windows tablet ellisr63 1 539 09-04-2021, 01:12 PM
Last Post: ellisr63
  Beware of Latest Windows 10 Update kblagron 10 4,538 09-13-2019, 12:33 PM
Last Post: Dean Roddey
  Abandoned Windows 10 for Windows 7 gReatAutomation 6 2,585 06-13-2019, 01:01 PM
Last Post: gReatAutomation
  Install Error []dll is missing ControlFreak 2 3,556 11-05-2017, 02:18 PM
Last Post: ControlFreak
  CQC fresh install kfly 12 7,579 10-07-2017, 04:51 PM
Last Post: Dean Roddey
  Anyone try a multi-site HA install using a VPN? IVB 17 12,066 09-06-2017, 01:18 AM
Last Post: NightLight
  MS Speech Platform configuration on Windows Server 2012 mbrown 3 4,042 08-30-2017, 09:34 AM
Last Post: Dean Roddey
  Playing Sonos Favourites fails with & symbols in the name NightLight 3 3,392 01-01-2017, 08:23 PM
Last Post: Dean Roddey
  Windows 10 no-go :( rtarver 56 21,211 09-14-2016, 09:38 AM
Last Post: Dean Roddey
  Windows 8.1 tablet options, February 2014 Mark Stega 38 19,381 11-12-2014, 07:51 AM
Last Post: Bal

Forum Jump:

Users browsing this thread: 1 Guest(s)