Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HTML help, please...
#1
The following is the HTML is get when I look at an Escient FP1's web GUI. I want to display the GUI in a smaller screen on a Samsung Q1. Before I waste too much time with this, am I correct that I would put in the width and height that I desire where zero's are currently listed, save it in Notepad, place that in my HTML root file and then point the interface to HASERVER/HTMLROOT/NewFile?

<html>
<head id='head'>
<script type='text/javascript' src='js/debug.js'></script>
<script type='text/javascript' src='js/class.js'></script>
<script type='text/javascript' src='js/callback.js'></script>
<script type='text/javascript' src='js/data_loader.js'></script>
<script type='text/javascript' src='js/data_queue.js'></script>
<script type='text/javascript' src='js/data_cache.js'></script>
<script type='text/javascript' src='js/event_map.js'></script>
<script type='text/javascript' src='js/global_event_handlers.js'></script>
<script type='text/javascript' src='js/state.js'></script>
<script type='text/javascript' src='js/index.js'></script>
<script type='text/javascript' src='js/index_item.js'></script>
<script type='text/javascript' src='js/album.js'></script>
<script type='text/javascript' src='js/radio.js'></script>
<script type='text/javascript' src='js/movie.js'></script>
<script type='text/javascript' src='js/setup_utilities_volumecontrol_rooms.js'></script>
<script type='text/javascript' src='js/uievents.js'></script>
<script type='text/javascript' src='js/top.js'></script>
<script type="text/javascript">
function handleResponse() {
alert('this function is called from server.html')
}
</script>
<link rel="stylesheet" href="stylesheets/common.php"
type="text/css"></link>
</head>
<body onload="init();" onunload="cleanup();"
id="body" bgcolor="000000" text="#FFFFFF" topmargin="0"
leftmargin="0"
style="background-color:BLACK;background-repeat: no-repeat; overflow:hidden;">
<iframe id='hidden' name='hidden' frameborder=0 width='0' height='0'></iframe>
<div id="main_area" >
</div>
</body>
</html>
Recovering (quasi) ex-professional integrator...wait...scratch that. I'm back in the field and should probably have my head examined...
HAI, UPB, Parasound, Global Cache GC100 and IR learner, DatalogDB, Barix Barionet (I need to buy another one of these!), Weather, RFID, Logic Server
Reply
#2
If you are wanting to do an indirect reference via your own HTML, then you'd access it through our web server. So you'd put it somewhere under the HTMLRoot directory, on a machine where the web server is running.

You'd then access it as "http://hostname/whatever.html", where hostname is the name of that machine where the web server is running, and whatever.html is the name of the file.
Dean Roddey
Explorans limites defectum
Reply
#3
Umm, I have saved the the Notepad file (.txt) in the HTMLRoot but, if I try to access it in IE with .html appended to the address, I get an error (Windows cannot find blah blah blah). If I append with .txt, it opens fine. How do I save a .txt as HTML if it isn't a file type option when doing the Save As?
Recovering (quasi) ex-professional integrator...wait...scratch that. I'm back in the field and should probably have my head examined...
HAI, UPB, Parasound, Global Cache GC100 and IR learner, DatalogDB, Barix Barionet (I need to buy another one of these!), Weather, RFID, Logic Server
Reply
#4
AnthonyZ Wrote:Umm, I have saved the the Notepad file (.txt) in the HTMLRoot but, if I try to access it in IE with .html appended to the address, I get an error (Windows cannot find blah blah blah). If I append with .txt, it opens fine. How do I save a .txt as HTML if it isn't a file type option when doing the Save As?

Go into My Computer, Tools, Folder Options, View tab and uncheck 'Hide extensions for known file types'.

You should now be able to rename the file so it has a .html extension directly in the Explorer.
Reply
#5
Thanks, jkish. Easy cheesy.
Recovering (quasi) ex-professional integrator...wait...scratch that. I'm back in the field and should probably have my head examined...
HAI, UPB, Parasound, Global Cache GC100 and IR learner, DatalogDB, Barix Barionet (I need to buy another one of these!), Weather, RFID, Logic Server
Reply
#6
OK, not so easy. I have changed the file to .html and that's great. The problem is that if I try to access from another machine ( http;//HASERVER/FP1.html ), I get an error message of the 404 type stating that it can't access the file. The same is true, if I try outside the IV and just try to open it in a browser on another machine. I've also pinged the machine named HASERVER and the connection is fine. Any ideas?
Recovering (quasi) ex-professional integrator...wait...scratch that. I'm back in the field and should probably have my head examined...
HAI, UPB, Parasound, Global Cache GC100 and IR learner, DatalogDB, Barix Barionet (I need to buy another one of these!), Weather, RFID, Logic Server
Reply
#7
AnthonyZ Wrote:OK, not so easy. I have changed the file to .html and that's great. The problem is that if I try to access from another machine ( http;//HASERVER/FP1.html ), I get an error message of the 404 type stating that it can't access the file. The same is true, if I try outside the IV and just try to open it in a browser on another machine. I've also pinged the machine named HASERVER and the connection is fine. Any ideas?

Is the semicolon above in the URL a typo? That should be http://...

CQC webserver installed? On port 80?
Reply
#8
It's a typo. Umm, I don't know about the webserver. I just don't remember and I haven't documented the install. Is there a way to check or am I better off uninstalling and then reinstalling CQC?
Recovering (quasi) ex-professional integrator...wait...scratch that. I'm back in the field and should probably have my head examined...
HAI, UPB, Parasound, Global Cache GC100 and IR learner, DatalogDB, Barix Barionet (I need to buy another one of these!), Weather, RFID, Logic Server
Reply
#9
AnthonyZ Wrote:It's a typo. Umm, I don't know about the webserver. I just don't remember and I haven't documented the install. Is there a way to check or am I better off uninstalling and then reinstalling CQC?

Not sure if there is an easy way to check or not.
Reply
#10
The only sure way I know of to tell is to reinstall the latest version on the server running the web server and select custom install rather than using the previous parameters. When you get to the web server, it'll have the server port and the web port.

Russ...
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  A Little HTML Help potts.mike 2 1,901 01-07-2015, 04:38 PM
Last Post: potts.mike
  Sending HTML commands to Blue Iris standon 2 5,382 06-28-2011, 09:05 AM
Last Post: Dean Roddey
  HTML Expert needed... hucker 2 1,976 05-12-2009, 06:12 PM
Last Post: hucker
  Html files not showing Trioxide 4 2,246 01-07-2009, 09:56 AM
Last Post: Trioxide
  Problem with Displaying html Files in htmlroot kblagron 7 3,133 09-12-2008, 03:23 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)