Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CQSL Audio Player
#1
Trying to access the CQSL Audio Player driver from 2 instances of the IV. The reason I am doing this is because I have the IV on the server but I also have a Nokia 770 RDP into the server. I want to be able to control the music from either the server or my Nokia. Therefore I setup both IVs, different templates, to use the same Audio Player driver. This way I can see what music is playing on either IV and can change it and you see the change on the other IV. I am doing this because CQC is playing the music via my AV Receiver and I am be downstairs at the server controlling it or outside using my Nokia listening through my wireless speakers.
Noticed that when I have my Nokia connect and open the IV that my music, which was playing before, stops. The counter keeps going like the music is playing but there is no output, thus no sound. Have tried several times with the same effect. I have to reboot my server, and as it is shutting down the audio comes back on and I hear the music playing, for it to work again.
Is there away to get this working the way I want?

Thanks
Reply
#2
I don't think that there's any way that would happen unless there was some OnLoad command in the template being loaded that stopped the playback, or perhaps changed the repository that the player is associated with. So check that first.
Dean Roddey
Explorans limites defectum
Reply
#3
Nope. Just tried again. Both IVs are showing the same song playing and in the same place, if I change songs it shows on both so I know that is working correctly. Just I am getting no sound. If I play a movie it works fine so I know the output on the server is good. So just a problem with the Audio Player driver and the 2 IVs running at the same time.
Dean, you are saying that it should work?
When I click Restart on my server it asks if I want to disconnect other users, when I do then the audio comes back, but you are already shutting down so can't do anything.
Reply
#4
Oh, I misunderstood your issue. I that the problem is that RDP sessions cause something to happen to the audio devices. I know that Mark saw this at one point and had to figure it out, but I forget the specifics of the issue. Someone else may be able to comment who has dealt with this. You didn't set up the audio player to use any 'default' audio device or anything, did you? The RDP thing might cause that to change. If so, try selecting the specific audio device.
Dean Roddey
Explorans limites defectum
Reply
#5
Yes, when I setup the driver there is the option of Target Audio Device and I selected the only option there, my audio card on the server that outputs to the AV Receiver. So that is fine. But you are saying the RDP changes that setting? If I RDP in and add another CQSL Audio Player driver through the RDP then the only option I get for the Target Audio Device is "Microsoft RDP Audio Driver (emulated)"
How do I change this so when I RDP in it does not change the settings? I looked at the OnLoad on the main template and nothing there would affect the audio.
Reply
#6
I don't remember the details. This isn't something I've ever had happen, but some other folks have. Hopefully Mark can comment tomorrow, since I know he had to deal with this. I'm assuming this is the issue, though it's always possible that it's not. But there's nothing at all that would cause the audio from stopping playing when you load the IV, other than commands issued due to an OnLoad. So if it's not that, it's got to be something like this.
Dean Roddey
Explorans limites defectum
Reply
#7
Okay I found the thread you are talking about
http://www.charmedquark.com/vb_forum/sho...hlight=rdp
So I was able to change the setting on another computer with Windows XP to leave the audio on the server and works fine. But I am using the Nokia 770 with the RDesktop command line version to RDP in and just followed the instructions provided by jkmonroe. So is there an option for audio in the command line?
Reply
#8
No idea about that one. You might do better to ask on that thread.
Dean Roddey
Explorans limites defectum
Reply
#9
Try this option and see if it works...

-r sound:remote

RDesktop Command Line Options
Wuench
My Home Theater/Automation Website

[THREAD=5957]BlueGlass CQC Config[/THREAD]
[THREAD=10624]Wuench's CQC Drivers[/THREAD]
Reply
#10
Nice find wuench , but I think he actually wants -r sound:off
Brian - a long time user that rarely messes with the system now
Other systems used:
SageTV w/ cablecard tuner & multiple extenders for viewing
BlueIris and IP cameras for CCTV
Incredible PBX for home phone
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Multiroom Audio Suggestions kblagron 4 4,235 08-17-2017, 03:21 PM
Last Post: znelbok
  Anyone doing TTS without lag in audio? IVB 5 3,658 05-15-2017, 12:22 PM
Last Post: Dean Roddey
  Marantz Network Audio Players cavalier240 7 4,777 11-10-2015, 07:15 PM
Last Post: jkmonroe
  BluRay Player? jkmonroe 7 4,059 06-30-2015, 04:22 PM
Last Post: jkmonroe
  Roku as media player with CQC media control bryanb 11 7,430 01-11-2015, 05:17 PM
Last Post: Dean Roddey
  Preferred whole house audio rtarver 24 11,089 05-14-2014, 06:32 PM
Last Post: jkish
  Need QCQ Controlled Audio Solution anogee 4 3,665 08-02-2013, 07:47 PM
Last Post: Dean Roddey
  Audio files not loading dman000000 17 8,960 07-12-2013, 05:38 PM
Last Post: dman000000
  roku as audio source IVB 2 2,327 01-22-2013, 11:19 AM
Last Post: IVB
  Best audio format??? rtarver 5 3,097 12-26-2012, 02:10 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)