Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't configure client PC through Admin client suddenly...
#1
I pulled up the admin client on the MS, and was going to configure some stuff on an attached PC, but it wasn't available as an option. I'm able to contact it over the network (tightvnc works).

Logging into that PC, I tried to pull up the Admin client, and it said:

An Error occured while loading persistent state,
Details were:
The CIDLib Configuration Server could not be contacted.

Any other things to try before I reboot or whatever else to fix it?
Reply
#2
Is the service running? Do you see the CIDCfgSrv program running there?
Dean Roddey
Explorans limites defectum
Reply
#3
Hitting CtrlAltDel, yep, it's listed there under Processes.

I'm running .20 on everything, btw.
Reply
#4
You may have slipped a disc on the firewall and it's being blocked or something.
Dean Roddey
Explorans limites defectum
Reply
#5
Not running a firewall, on the MS or the client PC.
Reply
#6
If you go to that machine and run the CQCNetTest, what happens?
Dean Roddey
Explorans limites defectum
Reply
#7
"bengals" is the main server
"media-pc" is the client I'm trying to configure, and is where I ran the net test


CQC Network Info Test
Copyright © Charmed Quark Systems


System Information
--------------------------------
OS Version: 5.1.2, Build: 2600
Node Name: media-pc
TCP Version: 2.2


Network Adaptor Information
--------------------------------
{56CF1F1E-CFDA-429A-B891-C47BDEF735FB}
NVIDIA nForce Networking Controller - Packet Scheduler Miniport
DHCP Enabled: True
Gateway/Mask: 192.168.0.20/0.0.0.0
Hardware Addr: 00 E0 4C DC 2E DA
Address/Mask #0: 192.168.0.5/255.255.255.0


Environment Information
--------------------------------
CID_NSADDR: bengals
CQC_DATADIR: C:\Program Files\CQC\CQCData


Name Resolution
--------------------------------
Trying to resolve name: media-pc...
Resolved to: 192.168.0.5

Resolving back the other way...
Host Name: media-pc


CQC Connection Tests
--------------------------------
Trying to connect to CQC name server...
Connected to name server successfully

Trying to connect to log server...
Connected to log server successfully

Trying to connect to Master Cfg Server...
Connected to Master Cfg Server successfully

Trying to connect to installation server...
Connected installation interface successfully

Trying to connect to security server...
Connected security interface successfully

Trying to connect to macro server...
Connected macro interface successfully

Trying to connect to CQCServer on host bengals
Connected CQCServer successfully

Trying to connect to CQCServer on host broncos
Connected CQCServer successfully


Server Statistics
--------------------------------

Stats For Process: Name Server
----------------------------
Running On: bengals
Up Since: Sun, Jun 08 18:33:27 2008 -0700
Client HWM: 18
Dropped Packets: 0
Cur Clients: 17
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 2
Worker Threads: 4
Targets: 0
Cmd Cache Sz: 0
Srv Cache Sz: 0
Wait List: 0


Stats For Process: Log Server
----------------------------
Running On: bengals
Up Since: Sun, Jun 08 18:33:27 2008 -0700
Client HWM: 13
Dropped Packets: 0
Cur Clients: 12
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 2
Worker Threads: 4
Targets: 0
Cmd Cache Sz: 1
Srv Cache Sz: 1
Wait List: 0


Stats For Process: Master Cfg Server
----------------------------
Running On: bengals
Up Since: Sun, Jun 08 18:33:27 2008 -0700
Client HWM: 3
Dropped Packets: 0
Cur Clients: 2
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 2
Worker Threads: 4
Targets: 0
Cmd Cache Sz: 2
Srv Cache Sz: 1
Wait List: 0


Stats For Process: Data Server
----------------------------
Running On: bengals
Up Since: Sun, Jun 08 18:33:28 2008 -0700
Client HWM: 4
Dropped Packets: 0
Cur Clients: 1
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 6
Worker Threads: 4
Targets: 1
Cmd Cache Sz: 2
Srv Cache Sz: 2
Wait List: 0


Stats For Process: Local Cfg Server
----------------------------
The program is not registered in the name server

Stats For Process: CQCServer on bengals
----------------------------
Running On: bengals
Up Since: Sun, Jun 08 18:33:28 2008 -0700
Client HWM: 1
Dropped Packets: 0
Cur Clients: 1
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 2
Worker Threads: 4
Targets: 1
Cmd Cache Sz: 2
Srv Cache Sz: 1
Wait List: 0


Stats For Process: CQCServer on broncos
----------------------------
Running On: broncos
Up Since: Sun, Jun 08 21:38:36 2008 -0700
Client HWM: 1
Dropped Packets: 0
Cur Clients: 1
Max Clients: 92
Active Cmds: 1
Queued Cmds: 0
Registered Objs: 2
Worker Threads: 4
Targets: 1
Cmd Cache Sz: 2
Srv Cache Sz: 1
Wait List: 0
Reply
#8
It appears that the problem is the other way, that the local configuration server on that machine cannot contact the master server and get itself registered.
Dean Roddey
Explorans limites defectum
Reply
#9
Ummm....ok. Soooo....now what?

I mean, I'm sure I could probably (hopefully!) fix this with a reboot, but I just wanted to leave it as-is for any troubleshooting you wanted to put it through. I didn't change any network configurations or anything else, and it was working fine previously....so this seems like random failure.
Reply
#10
Something is preventing the config server from contacting the MS. If you look in the Bin directory on that machine, is there any .LocalLog file from the config server? If so, zip it up and send it to me. Then you can kill it and see if it gets happy again.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Admin Interface Help Doesn't Work alexismtz13 1 178 04-28-2022, 01:14 PM
Last Post: Dean Roddey
  Variables Driver Client gReatAutomation 4 1,627 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  Problem with Accesssing Variables Driver Client Interface kblagron 5 2,026 03-05-2020, 02:24 PM
Last Post: kblagron
  Client side error dialog popping up xlurkr 3 1,655 01-04-2020, 04:01 PM
Last Post: xlurkr
  Simple device control from Admin Interface simplextech 7 3,041 01-04-2020, 12:18 PM
Last Post: simplextech
  Configure Elk Function Keys kblagron 2 1,389 12-29-2019, 11:30 PM
Last Post: kblagron
  ELK M1 Client Interface question lleo 1 1,298 06-12-2019, 08:15 AM
Last Post: Dean Roddey
  Admin interface and CML IDE interface issue lleo 5 2,966 01-11-2019, 03:07 PM
Last Post: Dean Roddey
  why master server needs DHCP client running? lleo 4 2,329 01-04-2019, 01:13 PM
Last Post: Dean Roddey
  Elk Client Interface Gremlins IVB 9 3,391 12-23-2018, 08:58 PM
Last Post: IVB

Forum Jump:


Users browsing this thread: 1 Guest(s)