Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Errors when loading admin interface after upgrading to 2.2
#1
I finally got around to upgrading to 2.2 after taking the summer off from automation. Everything seemed to go fine with the install, but I am getting some errors when trying to run the tools on the client PCs.

When trying to load the viewer, I get errors stating that some of the fields are not valid. I assumed that this was because I would need to reload some of the drivers (but I am not sure). When trying to load the admin interface, I get an error that states "An error occured while loading persistent state" (by the way Dean, occurred should have two 'r's :-D ) Under error details it says "The CIDLib Configuration Server could not be contacted".

Did one of the services not start up properly? When doing the initial test after the install it had no problem communicating with the main server.

Any help would be greatly appreciated.

Thanks,
Acropolis
Reply
#2
Does everything work fine on the main server and other clients, and it's just a problem on one client, or is it a problem on multiple clients?
Dean Roddey
Explorans limites defectum
Reply
#3
It works fine on the main server (although it gave me an error stating that it couldn't load the HAI OmniProII driver the first time I started it up and then it worked fine). The other two clients seem to be throwing the same error. I just noticed that it happens when loading any of the apps (interface viewer, admin interface, etc.). The interface viewer continues with errors, but still opens. The admin interface won't even open on the client computers.
Reply
#4
Open the CQC Command Prompt on a client and run "CQCNetTest > NT.Txt" and post the results.
Dean Roddey
Explorans limites defectum
Reply
#5
Are you sure it is not because of the new rule that monikers cannot have spaces or special chars in them?
That was a change that broke a lot of stuff.
Stephan
Reply
#6
That could be true. If you had any driver monikers with spaces or any punctuation other than hyphen or underscore, they would fail. That shouldn't have ever been allowed but somehow it snuck through. Most everyone just by default used just characters, but some folks got bitten because they had spaces in them. But that would only affect things like interfaces and actions. It wouldn't prevent any programs from starting up.
Dean Roddey
Explorans limites defectum
Reply
#7
stefand Wrote:Are you sure it is not because of the new rule that monikers cannot have spaces or special chars in them?
That was a change that broke a lot of stuff.

By habit I typically don't use spaces or punctuation, but I will double check that if I can't find anything else. I will run the command that Dean recommended when I get home tonight and see what happens.
Reply
#8
Dean Roddey Wrote:Open the CQC Command Prompt on a client and run "CQCNetTest > NT.Txt" and post the results.


OK, the first time I ran the test, it said "access denied". I then ran it again by selecting "run as administrator" and I got the following results:

Code:
CQC Network Info Test
Copyright (c) Charmed Quark Systems


System Information
--------------------------------
      OS Version: 6.0.0, Build: 6000
       Node Name: GRUMPY.chios.local
     TCP Version: 2.2


Network Adaptor Information
--------------------------------
  {9DAD2EB6-B5CC-49C2-A623-78E712E27A86}
  D-Link DGE-530T Gigabit Ethernet Adapter
    DHCP Enabled: True
    Gateway/Mask: 0.0.0.0/255.255.255.255
    Hardware Addr: 00 0F 3D F2 B3 86
    Address/Mask #0: 0.0.0.0/0.0.0.0

  {820BC6F8-7BEB-406E-AD3F-FA92CB1F4174}
  Intel(R) PRO/1000 CT Desktop Connection
    DHCP Enabled: True
    Gateway/Mask: 192.168.16.2/255.255.255.255
    Hardware Addr: 00 0D 61 03 C4 6F
    Address/Mask #0: 192.168.16.10/255.255.255.0


Environment Information
--------------------------------
      CID_NSADDR: SUPERMAN.chios.local
     CQC_DATADIR: C:\Program Files\CQC\CQCData


Name Resolution
--------------------------------
    Trying to resolve name: GRUMPY.chios.local...
    Resolved to: 192.168.16.10

    Resolving back the other way...
    Host Name: GRUMPY.chios.local


CQC Connection Tests
--------------------------------
    Trying to connect to CQC name server...
    Connected to name server successfully

    Trying to connect to log server...
    Connected to log server successfully

    Trying to connect to Master Cfg Server...
    Connected to Master Cfg Server successfully

    Trying to connect to installation server...
    Connected installation interface successfully

    Trying to connect to security server...
    Connected security interface successfully

    Trying to connect to macro server...
    Connected macro interface successfully

    Trying to connect to CQCServer on host superman.chios.local
    Connected CQCServer successfully


Server Statistics
--------------------------------

    Stats For Process: Name Server
    ----------------------------
           Running On: superman.chios.local
             Up Since: Tue, Oct 09 17:44:02 2007 -0400
           Client HWM: 9
      Dropped Packets: 0
          Cur Clients: 9
          Max Clients: 92
          Active Cmds: 1
          Queued Cmds: 0
      Registered Objs: 2
       Worker Threads: 4
              Targets: 0
         Cmd Cache Sz: 0
         Srv Cache Sz: 0
            Wait List: 0


    Stats For Process: Log Server
    ----------------------------
           Running On: superman.chios.local
             Up Since: Tue, Oct 09 17:44:02 2007 -0400
           Client HWM: 7
      Dropped Packets: 0
          Cur Clients: 7
          Max Clients: 92
          Active Cmds: 1
          Queued Cmds: 0
      Registered Objs: 2
       Worker Threads: 4
              Targets: 0
         Cmd Cache Sz: 1
         Srv Cache Sz: 1
            Wait List: 0


    Stats For Process: Master Cfg Server
    ----------------------------
    The program is not registered in the name server

    Stats For Process: Data Server
    ----------------------------
           Running On: superman.chios.local
             Up Since: Tue, Oct 09 17:44:15 2007 -0400
           Client HWM: 4
      Dropped Packets: 0
          Cur Clients: 1
          Max Clients: 92
          Active Cmds: 1
          Queued Cmds: 0
      Registered Objs: 6
       Worker Threads: 4
              Targets: 1
         Cmd Cache Sz: 2
         Srv Cache Sz: 2
            Wait List: 0


    Stats For Process: Local Cfg Server
    ----------------------------
    The program is not registered in the name server

    Stats For Process: CQCServer on superman.chios.local
    ----------------------------
           Running On: superman.chios.local
             Up Since: Tue, Oct 09 17:44:15 2007 -0400
           Client HWM: 1
      Dropped Packets: 0
          Cur Clients: 1
          Max Clients: 92
          Active Cmds: 1
          Queued Cmds: 0
      Registered Objs: 2
       Worker Threads: 4
              Targets: 1
         Cmd Cache Sz: 2
         Srv Cache Sz: 1
            Wait List: 0
Reply
#9
Something strange is definitely going on. In the initial basic connection tests it claims it connected OK to everyone. But in the stats gathering phase, it says it cannot talk to either configuration server. That's pretty bizarre, because they aren't registered in the name server.

If you look on that client and on the master server, do you see a CIDCfgSrv.exe program in the task list?
Dean Roddey
Explorans limites defectum
Reply
#10
Dean,

I may have figured part of it out. I tested it on an XP machine that is running a flat panel and the admin interface loads fine. I wonder if the issue is because I didn't load CQC on the Vista machine by running the install file as admin. It may not have had the proper permissions to rgister the machine. I don't know what kind of check it does after the install, but it still would see the server on the network.

Just a guess. Unfortunately, I can't do any tinkering on the Vista machine right now because my monitor died tonight. I will check the main server (not Vista) and let you know if that file is runnning.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Upgrading to 6.0.2 znelbok 1 790 12-11-2021, 08:04 AM
Last Post: Dean Roddey
  How to size Interface Viewer WebRIVA templates gReatAutomation 5 2,350 12-24-2019, 05:29 PM
Last Post: Dean Roddey
  Upgrading to 5.x cost? Deane Johnson 1 1,842 12-11-2017, 11:05 AM
Last Post: Dean Roddey
  Interface Viewer Hardware MikeW 10 8,979 01-02-2017, 12:42 PM
Last Post: NightLight
  Template errors after upgrade to 4.8.3 avtexan 4 3,049 08-13-2016, 11:29 PM
Last Post: avtexan
  IV Admin Screens, or my latest stupidly complex idea IVB 0 1,966 07-26-2016, 05:56 PM
Last Post: IVB
  Why I hate upgrading znelbok 13 5,437 01-03-2016, 02:22 PM
Last Post: Dean Roddey
  Upgrading to 4.7.1 - License Key???? Deane Johnson 5 3,278 05-25-2015, 11:07 AM
Last Post: Dean Roddey
  Thermostat Interface - Gestures jokermac 8 5,485 08-05-2014, 09:40 AM
Last Post: dgage
  GC-100 not accepting changes through web interface Dean Roddey 6 4,470 07-16-2014, 10:40 AM
Last Post: standon

Forum Jump:


Users browsing this thread: 1 Guest(s)