Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Driver to Support Dynamic stringlists for Vertical and Horizontal List Browsers
#21
I am at work, so I may not get this perfect, but I will look when I get home:

DECLARE @PN varchar(10)

SELECT @PN = CAST(CAST(phonenum_col AS Int) AS varchar(10)) FROM tblTable

SELECT '(' + LEFT(@PN, 3) + ')' + SUBSTRING(@PN, 4, 3) + '-' + RIGHT(@PN, 4) AS fmtPN

There are probably a lot of othe ways to do it, but this was off the top of my head and gives you a formated output. I'll try it in Query Analyzer tonight to be sure it is right.

Edit: Updated to be correct
Reply
#22
Hey Mikla

Thanks for the reply - based on your help and a little bit of Google-ing, I got it working.

Thanks again

Joe
Reply
#23
thanks Mikla...i just checked in. didn't mean to put anyone off.

let me know if you have any more sql q's. Sounds like Mikla has you pretty well covered.
~~~ B01nk
Reply
#24
Since CQC no longer runs on WIN2K, I had to rebuild my master server with XP in order to upgrade CQC.

I moved the 2.4 version of CQC (haven't upgraded to 3.0 yet because I wanted to make sure every got moved properly) and everything is working on the new MS server except for this driver (which worked fine before).

The new MS has WIN XP and SQL Server 2008, compared to WIN2K and SQL Server 2005 on the old MS. I converted the database from SQL Server 2005 and created the ODBC connection, but the ListBuilder driver won't connect. The driver state stays at "Wait for Comm Resource" and putting the driver in verbose mode shows the following messages over and over:

Code:
08/01 08:32:53-appserver2, CQCServer, CQCDrv_dbSACD_Thread32
{
    CQCKit, CQCKit_DriverBase.cpp.2474, Status/App Status
    Driver 'dbSACD' is trying to get its comm resource
}
08/01 08:32:53-appserver2, CQCServer, CQCDrv_dbSACD_Thread32
{
    CQCKit, MEng.System.CQC.Runtime.CQCLogger.1545, Status/App Status
    ListBuilder: Could not connect to CQC-ODBC. Error=The database connection has already been made
}

"dbSACD" is the driver moniker and "CQC-ODBC" is the System DSN.

The last part of the error message is confusing me - it looks like it's saying it can't complete the ODBC connection because it already connected.

Any thought/ideas/assistance?

Thanks

Joe
Reply
#25
i've seen this before with different versions of SQL and ODBC drivers.

1) what version of SQL are you using?
2) is SQL installed on the same box on CQC?
3) are you using the SQL Native client for the ODBC connection?
~~~ B01nk
Reply
#26
1 - SQL Server 2008 Express, downloaded from http://www.microsoft.com/express/default.aspx

2 - Yes

3 - I think yes. I'm on the road, so not positive about this one, but it seems to me when I set up the ODBC connection there were 2 drivers to chose from. The first said simply "SQL Server" and the second said something like "SQL Native Client version 10" or something like that. I'm pretty sure I used the latter. Should I use the former?


Thanks for your help.

Joe
Reply
#27
Quote:3 - I think yes. I'm on the road, so not positive about this one, but it seems to me when I set up the ODBC connection there were 2 drivers to chose from. The first said simply "SQL Server" and the second said something like "SQL Native Client version 10" or something like that. I'm pretty sure I used the latter. Should I use the former?

The SQL Native Client would be the correct client to use. One thing to check is that you have your SQL install setup to allow remote connections...even if it's on the same pc. i've had this bite me in the rear a few times. Other items to check would be permissions. i typically have the CQC service run as a dedicated account, this account has access to the SQL server databases - this has eliminated 95% of any connectivity issues i've had between CQC and SQL servers.

let me know if this helps??
~~~ B01nk
Reply
#28
pseigler

I changed the CQC service to run as a dedicated account and everything is working great again.

Thanks for your help.

Joe
Reply
#29
Wonderful. Glad I could help
~~~ B01nk
Reply
#30
I'm trying to get this driver working but I am getting the same, "

I've made CQC log in to a dedicated user, given that new user Admin privledges. I have also configured the SQL remote access per these instructions.

I am running the database on my CQC Server machine (which happens to be a Windows Home Server machine). It is SQL Server 2005.

I am a complete database moron, so start from the beginning with any advice. But I have the database up and running and logging data which I am running querys on and graphing stuff.

Any help would be appreciated.

Thanks!
Brian - a long time user that rarely messes with the system now
Other systems used:
SageTV w/ cablecard tuner & multiple extenders for viewing
BlueIris and IP cameras for CCTV
Incredible PBX for home phone
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RainMachine Sprinkler Irrigation Controller Driver kblagron 50 2,358 06-01-2020, 01:18 PM
Last Post: Dean Roddey
  Russound MCA-66 on TCP driver lapointe.sc@gmail.com 5 96 05-24-2020, 06:23 AM
Last Post: gReatAutomation
  Samsung SmartTV Driver George M 0 39 05-20-2020, 09:04 AM
Last Post: George M
  OpenWeatherMap Weather Driver Using OneCall API kblagron 11 205 05-18-2020, 04:09 AM
Last Post: dlmorgan999
  Tesla Driver Driver kfly 10 739 05-08-2020, 08:49 AM
Last Post: gReatAutomation
  JVC D-ILA Driver jokermac 34 3,914 04-13-2020, 01:28 AM
Last Post: Mark Stega
  LIFX Driver bobskie708 15 5,863 01-05-2020, 11:00 AM
Last Post: simplextech
  Philips Hue V2 - Group and Scene Support simplextech 2 365 01-03-2020, 06:36 PM
Last Post: simplextech
  Universal Devices ISY Insteon Driver wuench 369 174,103 12-28-2019, 05:15 PM
Last Post: simplextech
  RunTimer2 driver rbroders 18 7,599 10-17-2019, 04:38 PM
Last Post: rbroders

Forum Jump:


Users browsing this thread: 1 Guest(s)