Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ExecApp Action Failing
I am trying to use the ExecApp Action command from a button in one of my templates and am getting the error:
10/30 19:17:46-CQC-MasterPC, CQCIntfView, MainThread
    CQCKit, CQCIntfEng_ActEngine.cpp.726, Failed/Cannot Do, Error: 770/0/0
    An unknown exception occured during command processing. Offending cmd was:

    System::ExecApp(C:\\Program Files\\CQC\\Helpe..., , , Show)
      <CQCIntfView> CQCIntfEng_ActEngine.cpp - 742
      <CQCIntfView> CQCIntfEng_View.cpp - 6132

Command used is:

    P1=C:\\Program Files\\CQC\\Helper Apps\\autohotkey\\click midleftcam.exe

I have a feeling this is a bug that was introduced somewhere after 5.4.0. I use this for a Halloween thing so only noticing the issue now unfortunately.  I was able to roll back to that earlier version in a VM image to test quickly and the same action works there just fine. Hoping this can be looked into and validated by someone else on 6.0.x to start. 

If it is in fact a defect I am not sure if any fixes are yet to come with CQC or not but if so perhaps it could be looked at and corrected sometime down the line.  

Wondering if this has something to do with this issue I reported earlier as well and if so could maybe be fixed at the same time.
and the potential root of that issue.  After reading again now I am not so sure that is related or not.
-Mike G
Is the name of that program actually 'click midleftcame.exe'? Or is click a program and midleftcam.exe a parameter to it?
Dean Roddey
Explorans limites defectum
(10-31-2021, 02:43 PM)Dean Roddey Wrote: Is the name of that program actually 'click midleftcame.exe'? Or is click a program and midleftcam.exe a parameter to it?
Yep, that's the actual name of the .exe or Program name -'click midleftcam.exe'.  I tried another program that didn't have such a strange name with a space in it and had the same outcome.  

I also just tried with a totally bogus name of just c:\\  and the same thing happens so it appears it's not even getting to the point of trying to find and run the .exe perhaps.
-Mike G

Possibly Related Threads…
Thread Author Replies Views Last Post
  Variable Action "Find" command or alternate Shaky 3 784 11-02-2021, 08:19 PM
Last Post: Shaky
  6.0.0 Interface Viewer - Action Trace Mark Stega 1 828 03-09-2021, 06:39 PM
Last Post: Dean Roddey
  ClickPLC driver now failing after upgrade znelbok 2 1,223 09-21-2020, 10:48 PM
Last Post: znelbok
  Escaping Character in Action Parameters gReatAutomation 0 744 09-02-2020, 05:51 AM
Last Post: gReatAutomation
  Action wait and exit if variable changes simplextech 8 3,261 02-01-2020, 12:35 PM
Last Post: simplextech
  [FEATURE] Event Run Action simplextech 4 2,677 01-09-2020, 02:04 PM
Last Post: simplextech
  Can't Find a Couple of Documented Action Commands kblagron 7 4,214 10-02-2018, 05:47 PM
Last Post: kblagron
  Create Global Action from IV? jkmonroe 3 2,528 12-30-2017, 12:04 PM
Last Post: Dean Roddey
  ExecApp and .bat simon 15 7,105 11-16-2017, 06:27 PM
Last Post: Dean Roddey
  High Level Triggers and Action rules admin screen kfly 1 2,235 11-01-2017, 05:21 PM
Last Post: Dean Roddey

Forum Jump:

Users browsing this thread: 1 Guest(s)