Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Log Message
#1
Hi 

My logs are filling up with "Some fields of this driver got no initial values. Up to the first 8 are displayed". (An entry for each of my sonos speakers)

Is there any way to get rid of this message?

Thanks
Karen
Reply
#2
(09-13-2021, 03:04 AM)karenlee Wrote: Hi 

My logs are filling up with "Some fields of this driver got no initial values. Up to the first 8 are displayed". (An entry for each of my sonos speakers)

Is there any way to get rid of this message?

Thanks
Karen
Hi Karen,

This is what happens any time the driver is reset or restarted.  I get them from time to time on a few, but only on startup for the Sonos drivers (I use both of them).  I have learned to ignore them other than possibly a warning sign of something not right if the driver is resetting often.

Blake
Reply
#3
They are just a diagnostic, to make it known that some fields are not getting set initially on startup, so that over time they can be found and updated. it won't hurt anything per se, but it does leave them not representative of the state of the device until such time as they get a value set.

If you are seeing a lot, as Blake indicated, then the driver is cycling for some reason.
Dean Roddey
Explorans limites defectum
Reply
#4
(09-18-2021, 04:54 PM)Dean Roddey Wrote: They are just a diagnostic, to make it known that some fields are not getting set initially on startup, so that over time they can be found and updated. it won't hurt anything per se, but it does leave them not representative of the state of the device until such time as they get a value set.

If you are seeing a lot, as Blake indicated, then the driver is cycling for some reason.

I've never seen them before the last CQC update - only since I upgraded.  Is there any way to stop them?  I have around 10 speakers, so it fills up my log file and makes it hard to see real issues.
Reply
#5
I'd have to update the driver to give those fields initial values. But, the real issue is that the driver is cycling. That can't be good, and if that is fixed then the other issue isn't really important, though it would be good to fix that as well.

Are there any log msgs that would indicate why it might be cycling? What version are you running?
Dean Roddey
Explorans limites defectum
Reply
#6
Thumbs Up 
(10-23-2021, 09:56 AM)Dean Roddey Wrote: I'd have to update the driver to give those fields initial values. But, the real issue is that the driver is cycling. That can't be good, and if that is fixed then the other issue isn't really important, though it would be good to fix that as well.

Are there any log msgs that would indicate why it might be cycling? What version are you running?


Fixed with version 6.0.7   Smile Heart
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Amazon AWS Message kblagron 1 139 10-16-2021, 03:49 PM
Last Post: Dean Roddey
  Sonos Zone Player - Win10 zra 9 2,725 09-26-2019, 10:00 AM
Last Post: zra
  SONOS Driver Question gReatAutomation 13 4,561 08-23-2019, 12:37 PM
Last Post: Dean Roddey
  Sonos - PlayFovorite command NightLight 22 5,670 05-10-2019, 09:32 PM
Last Post: kblagron
  Sonos batwater 4 1,700 01-24-2019, 05:20 AM
Last Post: batwater
  Sonos Update Error (Again) karenlee 39 12,034 12-04-2018, 10:15 PM
Last Post: Dean Roddey
  Sonos PlayFavorites kblagron 8 3,484 10-22-2018, 08:46 PM
Last Post: Dean Roddey
Big Grin A Big Thanks on my 1000th Forum Message kblagron 1 1,297 09-12-2018, 10:35 PM
Last Post: Dean Roddey
  Sonos Driver zra 3 2,127 09-01-2018, 03:09 PM
Last Post: Dean Roddey
  Sonos stops after CQC restart batwater 1 1,488 05-18-2018, 10:12 AM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)