Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
WebRiva will not render graphics
#11
(09-05-2020, 03:22 PM)Dean Roddey Wrote: Do you have the transparency up high in the widget image settings maybe?
The base background images are without any transparency settings while the overlays have some transparency. Will the entire display fail to render is any of the image contains transparent elements? I have attached a pdf of the before and after.


Attached Files
.pdf   IV render.pdf (Size: 366.73 KB / Downloads: 5)
Reply
#12
No, it's just that Windows requires that images that have alpha transparency be pre-multiplied, i.e. the pixel values pre-reduced by the alpha transparency. That inludes the per-pixel alpha plus any constant alpha (the slider in the CQC image settings.) It's not practical to do that multiplication every time the image is displayed, so it's pre-multiplied up front and cached for reuse. That's what I send to WebRIVA, but it doesn't expect them to be pre-multiplied so it will double the transparency. Mostly that's not noticeable, but if you have the constant alpha slider way up, it may end up so lightened that it doesn't appear to be there.

That's something that needs to be dealt with, but the only practical way is probably to cache both the pre-multiplied and original versions of the image in memory, which could be a bit heavy.
Dean Roddey
Explorans limites defectum
Reply
#13
How big is that background image? It's not by any chance some huge images way bigger than is required for the display size is it? If so, WebRIVA may be choking on it. If that's the case, try pre-sizing it to the actual size required for the template itself. Mostly it looks like everything is OK except the background image.
Dean Roddey
Explorans limites defectum
Reply
#14
(09-06-2020, 07:16 AM)Dean Roddey Wrote: How big is that background image? It's not by any chance some huge images way bigger than is required for the display size is it? If so, WebRIVA may be choking on it. If that's the case, try pre-sizing it to the actual size required for the template itself.  Mostly it looks like everything is OK except the background image.

It appears the image is 1280 x 720. Way to big most likely as I get the same results when I test that image. Can you go into admin interface(images) and set image size to 960 x 540? to see if that works?
Thanks
Kevin
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#15
(09-06-2020, 11:03 AM)kfly Wrote:
(09-06-2020, 07:16 AM)Dean Roddey Wrote: How big is that background image? It's not by any chance some huge images way bigger than is required for the display size is it? If so, WebRIVA may be choking on it. If that's the case, try pre-sizing it to the actual size required for the template itself.  Mostly it looks like everything is OK except the background image.

It appears the image is 1280 x 720. Way to big most likely as I get the same results when I test that image. Can you go into admin interface(images) and set image size to 960 x 540? to see if that works?
Thanks
Kevin
Also use the nocach option on webriva for testing to save yourself some headaches. if you are not doing that  already.

/cqsl/webriva/index.html?user=ipad&nocache=1&pw=XXXXXXX
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#16
(09-06-2020, 11:06 AM)kfly Wrote:
(09-06-2020, 11:03 AM)kfly Wrote:
(09-06-2020, 07:16 AM)Dean Roddey Wrote: How big is that background image? It's not by any chance some huge images way bigger than is required for the display size is it? If so, WebRIVA may be choking on it. If that's the case, try pre-sizing it to the actual size required for the template itself.  Mostly it looks like everything is OK except the background image.

It appears the image is 1280 x 720. Way to big most likely as I get the same results when I test that image. Can you go into admin interface(images) and set image size to 960 x 540? to see if that works?
Thanks
Kevin
Also use the nocach option on webriva for testing to save yourself some headaches. if you are not doing that  already.

/cqsl/webriva/index.html?user=ipad&nocache=1&pw=XXXXXXX

----------------------------------------------------------------------------------------

The image is configured as 1024 X 768. The 1280 X 720 resolution from the pdf would result from my upscaling the screen capture before resizing to maintain image clarity, but I did reduce the size to 720 X 540 and it worked. Thank you !! 

The  960 X 540 resolution created a really distorted looking image for an iPad.

Is it normal for the fonts to change as well?  Strangely the fonts are correct on some of the screens  If that is the only thing I cannot correct it is a marked improvement from where I was.  

Thanks again for all the help
Reply
#17
You should try to stick to fonts that either on both platforms, or ones that you can install on the phone. What fonts are you using?
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  WebRiva add to home screen fix NishanF 2 573 11-16-2020, 08:54 AM
Last Post: sic0048
  With webriva, anyway to get an embedded browser window? ghurty 1 482 04-26-2020, 04:43 PM
Last Post: Dean Roddey
  WebRIVA on iOS dlmorgan999 14 1,991 04-26-2020, 04:08 PM
Last Post: dlmorgan999
  Check Box widget on WebRIVA vs Interface Viewer bryanb 1 527 04-23-2020, 06:15 AM
Last Post: bryanb
  CQC WebRIVA and BlueIris in a secure environment bryanb 2 563 03-23-2020, 03:24 AM
Last Post: bryanb
  WebRIVA Splash Screen gReatAutomation 4 981 03-02-2020, 05:15 PM
Last Post: gReatAutomation
  Phone/WebRIVA Login/Security Alternatives? gReatAutomation 14 3,062 01-27-2020, 05:19 AM
Last Post: gReatAutomation
  Changing WebRIVA Splash Image? gReatAutomation 4 1,132 01-07-2020, 05:28 PM
Last Post: gReatAutomation
  IOS Homescreen Webriva fails to connect zra 5 1,720 10-05-2019, 12:26 PM
Last Post: zra
  WebRIVA and Cameras on iOS gReatAutomation 5 1,365 07-25-2019, 01:31 PM
Last Post: bryanb

Forum Jump:


Users browsing this thread: 1 Guest(s)