Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
PurpleAir ??
#1
Has anyone used the PurpleAir driver successfully?

I created the .json file and the driver appears to be reading it.
But it is not working. The log says "no child with the name A_H" was found. (A is what I called my sensor in cqc, I presume A_H is humidity). But the driver is not getting values for ANY fields. 

I know the PurpleAir sensor itself is working and I can use PA's http call that returns json to see that the data is up to date. The sensor also shows data on their map as usual.

One question: does the name of the sensor (in the cqc .json file) need to match the name of the sensor (its "label" in PurpleAir) as it is configured in PurpleAir? Or is getting the id numbers sufficient and the cqc sensor name can be arbitrary?

Any tips from those who have used it would be great.
Reply
#2
It looks like the driver doc page indicates the form of the URL. So try hitting that with a browser and see what you get back

https://www.charmedquark.com/Web2/CQCDoc...=PurpleAir
Dean Roddey
Explorans limites defectum
Reply
#3
I did. I included that link in my email to you last night with my sensorID filled in.
It is a lot of json. I can see:
* it is live/current
* various values from sensor A
"humidity":"60","temp_f":"90","pressure":"1008.95" .... "PM2_5Value":"12.31" (and other pm values as well, "pm=particulate matter")
Then it has various PM values for sensor B (the child sensor)
So, not sure what you would have me look at.
Thanks.
Reply
#4
OH, for some reason I was thinking that was your configuration file. Ah... there was a link further down. It looks like perhaps they changed the format. I'll have to see what the driver is looking for. Clearly there is no H_A value in there.
Dean Roddey
Explorans limites defectum
Reply
#5
(08-20-2020, 07:20 AM)Dean Roddey Wrote: OH, for some reason I was thinking that was your configuration file. Ah... there was a link further down. It looks like perhaps they changed the format. I'll have to see what the driver is looking for. Clearly there is no H_A value in there.
Looks like documentation of the fields/objects is here:
https://www2.purpleair.com/community/faq...ect-fields
Reply
#6
Any progress on this?
Reply
#7
I'm still working on getting myself back to a functional system for the open source release. I'm getting there. Hopefully it won't be much longer. I'm starting to bring up the servers and making sure that they are finding what they need in the new regime.
Dean Roddey
Explorans limites defectum
Reply
#8
oh. ok. thanks.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)