Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Continued Issues - RadioRA2 Thermo
#1
I am having continued issues with the RadioRA2 driver, specifically with the thermostat. It will work for a couple of days, then when I try to change the set points via my IV, I see an error code in the logs and ???? in the IV. I also cannot change the set point values in the driver screen itself.

Updates to the set points on the thermo itself show up on the driver and I can change the mode (Cool, Heat) from the driver itself or from the IV. I can also change the fan to on or off from the driver or from the IV.

Issue is with setting/reading set points from the driver or IV.

Code:
02/28 09:17:47-CQC, CQCServer, CQCDrv_RadioRA2Thread22
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.2398, Status/App Status
    Error in Int fld write: Lutron Error. Code=4
}
Reply
#2
Now, all the sudden, I can again change the set points. Very intermittent and it somehow fixes itself.
Reply
#3
The 4 is from the Lutron system, and it means parameter out of range. So it didn't like something we sent presumably. I'll update the driver to dump the outgoing msg to the log if it gets an error response from the Lutron controller, so we can see exactly what got sent.
Dean Roddey
Explorans limites defectum
Reply
#4
(02-28-2020, 01:25 PM)Dean Roddey Wrote: The 4 is from the Lutron system, and it means parameter out of range. So it didn't like something we sent presumably. I'll update the driver to dump the outgoing msg to the log if it gets an error response from the Lutron controller, so we can see exactly what got sent.

great thanks
Reply
#5
Give this one a try. Import it, then reconfigure to pick up the changes. Any Int fields that are rejected will log the outgoing msg text.


Attached Files
.cqcdrvpack   RadioRA2_LogRejectedMsgs.CQCDrvPack (Size: 40.21 KB / Downloads: 1)
Dean Roddey
Explorans limites defectum
Reply
#6
Thanks Dean. I tried, was able to get the error again but nothing different is in the logs.

Code:
02/29 10:10:24-CQC, CQCServer, CQCDrv_RadioRA2Thread22
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.2405, Status/App Status
    Error in Int fld write: Lutron Error. Code=4
}
Reply
#7
You reconfigured the driver after importing it? I can't imagine how it couldn't log the new message if you got the above.
Dean Roddey
Explorans limites defectum
Reply
#8
Re-imported, reconfigured, and bounced CQC services, set verbosity to high. Replicated error code and no additional logs.
Reply
#9
OK, I guess I must be looking for it in the wrong place. Try this one...


Attached Files
.cqcdrvpack   RadioRA2_LogRejectedMsgs2.CQCDrvPack (Size: 40.21 KB / Downloads: 1)
Dean Roddey
Explorans limites defectum
Reply
#10
(03-01-2020, 06:45 AM)Dean Roddey Wrote: OK, I guess I must be looking for it in the wrong place. Try this one...

Tried this one. As things usually work, now I can set the set points with no problem. I'll keep testing it until I get the error.

Attached are what shows in the logs when setting a set point.

Interestingly, when I add my thermo, I gave it 06:00 as the Addr because that is the Zone ID for the thermostat from Lutron integration file. Below, looks like its calling 06:02?

Code:
03/01 09:59:48-CQC, CQCServer, CQCDrv_RadioRA2Thread22
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.2394, Status/App Status
    Msg rejected. Text=#HVAC, 6, 2, 78, 79
}
03/01 09:59:51-CQC, CQCServer, CQCDrv_RadioRA2Thread22
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.2394, Status/App Status
    Msg rejected. Text=#HVAC, 6, 2, 77, 79
}
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  RadioRA2 & WaitDriverReady gReatAutomation 2 204 04-02-2020, 03:42 PM
Last Post: gReatAutomation
  RadioRA2 Triggers gReatAutomation 3 250 03-25-2020, 05:11 PM
Last Post: Dean Roddey
  Lutron RadioRA2 Driver and Lutron Visor Control gReatAutomation 29 4,240 03-19-2020, 01:03 PM
Last Post: gReatAutomation
  RadioRA2 Visor Control Receiver - Input support gReatAutomation 12 1,237 02-24-2020, 07:38 AM
Last Post: gReatAutomation
  Issues after Acronis True image clone Ron Haley 4 441 02-14-2020, 03:44 PM
Last Post: Dean Roddey
  Possible Bug - Lutron RadioRA2 Driver and Thermostat gReatAutomation 39 4,503 11-13-2019, 03:57 PM
Last Post: Dean Roddey
  ZWave Issues / Aeotec gReatAutomation 16 2,190 07-26-2019, 06:21 PM
Last Post: Dean Roddey
  SOLVED: VLC dll Issues with CQC Interface Template Viewer gReatAutomation 3 888 06-17-2019, 06:17 AM
Last Post: gReatAutomation
  Lutron Caseta & Zwave Issues dangerlong 191 46,238 12-19-2018, 06:40 PM
Last Post: tom
  Echo Config file issues ghurty 6 2,530 07-08-2018, 07:13 PM
Last Post: ghurty

Forum Jump:


Users browsing this thread: 1 Guest(s)