Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Possible Bug - Lutron RadioRA2 Driver and Thermostat
#1
Dean is there a way to trouble shoot the Lutron RadioRA2 driver and how it interprets data from the Lutron RadioRA2 LR-HWLV-HVAC thermostat?

From the documentation:

Quote:CurMode - String R/W Get or set the current 'set' mode for the thermostat (e.g. heat, cool, auto heat, auto cool, etc...) The field limits will indicate the available modes that can be set.
FanMode - String R/W Get or set the current 'set' fan mode for the thermostat (off, on, auto, etc...) The field limits will indicate the available modes that can be set.
FanOpMode - String R The actual operating fan mode of the thermostat. The field limits will indicate the possible modes.
OpMode - String R The actual operating mode of the thermostat. The field limits will indicate the possible modes.

So, currently, my unit is not running but is set to Cool with fan in Auto position. You can see that the FanOpMode and OpMode are set to the same thing as the CurMode and FanMode.

FanOpMode should read Idle and OpMode should read Off because the unit is not running.

[Image: Screen-Shot-2019-09-27-at-22-31-56.jpg]
Reply
#2
Field dump:


Quote:<CQCFldDef Name='THERM#HallwayThermostat~CurMode' Type='MEng.String' SType='Generic' Access='ReadWrite'
            Private='No' AlwaysWrite='No' QueuedWrite='No' FldValue='Cool'>
        Enum: Off, Heat, Cool, Auto, EmHeat
    </CQCFldDef>
    <CQCFldDef Name='THERM#HallwayThermostat~OpMode' Type='MEng.String' SType='Generic' Access='Read'
            Private='No' AlwaysWrite='No' QueuedWrite='No' FldValue='Cool'>
        Enum: Off, Heat, Cool, Auto, EmHeat
    </CQCFldDef>
    <CQCFldDef Name='THERM#HallwayThermostat~FanMode' Type='MEng.String' SType='Generic' Access='ReadWrite'
            Private='No' AlwaysWrite='No' QueuedWrite='No' FldValue='Auto'>
        Enum: Auto, On
    </CQCFldDef>
    <CQCFldDef Name='THERM#HallwayThermostat~FanOpMode' Type='MEng.String' SType='Generic' Access='Read'
            Private='No' AlwaysWrite='No' QueuedWrite='No' FldValue='Auto'>
        Enum: Auto, On
</CQCFldDef>
Reply
#3
I have a RA2 test setup with a thermo, so I can try it and see what I get. It might be Monday before I can look at it. I'm in major rearrangement mode right now. I'm sending this from my tablet since the only functional bit at the moment.
Dean Roddey
Explorans limites defectum
Reply
#4
Sure no problem. Please let me know if you need any help.
Reply
#5
Whew... I'm finally back up again. I've got some more work to do, but I'll try to look at it tonight. Else tomorrow.
Dean Roddey
Explorans limites defectum
Reply
#6
(09-29-2019, 01:38 PM)Dean Roddey Wrote: Whew... I'm finally back up again. I've got some more work to do, but I'll try to look at it tonight. Else tomorrow.

No problem  Big Grin
Reply
#7
Somehow the Lutron thermo got removed from the power supply that it was connected to for testing. I'm going to have to find that and figure out how to wire it back up again.
Dean Roddey
Explorans limites defectum
Reply
#8
(10-01-2019, 01:47 PM)Dean Roddey Wrote: Somehow the Lutron thermo got removed from the power supply that it was connected to for testing. I'm going to have to find that and figure out how to wire it back up again.

No problem.
Reply
#9
OK, I found what must be the right power supply. It's 24V and has just bare wire at the end. Anyone know right off hand which of the thermo terminals the +/- power goes to? I don't think I had anything else hooked up before.
Dean Roddey
Explorans limites defectum
Reply
#10
(10-02-2019, 01:22 PM)Dean Roddey Wrote: OK, I found what must be the right power supply. It's 24V and has just bare wire at the end. Anyone know right off hand which of the thermo terminals the +/- power goes to? I don't think I had anything else hooked up before.
Are you sure is 24V DC? Most HVAC stuff is 24V AC, so polarity does not matter
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  920 Beta Bug - Lutron Thermostat gReatAutomation 5 541 02-12-2021, 06:13 AM
Last Post: gReatAutomation
  Was the issue with Lutron Radio RA2 not updating ever fixed? ghurty 3 774 12-06-2020, 11:42 AM
Last Post: gReatAutomation
  Lutron Caseta Add Fan and Shade Controllers bryanb 1 589 11-29-2020, 10:16 AM
Last Post: Dean Roddey
  ClickPLC driver now failing after upgrade znelbok 2 593 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 1,348 08-02-2020, 11:29 PM
Last Post: kblagron
  Marantz receiver driver (IP) dlmorgan999 6 1,387 05-15-2020, 03:32 PM
Last Post: dlmorgan999
  Lutron Caseta Occupancy Sensor bryanb 14 2,654 04-26-2020, 08:59 AM
Last Post: bryanb
  Variables Driver Client gReatAutomation 4 1,080 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  RadioRA2 & WaitDriverReady gReatAutomation 2 639 04-02-2020, 03:42 PM
Last Post: gReatAutomation
  RadioRA2 Triggers gReatAutomation 3 729 03-25-2020, 05:11 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)