Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Zone Player - Win10
#1
Hi Dean, 

I'm trying to install this on a new win10 VM. It finds the Sonos device(Connect), but the driver never connects. It ramps up the CPU utilization to 90% continuously too. The machine is virtually unusable until I pause the driver. 

I've turned off the firewall. When I installed the CQC device support and admin interface on this machine I couldn't use the FQDN for the master server, so I used the IP instead and that worked(I've always used the FQDN in the past). That was unusual, but nothing else seems off. 

Have there been any issues along these lines that you are familiar with? 

Im on 5.3.1 btw.
Reply
#2
(09-25-2019, 08:29 AM)zra Wrote: Hi Dean, 

I'm trying to install this on a new win10 VM. It finds the Sonos device(Connect), but the driver never connects. It ramps up the CPU utilization to 90% continuously too. The machine is virtually unusable until I pause the driver. 

I've turned off the firewall. When I installed the CQC device support and admin interface on this machine I couldn't use the FQDN for the master server, so I used the IP instead and that worked(I've always used the FQDN in the past). That was unusual, but nothing else seems off. 

Have there been any issues along these lines that you are familiar with? 

Im on 5.3.1 btw.
09/25 10:32:39-Sonos, CQCServer, CIDOrbSrvWorkThread_4
{
    CQCServer, CQCServer_DriverCtrl.cpp.202, Status/App Status
    A request to resume driver Audio3 was received, starting operation
}
09/25 10:32:40-Sonos, CQCServer, CQCDrv_Audio3Thread11
{
    CQCKit, CQCDriver_DriverBase.cpp.3682, Status/App Status
    Driver 'Audio3' is beginning initialization
}
09/25 10:32:40-Sonos, CQCServer, CQCDrv_Audio3Thread11
{
    CQCKit, CQCDriver_DriverBase.cpp.3829, Status/App Status
    Driver 'Audio3' is trying to get its comm resource
}
09/25 10:32:40-Sonos, CQCServer, CQCDrv_Audio3Thread11
{
    CIDUPnP, CIDUPnP_Device.cpp.412, Failed/Cannot Do, Error: 102/13/0
    Could not get service 'urn:upnp-orgConfusederviceIdBig GrineviceProperties' of UPnP device '10.0.1.102 - Sonos Connect'
      <CQCServer> SonosZPPropS_DriverImpl.cpp - 271
}
09/25 10:32:45-Sonos, CQCServer, CQCDrv_Audio3Thread11
{
    CQCKit, CQCDriver_DriverBase.cpp.3829, Status/App Status
    Driver 'Audio3' is trying to get its comm resource
}
Reply
#3
A little while back they changed their UPnP interface yet again, which broke us and we had to update the UPnP stuff to adapt to that. So that's most likely what you are seeing.
Dean Roddey
Explorans limites defectum
Reply
#4
(09-25-2019, 12:49 PM)Dean Roddey Wrote: A little while back they changed their UPnP interface yet again, which broke us and we had to update the UPnP stuff to adapt to that. So that's most likely what you are seeing.

Do I need to upgrade or are we still waiting?
Reply
#5
(09-25-2019, 12:49 PM)Dean Roddey Wrote: A little while back they changed their UPnP interface yet again, which broke us and we had to update the UPnP stuff to adapt to that. So that's most likely what you are seeing.

Wondering here. I have this Sonos Connect. It works with the IOS app, but at minimum I would like a way to tell CQC that it's playing. I was previously doing this with the Event system. But that was when the driver worked. Any solution that you can think of?
Reply
#6
Not without upgrading. We can't put a bunch of conditional stuff all over the UPnP system for this or that product really. The issue is the Windows UPnP stack, which we depend on (one of the few things that would be possible to do ourselves that we don't yet) is fairly twitchy. They probably test with everything but Windows applications that use the Windows UPnP stack, so they make regularly breaking changes. We've already had to take over some of the UPnP functionality to get over previous such things, but the last one isn't really doable that way.
Dean Roddey
Explorans limites defectum
Reply
#7
And so that I'm clear, you mean upgrading the Sonos connect or upgrading CQC?
Reply
#8
(09-25-2019, 11:42 PM)zra Wrote: And so that I'm clear, you mean upgrading the Sonos connect or upgrading CQC?

He's saying you need to upgrade your instance of CQC to get the latest changes which would, from reading in to his posts, fix your SONOS issue.
Reply
#9
I am on what I think are the latest released versions:

CQC 5.4.0
Sonos 10.4
Windows 10, Version 1903 (64 bit) 

and my Sonos Connect and CQC control are working fine.
Reply
#10
Thanks to everyone for the feedback.

Now I just need to figure out how to upgrade from 5.3.1 to 5.4
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  SONOS Driver Question gReatAutomation 13 465 08-23-2019, 12:37 PM
Last Post: Dean Roddey
  Sonos - PlayFovorite command NightLight 22 1,492 05-10-2019, 09:32 PM
Last Post: kblagron
  Sonos batwater 4 783 01-24-2019, 05:20 AM
Last Post: batwater
  Sonos Update Error (Again) karenlee 39 4,915 12-04-2018, 10:15 PM
Last Post: Dean Roddey
  Sonos PlayFavorites kblagron 8 1,488 10-22-2018, 08:46 PM
Last Post: Dean Roddey
  Sonos Driver zra 3 1,211 09-01-2018, 03:09 PM
Last Post: Dean Roddey
  Sonos stops after CQC restart batwater 1 802 05-18-2018, 10:12 AM
Last Post: Dean Roddey
  Sonos Driver with Sonos Connect Amp zra 5 1,865 05-05-2018, 09:43 AM
Last Post: Dean Roddey
  Help with CQC 3.3 on Win10 znelbok 1 603 05-02-2018, 06:19 PM
Last Post: Dean Roddey
  Sonos Drivers kjaerligkatt 66 14,884 02-15-2018, 06:06 PM
Last Post: jkmonroe

Forum Jump:


Users browsing this thread: 1 Guest(s)