Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Write Failed / ZWave
#1
Hey Dean, been getting a lot of these errors as of late:


[Image: Screen-Shot-2019-09-02-at-09-24-10.jpg]

[Image: Screen-Shot-2019-09-02-at-09-24-03.jpg]
Reply
#2
That is a mystery as to why those happen. Others see them as well, though not as often. The Z-Stick is creating a virtual comm port via USB and the driver talks to it through that. Sometimes the writes to it just return this error, but there's no port error bits set. The driver will reset the serial port and keep trying. In all of the cases above it looks like that was successful since it doesn't happen again for at least some minutes.

It may be that you have unresponsive (or badly responding) units that are backing up outgoing traffic and maybe we are overrunning the serial ports buffers or something, but there's not really any useful information to diagnose it.

Maybe try looking in the Windows event viewer and see if there's anything there related to a com port write failure that provides some lower level info. Probably not, but it's worth a look.
Dean Roddey
Explorans limites defectum
Reply
#3
+1.. get them also a couple times a day with my Aeotec. Does not seem to cause any real issue but probably an indication of some kind of problem.

I have tried everything but no clue what is causing. (changed from front to back USB ports,Longer usb cable)
I have a Dell OptiPlex 3020 minitower(win 10 pro)


09/01 18:43:35-CQC-PC, CQCServer, ZWIOThreadZ-Stick
{
    CIDComm, CIDComm_Port.cpp.209, Failed/Lost Connection, Error: 5013/147/121
    Write failed on /Local/COM8. Port Err: {None}
    The semaphore timeout period has expired.
      <CQCServer> ZWaveUSB3S_ZStick.cpp - 1760

}
09/01 18:43:35-CQC-PC, CQCServer, ZWIOThreadZ-Stick
{
    ZWaveUSB3S, ZWaveUSB3S_ZStick.cpp.1785, Failed/App Status
    An exception occurred in the I/O thread, restarting it
    State: WaitAck, MsgId: 19, TarId: 9, MsgBytes: 9, Out CC/Cmd: 0x26/2, CCBytes: 2
}
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#4
What does your zwave network look like. 
Maybe there is one type of device(or quantity) that is causing a hiccup:
See anything in common? Any locks?

Display Name,Type
Back Door Lock,Z-Wave Lock
Back Porch Light,Z-Wave Switch Generic
Backyard Security,Z-Wave Switch Generic
Bedroom Outside,Z-Wave Dimmer Switch Generic
Bedroom Reading,Z-Wave Dimmer Switch Generic
Dining Room Blinds,Z-Wave Dimmer Switch Generic
Elk M1,Z-Wave Remote
Fibaro Flood Sensor,Fibaro Flood Sensor
FibaroRGBW,Fibaro RGBW Controller
Fish Tank Light,Z-Wave Switch Generic
Fish Tank Moon Light,Z-Wave Switch Generic
Foyer,Z-Wave Switch Generic
Front Door Lock,Z-Wave Lock
Front Porch Light,Z-Wave Switch Generic
Garage Lights,Z-Wave Switch Generic
Jacksons Room,Z-Wave Switch Generic
Kayleys Room,Z-Wave Switch Generic
Landscape Lights,Z-Wave Switch Generic
Liv Rm Inside,Z-Wave Dimmer Switch Generic
Liv Rm Outside,Z-Wave Dimmer Switch Generic
Liv Rm Wall Left,Z-Wave Switch Generic
Liv Rm Wall Right,Z-Wave Switch Generic
Living Room,LAN Sonos Player
Living Room Blinds,Z-Wave Dimmer Switch Generic
Living room wall switch,Leviton VRCZ4-M0Z Zone Controller
Master Bedroom,LAN Sonos Player
Repeater Gameroom,Z-Wave Range Extender
Repeater Hallway,Z-Wave Range Extender
Repeater Living Room,Z-Wave Range Extender
Window Blinds,Z-Wave Controller
Z-Wave Controller,Z-Wave Controller
Z-Wave Controller zwp,Z-Wave Controller
Z-Wave Device,Z-Wave Device
_______________
Denon 3808ci, 2112ci ,Sonos, NoVo Grand Concerto, Z-Wave(Lights,Locks), Hue, SmartThings,
iPads,Tivo,Hikvision,Elk-M1,TED5000,Somfy RTS blinds+ZRTSI, Amazon Echos+Dots, Polk XRT12,
Honeywell Wi-Fi 9000, Caleo Wi-Fi Thermostats, Rainmachine
Reply
#5
(09-02-2019, 05:49 AM)kfly Wrote: 09/01 18:43:35-CQC-PC, CQCServer, ZWIOThreadZ-Stick
{
    CIDComm, CIDComm_Port.cpp.209, Failed/Lost Connection, Error: 5013/147/121
    Write failed on /Local/COM8. Port Err: {None}
    The semaphore timeout period has expired.
      <CQCServer> ZWaveUSB3S_ZStick.cpp - 1760

}
09/01 18:43:35-CQC-PC, CQCServer, ZWIOThreadZ-Stick
{
    ZWaveUSB3S, ZWaveUSB3S_ZStick.cpp.1785, Failed/App Status
    An exception occurred in the I/O thread, restarting it
    State: WaitAck, MsgId: 19, TarId: 9, MsgBytes: 9, Out CC/Cmd: 0x26/2, CCBytes: 2
}

At least that one has some useful info. The semaphore timeout expired thing is indicating that the comm port driver didn't get some response (presumably from the underlying hardware) and gave up. It's a generic error common to Windows device drivers in general, nothing serial port specific. My guess is that something at the Z-Wave network level is making the stick stop processing for some period of time and the serial port driver times out.

Maybe I can look at upping the timeouts on the serial port a bit and see if it helps, but you don't want to get crazy with that stuff since it will make things unresponsive in a bad way. Better to just timeout and restart beyond a certain reasonable point.
Dean Roddey
Explorans limites defectum
Reply
#6
One side effect is that I have a couple of counters that key off of a couple of my ZWave devices. Every time this error occurs, the counters resets, rendering them useless.
Reply
#7
For that, it shouldn't knock the driver offline or anything. It just resets the serial port, AFAIK, all within the Z-Stick I/O thread, so the driver shouldn't know or care as long as it recovers OK. Though maybe if it takes too long the driver sees it's not responding or something of that sort.
Dean Roddey
Explorans limites defectum
Reply
#8
(09-02-2019, 11:21 AM)Dean Roddey Wrote: ...it just resets the serial port, AFAIK, all within the Z-Stick I/O thread..Though maybe if it takes too long..

Any way we can confirm? This seems like a bug.
Reply
#9
Let me first bump the Z-Stick's internal timeouts a bit. Or maybe it needs to be the opposite, to have it give up faster on non-responsive units. I'll have to see what it's set to currently and we can play with adjusting that.

But ultimately the error is from the serial port driver, not from our Z-Wave driver, so the bug may not be in our territory. Here is someone reporting a similar issue under OpenHAB:
https://community.openhab.org/t/zwaveser...rors/15532

Quote:Error 0x79 at src/windows/termios.c(1323): The semaphore timeout period has expWrite action failed! Input/output error
(Repeats periodically in the console)

I'd found some other products reporting it before when it first showed up though I'm not having any luck finding them now.

Of course one step would be to try to get back up with the least amount of loss possible. I thought it was doing that but maybe not always.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Please add Somfy ZRTSI to zwave models kfly 15 361 11-24-2019, 03:37 PM
Last Post: kfly
  Zwave lock battery level indicator on Field Checkbox kfly 4 299 09-07-2019, 05:34 AM
Last Post: kfly
  Clear out all previous ZWave info gReatAutomation 3 243 08-01-2019, 02:00 PM
Last Post: Dean Roddey
  ZWave Issues / Aeotec gReatAutomation 16 795 07-26-2019, 06:21 PM
Last Post: Dean Roddey
  Zwave / Remove unused devices? gReatAutomation 2 196 07-25-2019, 02:27 PM
Last Post: gReatAutomation
  Going from Zwave to Lutron, worth it and what to do about the lock? ghurty 6 934 12-29-2018, 10:55 AM
Last Post: dogman
  Lutron Caseta & Zwave Issues dangerlong 191 39,523 12-19-2018, 06:40 PM
Last Post: tom
  How to update the new zwave stick/driver? ghurty 5 1,113 11-22-2018, 06:56 PM
Last Post: Dean Roddey
  Aeotec USB stick, existing zWave (v3) driver? IVB 3 1,510 03-05-2018, 08:57 PM
Last Post: znelbok
  ISY and Zwave potts.mike 46 13,050 02-08-2018, 04:27 PM
Last Post: IVB

Forum Jump:


Users browsing this thread: 1 Guest(s)