Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Moving the CQSL server
#1
So the data center where our current server is hosted is getting shut down, and we are sort of being forced marched to another one, which means setting up another system from scratch. It's not all bad I guess since we moved up to server 2016 and IIS 8 and MySQL 8 and the latest PHP and all that. And this machine has more memory than the current one, which tends to get a bit overwhelmed during Windows Updates.

I've made a couple attempts at the forum transfer, well about four now. For whatever reason, some posts have some text encoding issues (you'll see strange characters sometimes.) I have no idea why and I need to just get it back on line for now and worry about that later.
Dean Roddey
Explorans limites defectum
Reply
#2
The forums is back open, though there are still some quirks. I moved over the original content and imported the database again, so we are back to the original version of the forum software, which is in sync with the database again now.

But, we still get some strange character encoding issues sometimes. I'll try to figure out why that is, but for now I'm pretty sure we are safe in terms of moving forward since it's the original contents and database now.

Any posts that were made yesterday or earlier today were whacked. Sorry about that, but it needed to be done.
Dean Roddey
Explorans limites defectum
Reply
#3
I forgot how much I missed my days working in front and back end web development.
Reply
#4
It looks like MyBB isn't fully compatible with the latest PHP version, so that may 'splain some issues. I may have to back it down to V7.0 which I think is the latest version that MyBB is known compatible with.
Dean Roddey
Explorans limites defectum
Reply
#5
I've updated PHP to 7.1, which seems to be a supported version and it's the oldest one that's on the active list on the PHP site. Had a few scary moments there but finally got it working. So let's see how it does.
Dean Roddey
Explorans limites defectum
Reply
#6
I am getting a huge amount of warnings at the top of every page - using Firefox.
Chrome does not produce the warnings.

Warning [2] A non-numeric value encountered - Line: 499 - File: C:\inetpub\wwwroot\vb_forums\inc\functions.php PHP 7.1.29 (WINNT)
File Line Function
C:\inetpub\wwwroot\vb_forums\inc\functions.php 499 errorHandler->error
C:\inetpub\wwwroot\vb_forums\global.php 461 my_date
C:\inetpub\wwwroot\vb_forums\showthread.php 26 require_once
Warning [2] A non-numeric value encountered - Line: 499 - File: C:\inetpub\wwwroot\vb_forums\inc\functions.php PHP 7.1.29 (WINNT)
Mykel Koblenz
Illawarra Smart Home
Reply
#7
That's related to the compatibility issue as I understand it. You might try flushing Firefox's cache and restarting it and see if that helps,
in case you are getting mixed contents.
Dean Roddey
Explorans limites defectum
Reply
#8
It's working here for me in both browsers...
Dean Roddey
Explorans limites defectum
Reply
#9
I guess my next festival of pain needs to be upgrading the MyBB software to the latest version. The version we are running may actually have some issues with PHP 7.1, whereas the latest is supposed to be OK with it. I'll try to that tomorrow. Some day, somehow, we'll get it working again. I should send my ISP a bill for the hours and and mental anguish involved in this.
Dean Roddey
Explorans limites defectum
Reply
#10
We may have had some e-mail issues as well. So if anyone has sent me any e-mails over the last few days and I didn't respond, send them again.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Migrating to New Server gReatAutomation 1 612 06-12-2020, 05:40 PM
Last Post: Dean Roddey
  Global Variables in the Event Server context lleo 1 716 05-16-2020, 11:21 AM
Last Post: Dean Roddey
  Is there a way to change the listening port for the CQC server? ghurty 3 800 04-23-2020, 05:54 PM
Last Post: Dean Roddey
  Hosted CQC server - Latency zra 4 1,434 01-06-2020, 05:24 AM
Last Post: zra
  CQC Server Closing Connection gReatAutomation 1 871 12-19-2019, 01:53 PM
Last Post: Dean Roddey
  SubSonic Media Server API Support? gReatAutomation 4 1,871 06-16-2019, 02:45 PM
Last Post: gReatAutomation
  Logic Server not sending triggered events znelbok 7 2,693 05-08-2019, 08:13 AM
Last Post: Dean Roddey
  Files of type "Logic Server config" cannot be edited chmilar 2 1,489 04-06-2019, 11:53 AM
Last Post: chmilar
  why master server needs DHCP client running? lleo 4 1,956 01-04-2019, 01:13 PM
Last Post: Dean Roddey
  Moving MS question IVB 15 3,965 12-08-2018, 10:43 PM
Last Post: IVB

Forum Jump:


Users browsing this thread: 1 Guest(s)