Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Generic-Network Monitor - Config File Error
Trying to get the Network Monitor installed with the netmon.xml file located at

C:\Program Files (x86)\CQC\CQCData\MacroFileRoot

Trying to select the folder using the ... results in an error

[Image: Screen-Shot-2019-06-27-at-08-51-34.jpg]

If I copy/paste the location into the text box, it allows the entry.

[Image: Screen-Shot-2019-06-27-at-08-56-22.jpg]
I forgot to add that the documentation is pretty poor in terms of how to write the config file.

There is an older thread about the network monitor that has a documentation page that is much more robust and detailed. This should be included in the official documentation if it is the most current.
Looks like this is how you are supposed to enter the XML file path as the path:

Ok, can someone please post how to format this file?

[Image: Screen-Shot-2019-06-27-at-09-16-04.jpg]

The existing documentation only notes the sections but now how to




But not how to format the higher level root of the file:

ugh. this is getting extremely tiring:

[Image: Screen-Shot-2019-06-27-at-09-33-12.jpg]

What would be the time and cost investment in revamping the entire documentation set so that people can use it to perform initial install and configuration of all features? In some cases you cannot properly configure a driver with the documentation. My current issue is a good example.

Be happy to help in this area.
and more errors attempting to get the path correct:

[Image: Screen-Shot-2019-06-27-at-13-29-44.jpg]

Can anyone shed light on how to get this path working correctly? I've tried many variations.
So I removed the driver and installed it again so I could show everyone the path that the driver itself displays when you are configuring for the first time which is confusing because the path shown does not exist and conflicts with the path explained in the documentation with no mention of how to format the path or if you need to include the file name: [cqc]\CQCData\MacroFileRoot\

[Image: Screen-Shot-2019-06-27-at-13-55-26.jpg]
This is a third party driver, so the docs were provided by the writer of the driver. That's the pros and cons of third party drivers. You get more drivers, but maybe the docs aren't as complete and they can get behind.

For the file, CML code cannot access anything other than files under


So a path of \ points to that top level CML file directory. A path of \Drivers\Network_Monitor\netmon.xml means that the actual Windows level file would be:


Be careful about how you create files down there in the program files area. If you don't do it with a text editor that is running in admin mode, then you end up not actually creating a file there, it gets vectored to some per-user account area magically. So right click on a command window and run as admin. Then change to the right directory, from above, and see if the file is actually there.

If so, then we can worry about the actual format of it. If not, then it got vectored elsewhere. You can just run notepad from that admin style command window and create the file and save it and that should then show up there where it is supposed to.
Dean Roddey
Explorans limites defectum
I'm not sure what the actual top level XML element is. I'll look at the driver code here in a minute when I have a working system again and see if I can figure it out from there.

There is a little XML parser program that comes with CQC, which will do a basic syntax check so that you can at least be sure it's valid XML. Or you could open with a web browser and most of those will validate it and display it if it's legal.

That way, if you still get complaints it has to be about the contents and not the basic XML syntax, which is fairly easy to get wrong.
Dean Roddey
Explorans limites defectum
(06-27-2019, 10:33 AM)Dean Roddey Wrote: This is a third party driver, so the docs were provided by the writer of the driver.

I installed this driver from CQC, I did not install the one in that thread. The official CQC documentation for the driver, below, is here: http://IP_ADDRESS/Web2/CQCDocs/CQCDocs.html?topic=/Reference/Drivers/Network&page=/NetworkMonitor

[Image: Screen-Shot-2019-06-27-at-14-42-28.jpg]

Possibly Related Threads…
Thread Author Replies Views Last Post
  Event Server Error Bugman 4 439 06-05-2022, 08:54 AM
Last Post: Bugman
  Help with Log File Error karenlee 4 777 10-28-2021, 08:17 AM
Last Post: Dean Roddey
  Template scaling error NishanF 1 961 11-10-2020, 03:21 PM
Last Post: NishanF
  Camera Widget - URL, WebURL and Viewing While Not on Local network gReatAutomation 5 1,488 10-26-2020, 03:47 PM
Last Post: Dean Roddey
  Error Running Installer to Enable SSL gReatAutomation 2 1,188 10-26-2020, 07:41 AM
Last Post: gReatAutomation
  Error trying to edit scheduled events George M 15 2,755 09-27-2020, 09:27 AM
Last Post: George M
  Web Camera: libvlc.dll error simplextech 15 6,098 07-23-2020, 05:22 AM
Last Post: batwater
  REpeating error after reboot znelbok 3 1,324 07-18-2020, 06:11 PM
Last Post: Dean Roddey
  NetworkMonitor - Cannot Reload Config gReatAutomation 26 6,726 05-15-2020, 03:02 PM
Last Post: Dean Roddey
  I updated to the latest beta version of CQC, and now getting libvlc.dll error? ghurty 2 1,297 04-29-2020, 07:06 AM
Last Post: ghurty

Forum Jump:

Users browsing this thread: 1 Guest(s)