Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5.5 Beta Discussions Thread
(03-05-2021, 09:39 PM)kblagron Wrote: One other thing that I just noticed on 917 -> Whenever I pull up a help file from the AI, I get a message that the server connection is not private.  It is trying to access my server named "CQCServer" with a non-standard secure port that I used at installation as a secure connection.  I have only been using that non standard secure port for outside access to my system, not when it is local.

Was this a change from before?  I was assuming that help was accessed on the server from a non-secure connection before since it was local.  Maybe I missed it in the documentation, or somehow my setup has changed.

I did recently have to change my outside WebRIVA security certificate since it had expired, but that was pretty straightforward of just importing a new certificate onto the CQC server, so I don't think that would of caused a change.

I've about got this worked out. You can now select which port to use. Of course if you don't want to use an insecure port at all, and you want to use the secure one for external access, you'll have to come up with some compromise, like installing the web server on a second machine to use for the secure external access, and use an internal, self-signed certificate for local help access.
Dean Roddey
Explorans limites defectum
Reply
Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.
Thanks
George M
Reply
(03-22-2021, 05:36 AM)George M Wrote: Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.

Which drivers?
Reply
(03-22-2021, 11:26 AM)kblagron Wrote:
(03-22-2021, 05:36 AM)George M Wrote: Problem with 920.
When I updated my MS to windows10, the usb to serial hub was not supported. I replaced it but now trying to set up the driver to use it I am not getting the option to change the settings on any of the serial ports. The "Settings" button is greyed out. And of course the baud rate on the three devices I have are not 9600.

Which drivers?

Nuvo Concerto
Monoprice MZ6
W80RF
Thanks
George M
Reply
I looked at one of my drivers (Samsung) since I don't have any of those drivers, and I do have the option to change the baud rate as it is non-standard, so nothing has changed on that one for me.  I then went through the process of adding both the Nuvo and the MonoPrice driver, and both of mine were greyed out (I didn't have the W80RF on my system, so it must not be a shipped driver).

As I recall, it is a configuration setting within the manifest, but will have to let Dean respond to this one.
Reply
Thank you for checking it out.
Thanks
George M
Reply
I just looked at the manifests for these drivers. They are not supposed to be editable. I just need to make sure I have my ports set up to the correct settings they require.
Thanks
George M
Reply
(03-23-2021, 06:47 AM)George M Wrote: I just looked at the manifests for these drivers. They are not supposed to be editable. I just need to make sure I have my ports set up to the correct settings they require.

Since they are shipped drivers, you would have to copy those files to a folder where you can edit them (i.e. desktop), edit them, then copy to the User folder.  You would also need to change either the Make or Model as that is the index key for each driver. 

I am not sure whether you could just edit the manifest file on a system driver and still have it pointed  to the System CML Macro Driver folder file, but it might work.

In my Samsung Driver manifest, the section below shows where it is editable:

<CQCCfg:ConnCfg CQCCfg:Editable="True">
        <CQCCfg:SerialConn 
    CQCCfg:Baud="Baud_19200"
                            CQCCfg:Bits="Bits8"
                            CQCCfgTonguearity="None"
                            CQCCfg:StopBits="One"
                            CQCCfgTonguearityCheck="No"/>
    </CQCCfg:ConnCfg>

Since that last driver on your list (W80RF) is not a shipped driver, you could try that one, as it should already be in the User folder.  Just copy it to a folder that is editable, change the "Editable" to True, and you can either leave the configuration the same and edit it when you install the driver, or put those parameters below to default to that.  Once you do that, copy it back to where it came.

Make sure you have a backup of those files before proceeding, and you will have to restart the CQC service as well after you make the change.

This is probably not the official way to do this, but pretty sure it would work.
Reply
Not sure it would work to just change the False to True. Don't think the driver would be set up to accept any changes. But since I am not a coder I'm just speculating.
I will just check each manifest to see what is expected and then set up my ports to match.
Thanks for helping with this though.
Thanks
George M
Reply
Best to just adjust your settings to match the driver.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  6.x Beta Release Discussions Thread gReatAutomation 4 256 04-24-2021, 11:58 AM
Last Post: Shaky
  Official 6.x Beta Release Thread Dean Roddey 2 196 04-16-2021, 05:55 AM
Last Post: Dean Roddey
  6.X Discussions Thread gReatAutomation 1 118 04-01-2021, 03:23 PM
Last Post: Dean Roddey
  Official 5.5 Beta Release Thread Dean Roddey 43 7,533 02-26-2021, 04:51 PM
Last Post: kfly
  Official 5.4 Beta Discussion Thread Dean Roddey 441 128,511 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 22,719 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 298,069 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 16,200 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 133,560 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 12,306 10-09-2017, 06:49 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)