Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5.5 Beta Discussions Thread
Yeh, I've seen that as well on occasion.
Dean Roddey
Explorans limites defectum
Reply
Big Grin 
For Latest Version: 5.4.915 how confident are you that we will be able to seamlessly roll back to 5.4.914? I would be happy to test this out but if I cannot roll back easily my house will be out of commission [Image: biggrin.png]
Reply
If you let it do a backup for you, you can always go back. The backup contains the whole CQC directory. So you can always restore that backup and run the 914 installer to go back.

Of course, if you really want to be extra, extra careful, run the 914 installer first and let it do the backup.
Dean Roddey
Explorans limites defectum
Reply
Dean, This morning I did the 915 install but before I did I used 914 to do a reinstall and backup as you suggested. Then I did the 915 install. The JustAddPwr port stuff did not survive the 915 install. When I reinstalled 914 from the backup, my JustAddPwr port assignment came back correctly and my driver connected correctly. Thanks. Bryan
Reply
Ooops, I'll check that. I tested that GC=100 and JAP ports a couple times but something may have gotten lost. I'll check it again.
Dean Roddey
Explorans limites defectum
Reply
I just ran a test and both GC-100 and JAPwr stuff came through correctly. Do you have multiple units configured? I might need to get you to send me your repository file so I can do a test upgrade and see what happens.
Dean Roddey
Explorans limites defectum
Reply
Dean, I reran the 915 install and still had the same problem but I have a little more information. After the 915 install, I still had the JAPwr_1 unit name and it's correct unit address but my driver would not connect. It said "Waiting for com port". So I tried to reconfigure the driver. When I got to the serial port tab, the JAPwr_1 port was not listed under "Available Ports". So I went back to the Ports > JustAddPwr in the AI and sure enough the JAPwr_1 unit name was gone. So a added it back and saved it. Then tried to reconfigure the driver again and still the JAPwr_1 unit name did not appear in the list of available ports. Restored my 914 backup and the driver in question connected just fine. Hope this helps otherwise what file do you need from me to do your test upgrade? Thanks. Bryan
Reply
OK, yeh, that's a different sort of thing. I thought you meant it was just not there in the AI at all. I'll look at it from that direction.
Dean Roddey
Explorans limites defectum
Reply
(11-22-2020, 09:32 AM)Dean Roddey Wrote: OK, yeh, that's a different sort of thing. I thought you meant it was just not there in the AI at all. I'll look at it from that direction.

Are you going to send out another update?  Was looking to test this out, but I do have 4 GC-100's, and didn't want to do it if this version might not work correctly.
Reply
I've been trying to figure this out and I think I just did. I can't imagine how that was there all this time and didn't cause problems. It was one of those side angle type things. CQCServer (the driver host) could sometimes write an empty configuration back to the MS. It's hard to imagine why that never caused this problem before. Probably some timing thing or some such.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  6.x Beta Release Discussions Thread gReatAutomation 26 3,092 05-09-2022, 08:25 PM
Last Post: Shaky
  Official 5.5 Beta Release Thread Dean Roddey 46 13,491 09-23-2021, 03:32 PM
Last Post: jokermac
  Official 6.x Beta Release Thread Dean Roddey 2 922 04-16-2021, 05:55 AM
Last Post: Dean Roddey
  6.X Discussions Thread gReatAutomation 1 770 04-01-2021, 03:23 PM
Last Post: Dean Roddey
  Official 5.4 Beta Discussion Thread Dean Roddey 441 165,463 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 29,639 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 365,577 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 19,524 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 151,437 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 14,035 10-09-2017, 06:49 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)