Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5.5 Beta Discussions Thread
Thanks for taking care of that RadioRA2 stuff. I'll test it out today.
Reply
(03-28-2020, 08:23 AM)kfly Wrote: If you have windows security "Real-time protection" turned on it fails to download file.
If you turn off real time protection the file downloads fine in chrome.....

Kevin

I did this and it is installing fine, Thanks.
Reply
Hey Dean, does this release also cover the RadioRA2 Visor keypad buttons? I have not had time to install the update but with 913 release, adding a button does not seem to work.

[Image: Screen-Shot-2020-03-29-at-13-50-48.jpg]

[Image: Capture.jpg]

Trying to add 07:01 (GarageDr) and after saving in the Driver Client, it does not show up in the Driver. Only one message in the logs with verbosity set to high.

[Image: Capture.jpg]

Code:
03/29 13:56:06-CQC, CQCServer, CQCDrv_RadioRA2Thread21
{
    CQCGenDrvS, MEng.System.CQC.Drivers.Lutron.RadioRA2.DriverImpl.62, Status/App Status
    Expected trigger indicator. Line=3
}

The buttons in Essentials are set to Toggle Control type to keep in line with the documentation  (The driver will not see key press notifications unless a keypad is configured for single control mode, not a scene type mode. If a keypad is in scene mode, the driver will only see the messages that indicate the changes caused by the scene invocation.)

[Image: Capture.jpg]
Reply
The config file is invalid, so it's not parsing the file. It looks like perhaps the client driver isn't formatting out the trigger value for buttons but the server side is expecting it, so it fails to parse the file.

You could test that by opening up the config file in notepad and adding the trailing Trig value to the button line. It would be in the same form as you should see for any of the switches that have triggers on them.

It may be related to the fix I just made related to the trigger setting not sticking as well.
Dean Roddey
Explorans limites defectum
Reply
(03-29-2020, 12:40 PM)Dean Roddey Wrote: The config file is invalid, so it's not parsing the file. It looks like perhaps the client driver isn't formatting out the trigger value for buttons but the server side is expecting it, so it fails to parse the file.

You could test that by opening up the config file in notepad and adding the trailing Trig value to the button line. It would be in the same form as you should see for any of the switches that have triggers on them.

It may be related to the fix I just made related to the trigger setting not sticking as well.

Ugh. Not sure to what config file you are referring as I thought modifying file system files was a bad idea.
Reply
In this case, it's OK since it's not a system file per se, it's just a config file for the driver, which is just a text file. And this driver explicitly was designed to allow this. The reason being that some folks want to automatically generate it from some sort of database or spreadsheet or whatever of their Lutron config info and not have to use the client interface, which could be tedious for a really big system.

It's in [cqc]\CQCData\MacroFileRoot\Drivers\RadioRA2\xxx.Cfg

where xxx is the moniker of the RA2 driver. Just be aware that if you edit by hand you need to reconfig the driver to pick it up (or there may be a command via the InvokeCmd field to make it reload, and you shouldn't have the client driver loaded because it won't automatically see these manually made changes while it's running and could just overwrite your changes.

I think the driver doc page describes the format, which is quite simple.
Dean Roddey
Explorans limites defectum
Reply
Hey Dean. The release does fix the sticking triggers issue.

I have added the RadioRA2 Buttons via the RadioRA2 Client Interface and they do show up in the config file:

Code:
Button=VisorTransmitterAway,7:2,NoTrig
Button=VisorTransmitterGarageDoor,7:1,NoTrig
Button=VisorTransmitterHome,7:3,NoTrig

Unfortunately, no buttons populate in the driver and no log entries are shown despite High log verbosity.
Reply
I don't think buttons have any fields. If I remember correctly they exist purely to send out user action events when they are pressed. They also have to be configured a particular way (in the Lutron software) for the driver to see them, which should be described in the driver doc.
Dean Roddey
Explorans limites defectum
Reply
(03-30-2020, 12:55 PM)Dean Roddey Wrote: I don't think buttons have any fields. If I remember correctly they exist purely to send out user action events when they are pressed. They also have to be configured a particular way (in the Lutron software) for the driver to see them, which should be described in the driver doc.

Thanks Dean. Confirmed. For buttons they have to be non-scene buttons in Essentials software. In CQC, Trigger has to be set to Yes. I'll test with a Wall Keypad when I get one.

[Image: Capture.jpg]
Reply
Minor Bug, but frustrating:

Using the CML Driver IDE, whenever you use the Search function -  it works great for several searches.  After that, it will revert back to a previous search, which, if your not looking, will cause you to wonder where the item was you were searching.  In the pulldown box, the one you were looking for is there, but it grabs one of the other recent searches instead.
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  6.x Beta Release Discussions Thread gReatAutomation 26 3,092 05-09-2022, 08:25 PM
Last Post: Shaky
  Official 5.5 Beta Release Thread Dean Roddey 46 13,492 09-23-2021, 03:32 PM
Last Post: jokermac
  Official 6.x Beta Release Thread Dean Roddey 2 922 04-16-2021, 05:55 AM
Last Post: Dean Roddey
  6.X Discussions Thread gReatAutomation 1 770 04-01-2021, 03:23 PM
Last Post: Dean Roddey
  Official 5.4 Beta Discussion Thread Dean Roddey 441 165,463 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 29,639 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 365,579 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 19,524 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 151,437 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 14,035 10-09-2017, 06:49 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)