Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Official 5.5 Beta Release Thread
#21
Try stopping the CQC services and restart them. Wait a minute or so and try to run the Admin Interface. That has worked for me.
Reply
#22
Not sure what's going on there. Something similar has happened before, and it's always after an upgrade. Or for me locally, after a full rebuild. The only thing I can see that's common there is that all of the previously cached DLLs are going to be thrown out and all the new code has to be loaded up. Maybe that's causing some delay that's on the hairy edge and something is timing out on the server, and it fails to register the remote interface.

When you restart it, Windows already has the DLLs all cached up and in memory, so it doesn't happen presumably.
Dean Roddey
Explorans limites defectum
Reply
#23
(01-02-2021, 08:09 AM)Dean Roddey Wrote: Not sure what's going on there. Something similar has happened before, and it's always after an upgrade. Or for me locally, after a full rebuild. The only thing I can see that's common there is that all of the previously cached DLLs are going to be thrown out and all the new code has to be loaded up. Maybe that's causing some delay that's on the hairy edge and something is timing out on the server, and it fails to register the remote interface.

When you restart it, Windows already has the DLLs all cached up and in memory, so it doesn't happen presumably.


This is a common issue. Why not force a reboot or CQC services restart after an installation?
Reply
#24
They do. It has to stop them, copy over the new code, then start them up. I don't want to have to stop them and start them again. I'll see if I can find out what's going on. Nothing related to that stuff should be one and done. All that stuff should just keep trying until it works.

I'll try to figure out what's going on. Unfortunately it's one of those that never happens when you want it to. So I'll just have to wait for it to happen and then dig in and see what I find. I've done that a bit before when it happened but never came up with any conclusive. I could probably force some full rebuilds of the whole code base to simulate the loading of all new DLLs in an install. But that's a slow turnaround for testing.
Dean Roddey
Explorans limites defectum
Reply
#25
(01-03-2021, 07:07 AM)Dean Roddey Wrote: They do. It has to stop them, copy over the new code, then start them up. I don't want to have to stop them and start them again. I'll see if I can find out what's going on. Nothing related to that stuff should be one and done. All that stuff should just keep trying until it works.

I'll try to figure out what's going on. Unfortunately it's one of those that never happens when you want it to. So I'll just have to wait for it to happen and then dig in and see what I find. I've done that a bit before when it happened but never came up with any conclusive. I could probably force some full rebuilds of the whole code base to simulate the loading of all new DLLs in an install. But that's a slow turnaround for testing.

Some software requires a reboot after upgrading / installing. Whenever I have encountered this CQC issue, I always reboot and things work normally.
Reply
#26
It is rebooting though. Everything gets stopped, upgraded and then restarted. There's just some timing thing going on when it has to load all the new DLLs, which will make it take longer than usual. Something must be giving up too quickly.
Dean Roddey
Explorans limites defectum
Reply
#27
Version 5.4.920 is posted. It has some WebRIVA web cam extension fixes and the beginnings of adding source code/build type stuff to the documentation (under Advanced Topics.)
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  5.5 Beta Discussions Thread Dean Roddey 231 30,558 8 hours ago
Last Post: Dean Roddey
  Official 5.4 Beta Discussion Thread Dean Roddey 441 111,510 06-15-2019, 02:33 AM
Last Post: Bugman
  Official 5.4 Beta Release Thread Dean Roddey 55 20,025 06-07-2019, 07:02 PM
Last Post: Dean Roddey
  Official 5.3 Beta Discussion Thread Dean Roddey 815 266,164 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.3 Release Thread Dean Roddey 27 14,673 07-05-2018, 12:44 PM
Last Post: Dean Roddey
  Official 5.2 Beta Discussion Thread Dean Roddey 244 125,091 10-14-2017, 07:57 PM
Last Post: Dean Roddey
  Official 5.2 Beta Release Thread Dean Roddey 13 11,671 10-09-2017, 06:49 PM
Last Post: Dean Roddey
  Official 5.1 Beta Discussion Thread Dean Roddey 453 252,601 05-16-2017, 03:45 PM
Last Post: Dean Roddey
  Official 5.1 Beta Release Thread Dean Roddey 28 24,453 05-12-2017, 05:44 PM
Last Post: Dean Roddey
  Official 5.0 Beta Discussions Dean Roddey 2,019 611,616 11-09-2016, 04:34 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)