Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
ZWave integration frustrations
Nearly 6 months ago I moved into a new home, and began to rebuild my automation system.  As part of this, I made a big investment in zWave - much of the system needed to be based on wireless.

At the time, I chose the Fibaro HC2 as the primary controller, with the intention that this would be used for configuring and maintaining the zWave network, but the day-to-day management of the automation would be with CQC, as it's what I'd been using for over a decade (I think close to 15 years now, which is scary!). 

Well, I have *never* successfully integrated CQC with the HC2.  I just cannot get it to join the secure network, so I'm now in the situation where the HC2 is my primary automation controller, and CQC is resigned to some very basic control in the main cinema viewing room - primarily adding an OSD to my projector via my Lumagen :-(  There is much I dislike about the HC2, and would much prefer to get back to the flexibility of CQC.  So, how to move forward?

One option is to switch the HC2 for a SmartThings hub to access zWave; who has successfully done this.  How easy was it?  Any limitations you've encountered?  Does it have good zWave device coverage (the HC2 provides a wide range of device templates out of the box, which is nice for device config/customisation)?

Dean suggested a Leviton USB stick as a primary (and their installer software for setting up the network), but in the UK this costs circa US$150 to import, and surely won't work for EU ZWave devices if its not sold as an EU version/frequency?

Could a second zWave controller not be avoided altogether (especially since the advice is to switch it off once devices are set up)?   I remember reading that Dean wrote that he didn't want to take on the work of inclusion/exclusion of devices, which I totally get and understand.  But couldn't Zensys Tools be used to set up / manage the ZWave USB stick/network, and then just have CQC take over the device as the controller?  I'm no expert on zWave controller protocols, so may well be missing something obvious.

Other alternatives?  Maybe use OpenHAB as the primary for zWave setup/maintanance, which just needs a 2nd ZWave USB stick.
The problem with that is that you have to reset the stick to move it from primary to secondary. So you can't use the same stick as both a primary and secondary controller.

I looked around and couldn't find anything definitive on whether the Leviton stick is available for the EU. Of course the only part number I ever see actually has US in the name, VRUSB-1US. I searched for VRUSB-1 and VRUSB-1EU and found nothing interesting. It might be worth contacting a store that sells them and ask if they know anything.

Some folks use the ISY 994 which can control both Insteon and Z-Wave devices, and CQC controls those via the ISY. And that would also open you up to Insteon devices. Of course make sure there's no EU frequency issues.

When you say you cannot get 'it' to join the secure network, you mean you can't get our new driver to join the secure network when you replicate from the HC2? If you can't get our driver to join, we need to get a trace to see what msgs are going back and forth between the driver and the master.
Dean Roddey
Explorans limites defectum
We went through the traces during beta, back in March/April. See around post #377

The HC2 never played well, despite one brief sign that we were making progress. The signs were, from what you concluded, that the HC2 is not well behaved. This would not surprise me.

I dismissed the ISY994 a while back, because even if it supports EU frequency zWave (which seems unlikely when I googled it), it requires a PLM, and those are not suitable for 220v.

Hence why IÔÇÖm back to drawing board looking for a solution to use my zWave network with CQC.

IÔÇÖll need to check, but I thought Zensys tools allowed flipping the USB stick between Primary and Secondary without resetting the stick. WouldnÔÇÖt this be necessary for the transfer role function available in zWave controllers?
The Aeon stick has some sort of scheme like that. I have no idea how it works or if it would work with our driver. And of course you'd have to knock the driver offline every time you wanted to use it as the primary since you need to unplug it and walk around with it to do include/exclude operations. And I have no idea how you could then use it as a secondary controller because you have to be able to replicate from the primary after changes are made. If it's in secondary control mode when the driver is talking to it, I'm not at all sure how that would work.

There was a considerable bit more tweaking of the driver going on after that. Have you tried doing a replication with a recent version of the driver?
Dean Roddey
Explorans limites defectum
Yes, I tried again a couple of days ago, before posting.

So, today I've done a completely clean install of CQC on a new NUC, using 5.3.2  (to ensure there were no remnants left on the system from previous attempts during the beta releases)

The results were the same.  I've attached the trace.

Attached Files
.txt   Trace.Txt (Size: 16.6 KB / Downloads: 2)
Move that up to the latest beta and try that. That's why I meant by there having been a good bit of tweaking done since then. Probably still won't work, but we should make sure of that before we jump.
Dean Roddey
Explorans limites defectum
OK, I've done that, but still the same result. 

New trace attached.

Attached Files
.txt   Trace.Txt (Size: 16.74 KB / Downloads: 2)
Can you do that again and this time, don't stop the trace for couple minutes or so. I want to see if it ever gets around to sending the required msg. I.e. is it just stupidly slow or is it never sending it.
Dean Roddey
Explorans limites defectum
When you say don't stop the trace, do you mean just wait some time before flushing it?  if so, then the attached is a new trace where I've excluded, then re-included and finally waited 10mins before flushing. 

There are no entries in the trace after the time the client driver replies with an error dialogue at ~20:45

Attached Files
.txt   Trace.Txt (Size: 21.08 KB / Downloads: 2)
Following with interest. I had Fibaro HC2 but eventually tossed it in favour of Smartthings due to the unnecessary complexity of HC2 (this was some time ago, not sure how much HC2 has improved since then). Smartthings is OK, not had any problem with the devices, but have not been able to integrate with CQC. It integrates well with Alexa though, so on the face of things, it all works smoothly ('Alexa, turn off the lights' turns off my lamps on wall plugs via ST and at the same time, turns off my Hue lights via CQC). Following the dev of the new CQC Z-wave driver with interest as we'd like to possibly add more Z-wave stuff in the future, but being in Europe, we need to see how to integrate to CQC with EU devices.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Update on ZWave & RadioRA2 Multi-Gang and CQC gReatAutomation 1 1,327 01-31-2020, 01:18 PM
Last Post: Dean Roddey
  ZWave / Add all devices or just as you need them? gReatAutomation 2 1,450 09-16-2019, 01:42 PM
Last Post: gReatAutomation
  Google Play Music integration sic0048 1 1,503 12-25-2018, 11:52 AM
Last Post: batwater
  Basic Z Wave/CQC Integration Question MikeW 6 4,073 12-05-2018, 01:12 PM
Last Post: MikeW
  zWave, how I hate thee. need to redo network IVB 23 8,792 12-01-2018, 11:35 PM
Last Post: IVB
  Echo integration still working for folks? IVB 5 4,020 01-15-2018, 06:18 PM
Last Post: IVB
  USB ZWave Controller Configuration bobskie708 6 6,364 11-30-2017, 04:07 PM
Last Post: Dean Roddey
  delete zwave devices? jkmonroe 8 5,371 05-23-2016, 08:46 AM
Last Post: Dean Roddey
  connecting a zWave relay IVB 3 3,559 02-20-2016, 03:13 PM
Last Post: IVB
  zwave device configuration jkmonroe 75 28,675 12-31-2015, 05:21 PM
Last Post: Deane Johnson

Forum Jump:

Users browsing this thread: 1 Guest(s)