Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Update Error (Again)
Has this change invalidated the GroupTo function? I can get the volume to change etc, but the GroupTo is being ignored.
Yeh, in order to group, we have to know the device's UID. That's one of the things gotten by the DeviceProperties service. So that field doesn't exist anymore. So, when you do GroupTo, that one tries to get the UID of the one you told it to group to, and can't do that.

But, I realized just now I can work around that. That UID is what you pass to the driver to let it find the target. So I already have it and don't need to get it from the DeviceProperties. At least I think it's the same ID. I can't prove that right now since I can't actually use the dev props service to get its version and compare them. But I believe they are the same. In the next drop I'll put that field back and store that id in it and we can see if that works.
Dean Roddey
Explorans limites defectum
Phew, hope so, so far CQC is the only software that has allowed me to do the Sonos grouping programatically (I used it heavily to set the soundbar back the general group after watching TV, and adjust the volume back down to normal at the same time).
Give 5.3.910 a try. Hopefully the id is the same.
Dean Roddey
Explorans limites defectum
I can't install it, I select Run as Admin then it runs through an unpack process but just stops after unpacking without any errors?
Hmmm.... Let me look at that. Normally I always run the installer every time. But the changes were so small and it was getting late, so I just posted that one. Of course that would be the one that doesn't work.
Dean Roddey
Explorans limites defectum
I just tried it and it comes up for me. Try just running the unpacker normally. It's the installer itself that needs the security boost. You should get a security prompt when it runs.
Dean Roddey
Explorans limites defectum
Definitely doesn't work for me, and it's not a firewall issue or anything because version 909 is fine: I just tried it again and it puts up the installation windows after unpacking, but 910 just unpacks and stops. Do I need a specific version of windows for 910 to run?

ETA - I just checked the AppData, and 909 makes 2 folders in there (CQCInstUnp and CQCInst) but 910 only makes the CQCInstUnp folder.
So I made some changes to the UPnP stuff for the Zone Player guy. I went to test the Media Renderer and had to re-set up my local media repo, which required using the phone app, so I did that. It made me upgrade to 9.3 before I could do that.

After that I couldn't get it to connect to save my life, the device would never be found despite showing up in a search during driver installation.

I got suspicious and went and shut down the phone app. It showed up immediately to the driver at that point. So somehow I guess they are taking over the device. Maybe that's just when it's in certain screens or something, but it sucks either way because it's likely to confuse people.

I finally just now got it working, added an album to the queue, and it ran straight through them in about a second apiece, so clearly something is wrong there.
Dean Roddey
Explorans limites defectum
Oh well, after a lot of messing around, I realized that the Sonos never added any of my files to its library, and can't seem to recognize any shared directories no matter what I do. So it really was just failing each time it tired to play and moving to the next one.

I did though realize that a big optimization I realized I could get tonight on the UPnP stuff meant that I could read the status now quickly enough that I might read it before it starts playing and think it has already stopped. So I had to add a delay during which time I'll just keep telling the underlying media renderer engine that it's loading. If it gets to playing or I timeout, I start returning the real status. That should prevent any sort of race condition like that. But it would be nice to be able to test it.

Oh well, I'm mess with it a bit tomorrow.

Oh, the optimization is that I realized that until you actually change something UPnP services never report any values. Even if you query them, it doesn't report back values via the eventing interface. I was doing active polls until I got the evented values reported. But, that could be a long time in some cases, during which time I'd be actively polling pretty quickly.

I realized I could just force the the values get during the first poll into the state variables, and stop polling those values. They are evented so they will get reported via events if they change. So I never have to get the values more than once. Of course once you do something that causes that value to be reported then I would have stopped anyway. But sometimes after bringing up the driver it might be some time before you do something that would have caused all of the values to be reported.

If you have a good number of boxes, this should significantly reduce traffic.
Dean Roddey
Explorans limites defectum

Possibly Related Threads…
Thread Author Replies Views Last Post
  TTS Driver Error kblagron 7 767 03-03-2023, 01:05 AM
Last Post: kblagron
  Event Server Error Bugman 4 1,062 06-05-2022, 08:54 AM
Last Post: Bugman
  Help with Log File Error karenlee 4 1,174 10-28-2021, 08:17 AM
Last Post: Dean Roddey
  Sonos Log Message karenlee 5 1,365 10-24-2021, 04:18 AM
Last Post: karenlee
  Template scaling error NishanF 1 1,182 11-10-2020, 03:21 PM
Last Post: NishanF
  Error Running Installer to Enable SSL gReatAutomation 2 1,443 10-26-2020, 07:41 AM
Last Post: gReatAutomation
  Error trying to edit scheduled events George M 15 3,306 09-27-2020, 09:27 AM
Last Post: George M
  Web Camera: libvlc.dll error simplextech 15 6,994 07-23-2020, 05:22 AM
Last Post: batwater
  REpeating error after reboot znelbok 3 1,594 07-18-2020, 06:11 PM
Last Post: Dean Roddey
  I updated to the latest beta version of CQC, and now getting libvlc.dll error? ghurty 2 1,535 04-29-2020, 07:06 AM
Last Post: ghurty

Forum Jump:

Users browsing this thread: 1 Guest(s)