Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Elk Driver fails
#1
Sitting here when all of a sudden the Elk driver fails to connect.  Can get to the Elk M1G via the Elk software, so not a connection issue.  Reboot - no joy.  Tried Reconfig, and get the message "no driver manifest info could be found for this make/model (/)".
Any ideal?
Reply
#2
Flush the logs, try the reconfig again, and get me a log dump. That's something very unusual to see, and something pretty weird would have to have gone awry. Though given the issues you said you had the other day with CQC processes getting block, that could happen if the data server was not contactable. You could do a net test, so open the CQC Command Prompt and do:

CQCNetTest > Nt.txt

and post the output of that file. That won't prove it necessarily since that's running in your logged in session while the transaction that failed above is server to server.
Dean Roddey
Explorans limites defectum
Reply
#3
Attachment perhaps


Attached Files
.txt   cqclog.txt (Size: 13.8 KB / Downloads: 2)
Reply
#4
I can create additional instances of the V1 driver OK, and also the V2 driver. Could derlete bad driver in stance, but haven't touched it for a long time, so reluctant to touch it.
Reply
#5
I didn't see anything in there about the Elk driver. Did you try to do a reconfigure on it after the log flush?

If you want, you can shut down the service on the MS, make a copy of the file:

[cqc]\CQCData\Repository\CIDCfgSrvRepo.CIDObjStore

off somewhere else. Then start it up again, remove the driver, and re-add it. Be sure to use the same moniker, case is important.

Then zip up that copied file and send it to me. I can see if it's still healthy and if the Elk driver is still in there.
Dean Roddey
Explorans limites defectum
Reply
#6
Try this one - its the Security driver


Attached Files
.txt   security log.txt (Size: 14.81 KB / Downloads: 1)
Reply
#7
It looks like something is awry with the manifest info. That's causing the class name to be empty, which causes the driver to fail to load. Of course this could have happened some time ago, i.e. something damaged the manifest file on disk, and the next time it was loaded it failed.

But, try to remove it and re-add it. If it's just the manifest info in memory, but the file is ok, then it should come back ok. If it still doesn't, the file may have gotten damaged.
Dean Roddey
Explorans limites defectum
Reply
#8
I use Acronis for backup, and did a recovery from yesterdays run. All is well again.
Thanks. Not sure what caused it ?!
Reply
#9
Within an hour, failed again with the same issue ??
Reply
#10
Were you running before on a restored backup? As mentioned various times, there's no way to do a reliable backup without stopping the service.
Dean Roddey
Explorans limites defectum
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Driver for Amazon 4k Stick Darrie 3 508 01-15-2022, 02:21 PM
Last Post: znelbok
  CQSL Interface Driver connects but no control NightLight 3 566 10-26-2021, 01:12 PM
Last Post: NightLight
  ClickPLC driver now failing after upgrade znelbok 2 992 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 1,983 08-02-2020, 11:29 PM
Last Post: kblagron
  Marantz receiver driver (IP) dlmorgan999 6 2,077 05-15-2020, 03:32 PM
Last Post: dlmorgan999
  Variables Driver Client gReatAutomation 4 1,667 04-25-2020, 12:46 PM
Last Post: gReatAutomation
  Reconfig of Driver Causes Built In Triggers to Fire gReatAutomation 2 1,234 03-25-2020, 04:09 PM
Last Post: gReatAutomation
  Lutron RadioRA2 Driver and Lutron Visor Control gReatAutomation 29 11,256 03-19-2020, 01:03 PM
Last Post: gReatAutomation
  Timers Driver / Field Time Image / Seconds gReatAutomation 1 1,152 03-16-2020, 05:48 PM
Last Post: Dean Roddey
  Problem with Accesssing Variables Driver Client Interface kblagron 5 2,128 03-05-2020, 02:24 PM
Last Post: kblagron

Forum Jump:


Users browsing this thread: 1 Guest(s)