Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
iOS App for WebRIVA - CTC CQC
(01-09-2020, 12:28 PM)znelbok Wrote: I cant find any previous contact/emails I had with him so I would try a PM from here first.  Failing that I will have to do some googling and checking on other forums to find him again. (runs his own electrical business from memory based on his name)

Thank you. Smile
Reply
Is anyone having any success with this app on a WAN connection.

I put it down to my internet as I am having to use 4G and just assumed it was the NAT that the ISP was doing that screwed me over but a fired has just installed it and we can;t get his working over WAN either. LAN appears to work fine, just not WAN.

Also, if anyone has worked out how to get ngrok working with CQC please PM me
Mykel Koblenz
Illawarra Smart Home
Reply
I have a static IP Address for my Internet service and have no issues using CTC CQC application. I had to add a port forward in my firewall (Cisco RV345) and to add that port in the CTC CQC settings such that when the CTC CQC app hits my static IP Address and port that my firewall forwards that request to my CQC server.
Reply
Have basically the same thing. DDNS service configured and port forwarding setup - yet it is still not working.

I'll try the IP address to make sure that its not a DNS issue of some sort in the app.

Do you have a domain name assigned to the static IP that you could try?
Mykel Koblenz
Illawarra Smart Home
Reply
(07-10-2020, 07:24 PM)znelbok Wrote: Have basically the same thing.  DDNS service configured and port forwarding setup - yet it is still not working.

I'll try the IP address to make sure that its not a DNS issue of some sort in the app.

Do you have a domain name assigned to the static IP that you could try?

I do not have a domain name. Simply static IP Address with port forward. Two things to try are hitting the IV from both the external IP Address and port combination as well as from the internal IP Address, both from your web browser while on your home network:

Try the internal first:

Internal
http://INTERNAL_IP/CQSL/WebRIVA/index.html?user=USERNAME&pw=PASSWORD

Then try the external after you confirmed your port forwarding is set up properly in your firewall.

External
http://EXTERNAL_IP:PORT/CQSL/WebRIVA/index.html?user=USERNAME&pw=PASSWORD
Reply
You have missed the question - Those URL's work fine in the browser, its the CTC CQC app that is not working on WAN.

The app does not use the url's above. just the ip address and then inserts them.

I have my doubts as to the app using DNS to resolve the name to the right IP address

Edit

Just tested by putting in the IP address instead of the domain and it worked via the WAN connection. Appears the app wont resolve domain names which is really needed for WAN connections.

And as usual - as soon as I say that, I get it to work with a name - not sure why it did not work before but its going now.
Mykel Koblenz
Illawarra Smart Home
Reply
Hi Guys

Sorry I haven't been on here for ages. I can be contacted at laurence@crowhurst.com.au.

Can you let me know how Scaling factor is sent via a url. so I can look at adding it in to the app
Reply
I have updated CTC CQC to V2.

With the update comes the support for SSL, Split screen on iPad OS, a change of icon to match iOS home icon and Charmed Quark colouring. Also the  app makes use of Webkit.

Question for current users.
 One client who has updated to V2 reported that it is not scaling to full screen, I haven't changed anything that would have changed that, if any one else has updated to v2 and has experienced this issue, (or know why this may be happening) can they please contact me at laurence@crowhurst.com.au.
Reply
(11-05-2020, 09:33 PM)lcrowhurst Wrote: I have updated CTC CQC to V2.

With the update comes the support for SSL, Split screen on iPad OS, a change of icon to match iOS home icon and Charmed Quark colouring. Also the  app makes use of Webkit.

Question for current users.
 One client who has updated to V2 reported that it is not scaling to full screen, I haven't changed anything that would have changed that, if any one else has updated to v2 and has experienced this issue, (or know why this may be happening) can they please contact me at laurence@crowhurst.com.au.

And addition of vpscale setting. Thank you Laurence Smile

The scaling was my issue on my phone as I had zoom enabled in screen settings on my iPhone  Blush
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)