Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
NameSrv Issues with installing 5_2_10
I am travelling at the moment and with a few day's on the beach, decided to set my laptop up as a standalone system so I could play with some media ideas.  I first uninstalled the existing client only 5_2_1 system, deleting the CQC directory and did a new install as master server system with 5_2_10.  This failed first time as the password set page could not contact the CIDNameServer.  I ran uninstall again and found that theCIDNameSrv was still active in Task Manger.  So I closed it, then ran install again.

Tried this several times with and witout re-booting in between before I finally got 5_2_10 installed.  I created a few interfaces yesterday before leaving the laptop to sleep overnight.  This moring, all I get is the "Waiting for CQC" box and after a while another box with "Cannot contact CID Name Srv on Nueomancer:13502.

I have tried uninstalling and re-installing a few times, but still the same problem.  One thing is clear however.  The Uninstall routine does not remove the runnning name server from the task list without a re-boot.  You can also see it still listening on port 13502.  Even rebooting several times and checking that nothing is listening on port 13502 does not fix the problem.  Something has got confused - what do I do to try and fix it.

You can't let the machine sleep if you are running the full system. Well you can, just shut down the CQC App Shell service first. Typically, if you are going to do that sort of setup, you will install the service for Manual mode. That way, it only starts up if you ask it to, then you can stop it when you are done. Or you can do a full restart on the machine to make it restart.

I'm guessing that whatever went wrong is preventing the uninstaller from talking to the back end, so it can't stop them and clean up. Part of the reason is that sleeping is not for server stuff. It doesn't give larger services like the CQC back end time to shut down cleanly, and it could cause issues at some point because it'll just whack them mid-shutdown. Particularly if it ends up going through multiple wake up/sleep/wake up type cycles. That's just not something that complex server side processes are necessarily wound to deal with. Most folks don't have an issue with that, that I've heard, but it's not something that we'd promise would work.

There may also be an issue with trying to convert a client to a master. It's something not often done and there may be some issue there that no one has reported.

What I would do is:

1. Manually stop both services (CQC Application Shell and CQC Client Service)
2. Delete the CQC directory to clean up any old stuff, particularly any old client side configuration stuff
3. Restart the machine
4. Now run the installer and install it as a standalone system from scratch
5. Set it for manual mode startup

When you want to use it start the services. When you are done, stop them. You can use the Windows services interface to do that, or you can do it from a command line, or you could use our Tray Monitor program to do it.
Dean Roddey
Explorans limites defectum
Did everything you said but it still fails at the screen to enter the password.  The detail message is

01/01 00:00:00-Neuromancer, CQCInst, MainThread
    CIDOrbUC, CIDOrbUC_ThisFacility.cpp.716, Failed/Not Found, Error: 6003/0/0
    Could not contact the CIDLib Name Server (at Neuromancer:13502)
    The server at was not available

Now I ran the DOS utility netstat -an to see if the port was open.  What I found was that all the listening ports for CQC were active at the address etc.  So the name server was on, but there was no entry for 192.168.43:13502 which could explain why the installer cannot find it.   By the way, I have turned off IPv6 as the first time I tried this, the diagnostic gave an IPv6 address and there was no listening on that port either.  How do you force CQC to look in the correct place.

Just to be clear, was marked as LISTENING.
That's the 'any' address, which means it's listening on all available interfaces. I wouldn't turn off IPV6. That's generally assumed to be available on Windows these days and might cause issues with other things.

When you installed, what did you give as the name of the master server? Did you give it that laptop's name?

If so, then a common scenario is an anti-virus blocking the ports. The installer sets up exceptions for the Windows firewall, but if you have any other sort of AV or firewall software you might have to set up exceptions for CQC's ports.
Dean Roddey
Explorans limites defectum

Possibly Related Threads…
Thread Author Replies Views Last Post
  RTI XP6 Issues gReatAutomation 4 1,095 08-31-2020, 01:47 PM
Last Post: gReatAutomation
  Continued Issues - RadioRA2 Thermo gReatAutomation 10 3,118 03-01-2020, 11:42 AM
Last Post: Dean Roddey
  Issues after Acronis True image clone Ron Haley 4 1,776 02-14-2020, 03:44 PM
Last Post: Dean Roddey
  ZWave Issues / Aeotec gReatAutomation 16 6,552 07-26-2019, 06:21 PM
Last Post: Dean Roddey
  SOLVED: VLC dll Issues with CQC Interface Template Viewer gReatAutomation 3 2,406 06-17-2019, 06:17 AM
Last Post: gReatAutomation
  Lutron Caseta & Zwave Issues dangerlong 191 72,395 12-19-2018, 06:40 PM
Last Post: tom
  Echo Config file issues ghurty 6 4,146 07-08-2018, 07:13 PM
Last Post: ghurty
  ISY994i Device Issues bigdude 8 4,147 05-22-2018, 07:29 PM
Last Post: bigdude
  Redid server, issues with Nest and Elk ghurty 6 3,047 05-16-2018, 05:15 PM
Last Post: Dean Roddey
  CQC Server network issues znelbok 1 1,841 03-20-2018, 12:36 PM
Last Post: Dean Roddey

Forum Jump:

Users browsing this thread: 1 Guest(s)