Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sonos Drivers
#61
(02-04-2018, 12:49 PM)jkmonroe Wrote:
(02-04-2018, 05:55 AM)batwater Wrote: And lastly, I've had 3 Communication loss events since I fired the drivers back up after reverting to all wired. Something is still amiss. We will need feedback from others that have Sonos as to whether they are also seeing Comm drops.  I'm still looking at the switch logs on my network switches for logged events.

I have 5 zones of Sonos, the Home Theater and the rest are Play:1's.  0 comm drops.

Zone Driver only, Sonos is all the way updated, only the Playbar is hardwired (the rest are wireless).  Ubiquiti EdgeRouter X, MikroTik wapAC, Netgear JGS516PE managed switch.

Could it have something to do with control via CQC?  My Sonos are all (primarily) controlled via the Harmony Hub natively (sometimes I use Sonos app but rarely), including through my in-development CQC IV which kicks off Hub activities so we can always use the remote for volume control.



Thanks Jason , right now I just have the CQC ZP drivers loaded and running in "passive mode", have not automated anything yet due to excessive comm drops which likely were caused by network loops.  I have 6 Sonos devices, each one with a ZP driver mapped.  What is interesting is that all 6 driver instances have the same count on communication drops.  Process of elimination, I'm going to move the drivers to a different machine and see if that makes a difference.  Drivers currently reside on a Win 10 virtual machine.  Prior to going hardwired on everything I had massive comm drops on several devices including the wireless ones to the point where I disabled the drivers.


Counts are incrementing slowly whether we're using Sonos or not (at least I think this is the case.)  Right now it's up to 5.  I just bumped logging up to a high verbosity on the driver instance of the Sonos we use the most often.  Don't know if the comm losses will be logged or not, would be nice to have a times tamp of the comm loss.  With that I might be able to eventually correlate/associate where the problem is coming from.

Off to a Superbowl party, I'll move the drivers later or tomorrow.
Reply
#62
IF they all have lost comm the same number of times that certainly does tend to point to some external source of evil.
Dean Roddey
Explorans limites defectum
Reply
#63
Great, you all jinxed me.

Now none of my Sonos devices are working. They are all red and stuck at 'Wait for Comm Resource'. The log simply says "Could not load the zone player using the provided player ID."

My server is unchanged (no updates, nothing) and is a Windows 7 machine. I haven't tried to uninstall/reinstall the devices yet and probably won't be able to until the weekend.
do the needful ...
Hue | Sonos | Harmony | Elk M1G // Netatmo / Brultech
Reply
#64
How about any Sonos firmware updates or changes in firmware on your network gear?
Reply
#65
Mine did that last week,  and I rebooted the server and all was okay
Reply
#66
I think that Windows isn't so good about quickly re-finding UPnP ids if they change. It assumes that they are unchanging, and generally they are. It would probably at some point do some regularly scheduled checking of its cached info I guess, but I don't know long that might take.
Dean Roddey
Explorans limites defectum
Reply
#67
restarting the master server worked. everything came back online.

which is strange, because my system has been up for weeks and we've not had a power outage. that said, i was on 8.2.2 back on 1/8/2018 and when i just checked im now on 8.3, so Sonos did update.
do the needful ...
Hue | Sonos | Harmony | Elk M1G // Netatmo / Brultech
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Emotiva XMC-2 Drivers? Darrie 1 347 01-06-2022, 06:30 PM
Last Post: Dean Roddey
  Sonos Log Message karenlee 5 767 10-24-2021, 04:18 AM
Last Post: karenlee
  CQC Drivers, License and Upgrades simplextech 4 1,630 01-09-2020, 09:22 AM
Last Post: simplextech
  Sonos Zone Player - Win10 zra 9 3,277 09-26-2019, 10:00 AM
Last Post: zra
  SONOS Driver Question gReatAutomation 13 5,525 08-23-2019, 12:37 PM
Last Post: Dean Roddey
  Deleting Drivers From AI "Add Drivers List" kblagron 1 1,025 05-16-2019, 09:18 AM
Last Post: Dean Roddey
  Sonos - PlayFovorite command NightLight 22 6,601 05-10-2019, 09:32 PM
Last Post: kblagron
  Sonos batwater 4 2,012 01-24-2019, 05:20 AM
Last Post: batwater
  Sonos Update Error (Again) karenlee 39 13,527 12-04-2018, 10:15 PM
Last Post: Dean Roddey
  Sonos PlayFavorites kblagron 8 3,948 10-22-2018, 08:46 PM
Last Post: Dean Roddey

Forum Jump:


Users browsing this thread: 1 Guest(s)