Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lutron changes v1 to v2
I just upgraded from cqc 4.4

I was/am running Lutron QS v1.7

In both an interface and in the device field list, where previously I had a switch called 
   Sw_TheaterAV, you seem to have changed it to


You did not change this in the config file.

1. how do I migrate/update to the v2 driver (sorry, I looked, but couldn't find)
2. I presume I rename in the config file and where it is used to:

       Switch=TheaterAV,14:0, Trig

And it will get SWITCH or LGHT_   prepended to the name?

Do you mean Lutron HWQS? If so, that should still be a V1 driver. Which driver did you load exactly? You may have loaded the RA2 driver, which I guess is maybe compatible with the HWQS? If so, there is also still a V1 version of that as well that you could use.

If you WANT to upgrade to the V2 version, and there are advantages to that, you can do it. All the V2 drivers are based on a set of device classes, to provide standardized access to particular types of functionality. In the HTML help you can go to:

/More Details/Drivers & Fields/V2 Drivers

That describes how V2 drivers work. It also includes a link to the reference material where the device classes are defined. The bit before the # is the device class prefix. In some cases, where a single device class supports more than one type of field (such as switches vs. dimmers) it may also add a prefix to the field name itself, such as Sw_ or Dim_ to differentiate the type.

The configuration file format is the same. You just provide the base part of the name, and the correct field name will be built up from that. If you use the old V1 version, it will be the old style names that the original driver used. If you use the V2 driver you get V2 compliant names.
Dean Roddey
Explorans limites defectum
There's also a video about V2 drivers as well:
Dean Roddey
Explorans limites defectum
This is a screenshot of my current driver. I have not changed in recently nor in years.

It is possible that I am on some odd in-between release that was not common since I was early with HWQS and I may have paid you for some custom work. I can't remember.

My actual Lutron system is HWQS. It seems that it is the RA2 driver.

.png   SH_1211 Nov. 22 20.29.png (Size: 10.61 KB / Downloads: 8)

I guess there is no compelling reason to upgrade to V2 for me (I won't use auto-generate). That's fine.

So, refined questions:
1. Am I on the right driver (version or dot release), or is there a need to upgrade?
2. WHY did you add v2 field prefixes to my v1 driver and mess everything up :-)    ?

It looks like you are on the V1 driver. The RA2 driver should be compatible with the HWQS system. The same driver is actually used for both V1 and V2 modes. It's just a flag in the driver manifest file that tells it which mode to run.

The model showing up in the capture above is showing RadioRA2-IP, which is the model for the V1 driver. But, it looks like you are using some non-standard version of it it, because it's showing 1.7, when the latest version if 3.0. So I'm guessing that the manifest file you have is really causing the driver to run in V2 mode.

So, do this... Look at:


and see if there is a manifest file in there that indicates it is for Radio RA2 (the name should make it obvious.) If so, zip that up and e-mail it to me so that I can take a look at it.
Dean Roddey
Explorans limites defectum
BTW, from the info you are running the regular driver. So I'm guessing it's just the manifest file itself that's the issue. You might try:

1. Unload the driver
2. Go to the above mentioned directory and rename the manifest file (assuming it's there) or move it somewhere.
3. Restart the MS service. That should cause it to drop the previously loaded manifest info
4. Reload the driver, which should make it pick up the current manifest

See if that takes care of it. The unit configuration is in a file so that won't be affected by unloading and reloading the driver.
Dean Roddey
Explorans limites defectum
BTW, in #2 above, you would need to change the extension or move it out. If you just rename it but keep the .Manifest extension, it will still be loaded. The file name itself doesn't matter, just the make/model inside it.
Dean Roddey
Explorans limites defectum
Thanks for your notes.

There was nothing in manifests/user.

I unloaded lutron driver then stopped CQC services on master server.

I restarted services.

I added the lutron driver. This updated me to driver version 3.0 (v1)

I still get 

LGHT#SW_TheatreAV as a field.

This is in my config file:

Switch=TheaterAV,104:0, Trig

...manifests/user is still empty

Attached Files
.png   SH_1212 Nov. 25 14.47.png (Size: 10.3 KB / Downloads: 6)
OK, clearly the driver isn't seeing the V1/V2 flag correctly for some reason. I'll look at it.
Dean Roddey
Explorans limites defectum
Hmmm... I just tried it and I get V1 fields. So something strange is going on. Do you get prefixes for dimmers, thermos, etc...? All of those should have V2 prefixes if the driver is running in V2 mode.
Dean Roddey
Explorans limites defectum

Possibly Related Threads…
Thread Author Replies Views Last Post
  Timed Field Change in Lutron HW8 avtexan 11 6,297 08-06-2018, 11:17 AM
Last Post: Dean Roddey
  Raise / Lower Shades in Lutron RadioRa2 avtexan 3 2,559 05-27-2018, 08:55 AM
Last Post: Dean Roddey
  Adding Christmas Light control to CQC with Lutron HW8 avtexan 10 7,095 11-18-2015, 12:35 PM
Last Post: avtexan
  Lutron HomeWorks Illumination software Update bjkiller 1 4,558 09-17-2010, 10:55 AM
Last Post: Dean Roddey
  Lutron Homeworks HWICCO8 bjkiller 4 3,085 02-05-2009, 06:55 AM
Last Post: bjkiller
  Lutron Radio RA help, please... AnthonyZ 22 8,097 10-14-2008, 08:05 PM
Last Post: AnthonyZ
  Lutron Homeworks Button Press Austride 0 1,654 07-02-2008, 09:30 PM
Last Post: Austride

Forum Jump:

Users browsing this thread: 1 Guest(s)