Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C-Bus driver loading error
#1
I had to do a reboot last night and now my C-bus driver wont connect.

06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, CQCDriver_DriverBase.cpp.3298, Status/App Status
    Driver 'lighting' is beginning initialization
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, MEng.System.CQC.Runtime.CQCLogger.226, Status/App Status
    C-Bus Driver starting
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CIDMacroEng, CIDMacroEng_Engine.cpp.1808, Status/App Status
    Exception 'StringErrors.BadIndex' was thrown from line 2027
    MEng.String
}
06/16 06:45:42-Zeus01, CQCServer, CQCDrv_lightingThread22
{
    CQCKit, CQCDriver_DriverBase.cpp.3371, Status/App Status
    Driver lighting returned failure status on initialization
}


What does the StringErrors.BadIndex mean?

It just keeps repeating itsel.  Obviously the driver has not been changed - it an encrypted driver.
Mykel Koblenz
Illawarra Smart Home
Reply
#2
It means that the driver is creating a string, then accessing a character beyond the end of the string. I would guess the most likely scenario is that the driver is loading some configuration file? That would be a common scenario that would involve a lot of string manipulation on startup of a driver. Maybe you changed that file since the last time you started the driver? If so, maybe check it carefully that it's still correct.
Dean Roddey
Explorans limites defectum
Reply
#3
File has not been changed, but I will double check it anyway - strange things do happen around here.
Mykel Koblenz
Illawarra Smart Home
Reply
#4
You could always, as a test, replace it with a very simple, dummy one and see if that works. If so, then you could start moving over chunks until the problem comes back, to get a better idea of where it might be. If it still fails to load with a very simple dummy file, then probably it's not the file and we can look elsewhere.
Dean Roddey
Explorans limites defectum
Reply
#5
Turns out it was one of the config files. N0t sure what was wrong but I cleaned up a few lines for fields that no longer exist and it loaded up eventually.
Mykel Koblenz
Illawarra Smart Home
Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  TTS Driver Error kblagron 5 136 11-26-2022, 05:35 PM
Last Post: Shaky
  Event Server Error Bugman 4 616 06-05-2022, 08:54 AM
Last Post: Bugman
  Driver for Amazon 4k Stick Darrie 3 697 01-15-2022, 02:21 PM
Last Post: znelbok
  Help with Log File Error karenlee 4 900 10-28-2021, 08:17 AM
Last Post: Dean Roddey
  CQSL Interface Driver connects but no control NightLight 3 756 10-26-2021, 01:12 PM
Last Post: NightLight
  Template scaling error NishanF 1 1,033 11-10-2020, 03:21 PM
Last Post: NishanF
  Error Running Installer to Enable SSL gReatAutomation 2 1,276 10-26-2020, 07:41 AM
Last Post: gReatAutomation
  Error trying to edit scheduled events George M 15 2,933 09-27-2020, 09:27 AM
Last Post: George M
  ClickPLC driver now failing after upgrade znelbok 2 1,103 09-21-2020, 10:48 PM
Last Post: znelbok
  Pentair driver tom 5 2,158 08-02-2020, 11:29 PM
Last Post: kblagron

Forum Jump:


Users browsing this thread: 1 Guest(s)