Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Echo Config file issues
I've been playing around with Alexa today, and thanks to the excellent documentation have been able to set up the Amazon side of things without issue.  However, I seem to be having trouble with the CQC side of things.  I made a sample starter configuration file as suggested in the pdf but when I run it Alexa says "The CQC configuration file could not be loaded. Please contact your CQC administrator."

I thought maybe I had not put the file in the correct location, but I double-checked by running the command prompt as an administrator and it's in the right place.  I've attached a screen shot showing the location.  I'm not sure what I should try next.



Attached Files
.jpg   Echo1.jpg (Size: 82.81 KB / Downloads: 12)
Check the logs. That could mean that there are syntax issues in the file.
Dean Roddey
Explorans limites defectum
Its the sample config file from your pdf:

Volume, Music Volume, Theater Volume
Still check the logs, to see if any errors show up, else we are just guessing.
Dean Roddey
Explorans limites defectum
Looks like it isn't finding the file.

Attached Files
.txt   CIDLog.Txt (Size: 30.99 KB / Downloads: 8)
When you can clearly see that the file is there, but it's not found, and it's down in the program files areas, a relatively common scenario is that the system has redirected your file to a per-user directory. You may have to start the editor (or command line) as an admin. Then go to the place where it should be and see if it's still there. If not, then it probably got redirected and you'll have to create it again as admin and that should do it.

If you still see it there, let me know.
Dean Roddey
Explorans limites defectum
I deleted and recreated the directory for the echocfg file running notepad as an admin.  Everything appears to be in the correct spot but its still not finding the file.  I've attached a screenshot of the command prompt which appears to indicate the file is in the right place.

Attached Files
.jpg   echo.jpg (Size: 69.55 KB / Downloads: 3)
You already cleared one possible cause I was going to suggest, using notepad and not another text program.

One of your above posts I think states you used the sample config from the .pdf, did you copy that in or type it out? I recall someone copy and pasted and it did not work until they typed it out. If you typed it out, check spelling. I mucked around for a while and left off a letter and didn't notice.
System: WHS, UPB, Plex, Elk
Drivers: Autopatch, DataLog DB, DTV IP, GC-100, IRA, Logic Server, Variable Driver, Weather Underground
I copy/pasted it from the pdf.  I'll try typing it out and see what happens, thanks for the suggestion.

Unfortunately that didn't fix the problem.
Did you check the logs again after typing it out? Just again making sure it wasn't a syntax error. If it still is staying it didn't find it, it has to be something silly at this point.

Is this a single machine system? Are you creating the file on the same machine where the CQC web server is running?
Dean Roddey
Explorans limites defectum

Possibly Related Threads…
Thread Author Replies Views Last Post
  CQC issues after Upgrade and Move to VM Ron Haley 9 658 01-19-2023, 06:26 AM
Last Post: kfly
  Help with Log File Error karenlee 4 1,170 10-28-2021, 08:17 AM
Last Post: Dean Roddey
  Amazon Echo integration rhosch 8 2,334 05-15-2021, 01:06 PM
Last Post: Bugman
  Echo troubleshooting dlmorgan999 3 1,194 01-13-2021, 04:27 PM
Last Post: dlmorgan999
  RTI XP6 Issues gReatAutomation 4 1,398 08-31-2020, 01:47 PM
Last Post: gReatAutomation
  NetworkMonitor - Cannot Reload Config gReatAutomation 26 7,498 05-15-2020, 03:02 PM
Last Post: Dean Roddey
  Continued Issues - RadioRA2 Thermo gReatAutomation 10 3,677 03-01-2020, 11:42 AM
Last Post: Dean Roddey
  Issues after Acronis True image clone Ron Haley 4 2,067 02-14-2020, 03:44 PM
Last Post: Dean Roddey
  ZWave Issues / Aeotec gReatAutomation 16 7,800 07-26-2019, 06:21 PM
Last Post: Dean Roddey
  Generic-Network Monitor - Config File Error gReatAutomation 17 7,385 06-27-2019, 11:46 AM
Last Post: gReatAutomation

Forum Jump:

Users browsing this thread: 1 Guest(s)