Charmed Quark Systems, Ltd. - Support Forums and Community
Any drivers need to be added/updated for 4.2? - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Any drivers need to be added/updated for 4.2? (/showthread.php?tid=7781)



Any drivers need to be added/updated for 4.2? - Dean Roddey - 07-18-2012

What drivers need to be added to 4.2 or updated, now that they have been blooded in the field and proven solid? I need to go ahead and start getting them into place.


Any drivers need to be added/updated for 4.2? - znelbok - 07-18-2012

Dean

I still think that we need to have a repository of "approved" drivers (i.e. those that would normally be added to the build) and that way you dont need to keep asking and adding them.

The drivers could be submitted and then approved by you (or Mark) and then added.

Remove all the drivers from the package and build in some sort of interface that will go to the store (store as in storage, not a store as in to buy) for the driver.

Handling updates would also need to be considered, something like what iOS does where it notifies you that an app has an update available. Make this a manual thing with the option of automatically chacking as well.

Don't remove the current method of adding drivers though - for those of us you write and test we can't lose that functionality.

If the CQC system does not have internet access then the store must cater for manual downloading of the drivers as well.

Mick


Any drivers need to be added/updated for 4.2? - rbroders - 07-18-2012

I'm hoping you can incorporate my changes to the Elk driver. I have been testing it quite a bit. Not sure too many others have though.

I'm on a trip now, but I can email the source on Friday...

--Bob


Any drivers need to be added/updated for 4.2? - Dean Roddey - 07-19-2012

znelbok Wrote:Dean

I still think that we need to have a repository of "approved" drivers (i.e. those that would normally be added to the build) and that way you dont need to keep asking and adding them.Mick

One of these days. Right now it would be a huge amount of work to do it, since it would have to deal with versioning of drivers and such. The current way insures that all the drivers are correct for whatever version you install, so in that sense it's saving a lot of work.


Any drivers need to be added/updated for 4.2? - gacevich - 07-27-2012

rbroders Wrote:I'm hoping you can incorporate my changes to the Elk driver. I have been testing it quite a bit. Not sure too many others have though.

I'm on a trip now, but I can email the source on Friday...

--Bob

I'm still trying to troubleshoot my hardware to make sure it is not the problem, but elk driver will not pull up info from my aprilaires. Worked fine for a long time. Once I rule out hardware I'm gonna turn to the cqc side of things.


Any drivers need to be added/updated for 4.2? - Dean Roddey - 07-27-2012

There haven't been any other complaints, and all thermos look the same to CQC via the Elk, so it's a little unlikely. But never say never. Are none of the fields available, or are they there but in error?


Any drivers need to be added/updated for 4.2? - gacevich - 07-27-2012

All the fields except for the thermos seems to be populating correctly. All four thermo's showing same problem. That's why I wanna scratch at the hardware side for a bit longer.

Does anybody know how to view thermo info in ELKRp? I have labeled thermos in the Thermostats subfolder under Automation. But I don't see where I can view the thermo field values in ELKRp.


Any drivers need to be added/updated for 4.2? - wuench - 08-01-2012

Here is a list of my drivers that can be included, the raw files and htm docs are in the threads:

Updated Drivers:
[THREAD=4942]Epson VP21 1.4 (Shipped ver is 1.2)[/THREAD]
[THREAD=4677]POP3 Email 1.5 (Shipped ver is 1.4)[/THREAD]
[THREAD=10000]Syslog 1.1 (Shipped ver is 1.0)[/THREAD]
[THREAD=9999]Network Monitor 1.1 (Shipped ver is 1.0)[/THREAD]

New Drivers:
[THREAD=9722]XBMC[/THREAD]
[THREAD=10224]Boxee[/THREAD]
[THREAD=10236]EventGhost[/THREAD]


The EventGhost driver requires a plugin file for EventGhost to work so you may have to link to that in the docs or we can just leave it in the thread...


Any drivers need to be added/updated for 4.2? - Dean Roddey - 08-01-2012

Hmm.... I'm probably going to put up 4.2 today, so I don't want to take the risk. I'll do these immediately afterwards. I'm probably going to end up doing a fairly quick followup release, in order to get more auto-generation stuff out without waiting for a full release cycle. So that'll give them time to get banged on but without waiting a long time and being out of sync yet again before the next full release.