Charmed Quark Systems, Ltd. - Support Forums and Community
Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: CQC Support (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=9)
+--- Thread: Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior (/showthread.php?tid=7518)



Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior - Ishmael - 12-04-2011

If you are using CQC with the latest Elk firmware M1G 5.2.8 and M1XEP 1.3.28, could you take a peek at your Elk driver in CQC and tell me if you see it disconnecting once a minute, such as described below.

I use an Elk M1G, CQC, and an ISY99i. Last night, I decided to upgrade to the latest ISY release and add their Elk module. The ISY module has firmware prerequisites of M1G 5.2.8 and M1XEP 1.3.28. My versions were older, so I upgraded, set everything up, and at first glance, all seemed good.

While checking things in CQC, I noticed that the M1G connection went offline, then came online. I then noticed that $LostCommRes was higher, and as I watched things, the connection kept going offline and coming back online.

Much troubleshooting ensued including sniffing the traffic from the M1G to both CQC and the ISY. I discovered that, once a minute, the M1G is sending the RP (remote programming mode entered) code, and then 10 seconds later, it sends the IE programming mode exited code. 50 seconds later, at the top of the next minute, here comes RP again, and then 10 seconds later, IE again.

This behavior remains the same whether just CQC is connected, just the ISY, or both.

I have two rules that run in the M1G once a minute, so just in case it could be rule related, I made a copy of my Elk configuration, deleted all rules in the copy, and sent that to the control. The behavior remained exactly the same.

FWIW, during the ten second interval, the M1XEP web interface also becomes non-responsive, although it doesn't display the "Panel has entered programming mode" message that appears when running ElkRP.

If anyone knows of anything that might help troubleshoot this further, please let me know.

Thanks.

Chris


Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior - Dean Roddey - 12-04-2011

If the driver sees the RP entered command, it goes offline because it has to be disconnected while the RP software is in control. So it would be a bad thing for some device to send out such a command and push everyone offline ever minute, unless there's some new info in that command that let's us know that it's one we can ignore (in which case why in the world would this device be acting like the RP software anyway?)


Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior - wuench - 12-04-2011

I would bounce power on your XEP, if you haven't already.

FWIW, I am running an older version of Elk Firmware and the ISY Elk module (and CQC) are working fine for me...


Elk 5.2.8/M1XEP 1.3.28 firmware curious behavior - Ishmael - 12-06-2011

I tried downgrading the M1G to 5.2.4, with no change. I looked closer at what the M1XEP is sending, and realized that it is sending that code (RP02) that indicates that it is rebooting once a minute. This points me back pretty directly at Elk, so I've contacted technical support for any last ditch efforts and/or return information.

Chris