Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - Fonceur - 06-13-2009

personalt Wrote:This new version works great...
Good!

Quote:Should I be concerned about org.mortbay.log? I have zero clue what that is.
It's all over your log file, so I assume it should be easy to track among your installed plugins...


Sage Media Server driver (beta) - personalt - 06-13-2009

I am getting almost all the variables populated. The only thing that I dont see is the recorded show list.

In sage I see it go from upcoming to recorded to favorites. However in the CQC log though I only see one entry that the recorded list is done. I see no adds. However later when I delete a single show I do see the DEL entry in CQC but of course there is nothing in the list to delete. the leads to be believe there is a error or bad character in my xml dump..

Is there any special characters in the XML that might cause CQC to barf? I have the XML file here that it is trying to parse.

http://www.comestayplay.com/rsl.xml

forgive me for the 'real housewives of nj' my wife watches that...

The idea of sending incremental changes is really cool and a upgrade over the old recorded list(assuming I can figure out what is wrong with the initial paint).


Sage Media Server driver (beta) - Fonceur - 06-13-2009

personalt Wrote:I am getting almost all the variables populated. The only thing that I dont see is the recorded show list.
Set the driver to verbose mode High, restart SageTV, and check the CQC log for anything funny happening with RSL...


Sage Media Server driver (beta) - personalt - 06-14-2009

It says 'Msg recieved, Item Diskspace Data:XXXXX' then
'Msg Received ITem: Recorded Show List Data: Done'

However there are no entries to add the new recored shows.

What I did notice was that overnight the new shows that recorded were added fine. It is when I restart sage and try and parse the whole list is when it barfs.

I trimmed down the list of recorded shows to get rid of anything i didnt really need to watch. With the shows that are left I dont see any real special characters but it still fails. I did see a ; in some descriptions but not sure that is it. I had some " in some descriptions but I deleted all those shows.

The latest file from the sage log is here
http://www.comestayplay.com/rsl.xml


Sage Media Server driver (beta) - Fonceur - 06-14-2009

personalt Wrote:It says 'Msg recieved, Item Diskspace Data:XXXXX' then
'Msg Received ITem: Recorded Show List Data: Done'
Could you paste the text surrounding that please...


Sage Media Server driver (beta) - personalt - 06-14-2009

http://www.comestayplay.com/rsl.zip has both the CQC and sage logs.

I took a break from this restarted everythng one more time. Now I have the recorded show list but not the upcoming recording. I have a feeling the driver might be dropping connection still, just not as much.

A little later I will shut both services down purge both logs and do a restart.

But if you want to take a look at this log - I restarted sage and CQC around 10:26:41. Actually I restarted CQC first and then set the logging to high for the driver then restarted Sage. The sage log was purged but the cqc log seems to go back further then the last restart. You should be able to work from the bottom up on the CQC log.

The RSL load takes place around 10:27-10:28. FYI - CQC and Sage are on the same machine but I ran CQC admin from my laptop, I dont know if that could cause any times to be out of sync by a few seconds.

Like I said above I have the recorded shows now but not the upcoming. I notice it looses its comm resource at 10:28:03, 10:28:09 & 10:28:13, this is well after the restart.

I will try and get some cleaner logs later but feel free to take a look.. thanks for all your help, this driver looks great as far as fixing the things I didnt like in the old version. I am very excited to see this going..


Sage Media Server driver (beta) - personalt - 06-14-2009

I am actually getting all the shows now.(most of the time). I have upcoming, favorites and recorded show lists.

It appears I am losing com resources from time to time.. That may be the reason for the sporadic response. did a little re-search on org.mortbay.log. I think it is for sage job queue. It is the module that fires off my comskip the commercial skipper.


Sage Media Server driver (beta) - SamVimes2 - 06-16-2009

Well I'm not sure what did it, but after a reboot of the server, I have my channel list now!

Thanks for all your work on this driver. It's really great.


Sage Media Server driver (beta) - SamVimes2 - 06-16-2009

Ok next question. Now that I've got my channel list, what do I write into the ChannelContentIndex field?

Nothing I write has any effect, except 0, which crashes the driver.


Sage Media Server driver (beta) - Fonceur - 06-16-2009

SamVimes2 Wrote:Well I'm not sure what did it, but after a reboot of the server, I have my channel list now!
Well, if you installed the latest version (.92c), I did increase the length of the timeout...

Quote:Ok next question. Now that I've got my channel list, what do I write into the ChannelContentIndex field?
Take a look at the sample template in the first post. Basically, you select a channel in the list, which fills the timeslots (i.e. channelcontent), then you get a specific timeslot (though channelcontentindex). You are skipping a step, so trying to select from an empty list...