Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - batwater - 11-21-2016

Thanks for the detailed response! Eeek, forgot about the tuners I have installed. The thought of adding more cards to my unraid box and disrupting the pass through hacking that I have already done (USB 3 for 3 instances and video for 2 instances) makes my knees wobble.

I'm afraid to upgrade to the newest release of UnRaid as it wipes out the config changes, uhg!


RE: Sage Media Server driver (beta) - daddyd - 01-02-2017

Dean, I just updated to 5.0.7 (from 4.5.4), looks like it isn't getting along with Sage. I went to update the driver to the referenced update in post #1 but the attachment isn't valid any more. Can you help me out?

Thanks!


RE: Sage Media Server driver (beta) - Dean Roddey - 01-02-2017

OK, I'd thought that the problem with attachments was that their attachment ids got changed, but actually it was that our custom attachment types didn't get carried forward. So I didn't think that there was such a file type to download. So I added the driver pack type. But, then it turns out that the MyBB software doesn't allow file extensions longer than that. So the CQCMacroPack extension can't be entered into the database. That sucks. I'm going to report this and hopefully they can get a fix for this.

In the meantime, the driver pack should now download. If you need the macro packs, that's going to be hard to get to until we get a workaround for this issue.


RE: Sage Media Server driver (beta) - daddyd - 01-02-2017

Thanks Dean. A couple of thoughts, has the server package also been updated? Also it looks like the player version has the port input locked, due to my quantity of clients I need to modify the port number for each instance. Could you help me out with this?


RE: Sage Media Server driver (beta) - Dean Roddey - 01-02-2017

I'm not sure about those issues. Someone who uses this driver would have to kick in with some knowledge on that front.


RE: Sage Media Server driver (beta) - Dean Roddey - 01-02-2017

OK, the other package types should be downloadable now.


RE: Sage Media Server driver (beta) - daddyd - 01-02-2017

(02-08-2013, 09:58 AM)whozeawhat Wrote: As requested, player should now allow for change in port.

Updated to version 2.9 for Sage Player driver.

Dean, this was the latest driver (it wasn't reflected on page one), this one we were able to manipulate the port change.


RE: Sage Media Server driver (beta) - Dean Roddey - 01-02-2017

So you were able to get it and it works?


RE: Sage Media Server driver (beta) - daddyd - 01-02-2017

After a little messing around, I was able to get all the player drivers (2.9 version connected to the Sage extenders) running, they seem to work. The server driver refuses to connect either with the posted server driver or with 2.9 - not sure how the player drivers are able to communicate. I can't try your posted v2.79 since I can't manipulate the port to reflect the one I am actually using. I also can't connect to my one PC based client also using the server driver or 2.9.

I know Sage was a dying product a couple of years ago, but I am 8 years into it and there still isn't anything even close to being as good. It would be great to get a stable V2 compliant server/player driver completed and released. My ipad/phone is my go-to remote since I spend more time queuing up movies for my kids.


RE: Sage Media Server driver (beta) - SomeWhatLost - 01-04-2017

(01-02-2017, 02:03 PM)daddyd Wrote: After a little messing around, I was able to get all the player drivers (2.9 version connected to the Sage extenders) running, they seem to work.  The server driver refuses to connect either with the posted server driver or with 2.9 - not sure how the player drivers are able to communicate.  I can't try your posted v2.79 since I can't manipulate the port to reflect the one I am actually using.  I also can't connect to my one PC based client also using the server driver or 2.9.

I know Sage was a dying product a couple of years ago, but I am 8 years into it and there still isn't anything even close to being as good.  It would be great to get a stable V2 compliant server/player driver completed and released.  My ipad/phone is my go-to remote since I spend more time queuing up movies for my kids.

Sage player driver and server drivers are completely different things, makes sense that one could work while the other didn't... I generally only use the player driver in my setup... not sure if I even tried installing the server driver? need to check on that when I get a chance...

to fix his posted driver, that may or may not be the latest version, you just need to edit the manifest, and change where it says ports editable from false to true (or something like that... I am not a sw guy, but at the time it seemed obvious and it worked...)
but I vaguely remember the actual latest driver not needing to have the ports thing edited?


completely agree that sage is no longer a dead product... it is alive and well as an open source product now... will live forever! (well maybe?)
so if someone who could do driver type stuff would step up and take this over, or someone go hunt down beelzerob and get him to pick up development again, that would be appreciated...
where is beelzerob anyway? haven't seen him around? hope all is well...