Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - potts.mike - 04-03-2011

Are the instructions linked to in the first post of this thread the most current?


Sage Media Server driver (beta) - Fonceur - 04-03-2011

potts.mike Wrote:Are the instructions linked to in the first post of this thread the most current?
Well, on a SageTV 7 system, SageTCPServer gets installed through the SageTV plugin interface and pretty much configures itself, but the CQC part hasn't changed...


Sage Media Server driver (beta) - potts.mike - 04-03-2011

Do I still need to edit the sage.properties file?

I added this line

sageTCPServer/client=local.9260,00012e2c03a2.9261

but the driver is still at "wait for Comm Resources"


Sage Media Server driver (beta) - Fonceur - 04-03-2011

No, that line is wrong if you are running SageTV 7 with the latest SageTCPServer plugin...


Sage Media Server driver (beta) - potts.mike - 04-04-2011

Are there updated instructions posted somewhere?


Sage Media Server driver (beta) - Fonceur - 04-04-2011

I've just updated the wiki.


Sage Media Server driver (beta) - rm1759 - 04-12-2011

I think I am missing something obvious.

i have installed everything according to the directions, but I cannot get the driver to connect, I see this error in the log:

macro class '\meng\user\cqc\macros\libraries\xml' was not found

looks like I need a macro class(es) as well for this? I installed all of the templates as well.


Sage Media Server driver (beta) - Fonceur - 04-12-2011

rm1759 Wrote:I installed all of the templates as well.
There is a set of macros bundled with the templates...


Sage Media Server driver (beta) - rm1759 - 04-13-2011

Fonceur Wrote:There is a set of macros bundled with the templates...

Do I have to do something else besides import the templates? I did import both template packs, but I do not see any of those macros in my system?


Sage Media Server driver (beta) - Fonceur - 04-13-2011

rm1759 Wrote:Do I have to do something else besides import the templates? I did import both template packs, but I do not see any of those macros in my system?
Have you imported SageMacros_0.1.CQCMacroPack from the templates pack?

EDIT: Since the maximum file size was increased recently, I've recombined all the templates into a single zip, and moved the macros out of it...