Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - Fonceur - 03-24-2011

batwater Wrote:Auto reboot has a field but no radio button options, prompts for text input when I select.
Oops, that was the NetBean editor trying to help with the "" and breaking stuff instead... Wink

Quote:Um, getting repeat errors in CQC logs, capturing logsnap will post.
Right, I guess None wasn't part of the enumeration for the PlayMode field...

Quote:This leads me to my above point, trying to turn on debug in SageTV UI but cannot.
Right, that's from the first issue, where autoReboot and debugOn got squeezed together in one spot but not the others.

Quote:Work from where, CQC driver?
I'm pretty sure I added some Extender_Command or such somewhere... Or maybe just a plain SageCommand field.

Quote:New code is coming up as 2.1.3 in the SageTV GUI.
Well, the SageTV GUI displays the content of some XML file, which hasn't been updated with that test version, the log itself would actually show 2.1.4.

So here's a fixed version.

EDIT: Everything seemed fine, so it's now an official release...


Sage Media Server driver (beta) - SomeWhatLost - 03-24-2011

fwiw, I tried the non-updated just a couple minutes ago, SagetTCPServer beta (ie 2.1.4), and saw pretty much the same things batwater did...

also, as far as windowing mode vs full screen for power on/off detection that works fine, and has been working fine for me... but I am only on 7.1.5 sage beta...

note by fine I mean there can still be up to a minute lag between the unit powering on/off and the windowing mode actually changing... but its been that way for a while...

also of note, the power controls seem to work fine from CQC now... exit standby actually turns on my hd300... haven't tried with the hd200, but I would guess it works now also...


Sage Media Server driver (beta) - SomeWhatLost - 03-26-2011

ok, so 2.15 seems broke...
I have triggers setup to turn on/off the lights when the projector is the display and sage is either in play mode or paused...
they used to work wonderfully... now, not so good...
doesn't seem like it is sending play/pause mode changes anymore? why not? stop seems to work though... at least it did once...


Sage Media Server driver (beta) - Fonceur - 03-26-2011

SomeWhatLost Wrote:doesn't seem like it is sending play/pause mode changes anymore? why not? stop seems to work though... at least it did once...
Hmm, I did change something to handle the "none", i guess that's a side effect...

I will need some logs, because it's working fine on my software client...


Sage Media Server driver (beta) - bjkiller - 03-27-2011

Fonceur Wrote:I don't have an extender myself, so I don't know. The WindowingMode field seems to reflect the StandBy state of the extender. Now if you press the Off button on your IR remote, maybe it's more than just a light StandBy mode, which would be why there is no WindowingMode event generated...
after recent changes, WindowingMode on poweroff - updates like 15 sec after, before it's was 2-3 sec.


Sage Media Server driver (beta) - Fonceur - 03-27-2011

The PlayMode update should be instantaneous due to the new SageTV events... The windowing mode should be noticed/sent within 250 ms... Are you running the SageTV beta version?


Sage Media Server driver (beta) - bjkiller - 03-27-2011

yes, latest beta.
btw: i sent extender to you, check PM for tracking number.


Sage Media Server driver (beta) - Fonceur - 03-27-2011

bjkiller Wrote:yes, latest beta.
OK, that might be the issue, as I'm seeing some funny stuff going on with the API of people running the beta...

Quote:btw: i sent extender to you, check PM for tracking number.
Thanks, having the actual hardware should help figure out some things.

Version 2.1.7 is a slightly more efficient version, see if helps any...


Sage Media Server driver (beta) - SamVimes2 - 03-27-2011

Fonceur,

Automatic extender restart works great and is a great addition. Thanks very much!


Sage Media Server driver (beta) - Fonceur - 03-28-2011

I need a few more volunteers with extenders to test this build. Instead of a full reboot, now it should only do a PowerOn (won't work the first time on the MVP).