Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - batwater - 10-07-2010

Fonceur Wrote:The latest version of SageTCPServer.jar is now available through the SageTV 7 Plugin interface...

It does not make use of any new SageTV 7 features, as I didn't want to break compatibility for users of SageTV 6, but now that the SageTV release is getting closer, eventually it probably will...

Great, it can be found under General Category.

Thanks!
-Ben


Sage Media Server driver (beta) - SamVimes2 - 10-19-2010

Hi Fonceur,

If we install the one from the plugin interface, will it cleanly and properly overwrite the one I had previously put in the JAR directory manually?

Thanks!


Sage Media Server driver (beta) - Fonceur - 10-19-2010

Yes, you can safely use the one from the SageTV plugin interface. Just be aware that you need an extra restart to really use it, as the first time it reuses the old one, even though it said it was restarting to install it.


Sage Media Server driver (beta) - SamVimes2 - 10-19-2010

Ok seems to have worked fine.

I am having a weird issue. I use your sample templates, and everything works fine, except sometime in a recent build the 'RecordedShows' part stops working.

The field is populated when the driver starts up, but when i click the button to load the template, it runs the macro, and the field blanks out. Nothing is returned from the macro, so the template list is blank as well.

Any ideas? I am getting some logs now.


Sage Media Server driver (beta) - SamVimes2 - 10-19-2010

Emailed you some logs. Looks like the recorded shows XML is getting split in two and something in the second chunk kills it.

Let me know if that's enough log.

Thanks!


Sage Media Server driver (beta) - Fonceur - 10-19-2010

SamVimes2 Wrote:Let me know if that's enough log.
There's nothing that jumps out... Anything special in the CQC log?


Sage Media Server driver (beta) - SamVimes2 - 10-20-2010

Nothing at all in CQC log with the driver verbosity set to high. Here's the action trace:
Code:
TRC: Start Action
Global Vars=
    GVar:RSActors=
    GVar:ZoneNumber=1
    GVar:RSTitle=
    GVar:URListOfIDs="3971118", "3982867", "4102673", "3994468", "4018498", "4185986", "4049506", "4042609", "4078127", "4049512", "4060665", "4060545", "4068552", "4060638", "4090508", "4078125", "4100710", "4102635", "4102674", "4102672", "4111061", "4111056", "4145232", "4130414", "4172296", "4168461", "4184291", "4185955", "4194501"
    GVar:URDate=
    GVar:Zone=Living
    GVar:RSID=
    GVar:RSDescription=
    GVar:URTitle=
    GVar:URChannel=
    GVar:RSListOfIDs=
    GVar:VideoDriver=Z1-Sage
    GVar:VideoZone=Living Room
    GVar:URDescription=
    GVar:MoviesCABFirstIndex=1
    GVar:RSList=
    GVar:TVTopic=Schedule
    GVar:RSGenre=
    GVar:VideoTopic=TV
    GVar:URActors=
    GVar:URGenre=
    GVar:MoviesCategory=All Movies
    GVar:URList="10/20  09:00PM, Ch. 702 -  Criminal Minds: Safe Haven #125", "10/20  10:00PM, Ch. 745 -  South Park #404", "10/20  10:00PM, Ch. 707 -  The Whole Truth: True Confessions #4", "10/21  08:30PM, Ch. 704 -  30 Rock: Reaganing #87", "10/23  11:28PM, Ch. 704 -  Saturday Night Live #817", "10/23  08:00PM, Ch. 704 -  Outlaw: In Re: Tyler Banks #7", "10/24  11:30PM, Ch. 761 -  The Venture Brothers: The Silent Partners #56", "10/24  10:00PM, Ch. 651 -  Bored to Death: Forty-Two Down! #18", "10/25  08:00PM, Ch. 702 -  How I Met Your Mother: Baby Talk #124", "10/25  12:30AM, Ch. 761 -  Metalocalypse: Doublebookedklok #52", "10/25  10:00PM, Ch. 704 -  Chase: Havoc #7", "10/25  09:00PM, Ch. 705 -  Lie to Me: Double Blind #48", "10/25  11:00PM, Ch. 745 -  The Daily Show With Jon Stewart #1653", "10/25  10:00PM, Ch. 707 -  Castle: 3XK #42", "10/26  11:00PM, Ch. 745 -  The Daily Show With Jon Stewart #1654", "10/26  08:00PM, Ch. 702 -  NCIS: Cracked #177", "10/27  09:00PM, Ch. 702 -  Criminal Minds: Devil's Night #126", "10/27  08:00PM, Ch. 711 -  America's Next Top Model: Zac Posen #241", "10/27  10:00PM, Ch. 707 -  The Whole Truth: When Cougars Attack #6", "10/27  09:00PM, Ch. 707 -  Modern Family: Halloween #30", "10/27  11:00PM, Ch. 745 -  The Daily Show With Jon Stewart #1655", "10/27  10:00PM, Ch. 745 -  South Park #405", "10/30  11:28PM, Ch. 704 -  Saturday Night Live #818", "10/28  11:00PM, Ch. 745 -  The Daily Show With Jon Stewart #1656", "11/01  02:00AM, Ch. 765 -  Naked Science: What Killed the Aztecs? #86", "10/31  10:00PM, Ch. 651 -  Bored to Death: The Case of the Grievous Clerical Error! #19", "11/01  08:00PM, Ch. 702 -  How I Met Your Mother: Canning Randy #123", "11/01  10:00PM, Ch. 707 -  Castle: Almost Famous #41", "11/01  11:00PM, Ch. 745 -  The Daily Show With Jon Stewart #1660"
    GVar:RSDate=
    GVar:MoviesTitleCount=0
    GVar:RSChannel=

CMD: 001.  (2ms) - GlobalVars::SetVariable
    P1=GVar:TVTopic
    P2=RecordedShows

VAR: Set variable 'GVar:TVTopic'
       =RecordedShows

CMD: 002.  (2ms) - Overlay::LoadOverlay
    P1=\User\Jpants2x\Sage_RecordedShows

CMD: 001.  (226ms) - GlobalVars::GetLength
    P1=GVar:RSList
    P2=LVar:RSListLength

VAR: Set variable 'LVar:RSListLength'
       =0

CMD: 002.  (226ms) - If System::Equals
    P1=0
    P2=0

CMD: 003.  (226ms) - MacroEng::RunMacro
    P1=MEng.User.CQC.Macros.Sage.GetList
    P2=SageMediaServer RecordedShows StartTime False False GVar:RSList GVar:RSListOfIDs

CMD: 005.  (237ms) - RecordedShows::SetBrowserList2
    P1=
    P2=

TRC: End Action [Result=Success]



Sage Media Server driver (beta) - SamVimes2 - 10-27-2010

Hi Fonceur,

This is still an issue...any thoughts on how I track down the problem?

Thanks!


Sage Media Server driver (beta) - Fonceur - 10-27-2010

The main problem is that I don't have CQC installed on my system, so can't easily look at the source code to figure it out... Wink I want to spend the time up to the end of the weekend on my new iOS project, but I'll look into it next week.


Sage Media Server driver (beta) - chmilar - 11-18-2010

I have SageTV running on a computer, and two extenders (STX-100 and STP-200).

I can get the latest SageTV-TCP driver to communicate with the Sage application on the computer, but for the extenders it shows "Online" but sticks on "Wait for Comm Resource".

I have gone through and rechecked all settings against the wiki instructions at talluscorp, and it all seems to be correct.


Just to make sure I am not missing something obvious:

SageTV V7 is not running as a service on the computer. I am running by launching the application.

Windows Firewall is off. No anti-virus.

The JAR files are in the JARs directory. (gkusnick.sagetv.jar, SageTCPServer.jar). These are installed via the plugin interface in SageTV.

Sage.properties has the lines:

load_at_startup_runnable_classes=sagetcpserver.StartServers

sageTCPServer/clients=local.9250,001e40b5a15d.9260,001d6a4cf5c3.9270

I have checked the MAC addresses and IP addresses of the extenders.

Three instances of the driver are loaded in CQC, each with the IP address and socket to match the "clients" line, and protocol as TCP.


Since the SageTV app on the computer is connecting, I am assuming that some of the configuration is correct. There is just something wrong about the extenders.

Does anyone spot a problem?