Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - Fonceur - 04-28-2009

I updated the XML macro, you will need to reload the SageMediaServer driver for it to take effect. It didn't like when a control character ended a string, like the title of one of tonight's "Two and a half men" episodes...


Sage Media Server driver (beta) - Fonceur - 05-05-2009

I added a QueryTextVal method, which makes it possible to have 2 different clients consulting different recorded shows, upcoming recordings or channel content... If you are not worried about simultaneous operations, you should stick to the easier Field methods... They make use of a few macros, so you can use some "static list browser" and "variable text" widgets.

MEng.User.CQC.Macros.Sage.GetList

<Moniker> <Name> <SortProperty> <SortOrder> <UnWatched> <List> <ListOfIDs>

SortProperty: {Title, Episode, Category, StartTime, EndTime, IsWatched, Description, OriginalAirDate, Rating, MovieYear, Channel, Duration}

SortOrder: True = Increasing, False = Decreasing.

UnWatched: True = Shows not previously watched, False = all shows.

SageRepo RecordedShows StartTime False True GVar:RSList GVar:RSListOfIDs

SageRepo UpcomingRecordings StartTime True False GVar:URList GVar:URListOfIDs


MEng.User.CQC.Macros.Sage.GetTimeslots

<Moniker> <Index> <List> <ListOfIDs>

SageRepo %(StdRTV:SelectIndex) GVar:CCList GVar:CCListOfIDs GVar:CCChannel GVar:CCChannelNumber


To fill a "static list browser" from the returned "quoted comma lists", you would use:

ChannelContent::SetBrowserList2(%(GVar:CCList), %(GVar:CCListOfIDs))


MEng.User.CQC.Macros.Sage.GetDetails

<Moniker> <Name> <ShowID> <Title> <Date> <Genre> <Desc> <Actors> <FirstRun> <HD>

SageRepo Channel %(IntfRTV:UserData) GVar:CCTitle GVar:CCDate GVar:CCGenre GVar:CCDescription GVar:CCActors LVar:IsFirstRun LVar:IsHD


<Moniker> <Name> <ShowID> <Title> <Date> <Genre> <Desc> <Actors> <ChannelName> <HD>

SageRepo RecordedShows %(IntfRTV:UserData) GVar:RSTitle GVar:RSDate GVar:RSGenre GVar:RSDescription GVar:RSActors GVar:RSChannel LVar:IsHD

SageRepo UpcomingRecordings %(IntfRTV:UserData) GVar:URTitle GVar:URDate GVar:URGenre GVar:URDescription GVar:URActors GVar:URChannel LVar:IsHD


Sage Media Server driver (beta) - beelzerob - 05-06-2009

Hey, dunno if this has been fixed in a recent version or not, but I just updated and got these errors:

Code:
05/06 22:52:54-cqc-server, CQCServer, CQCDrv_smedia_Thread11
{
    CQCKit, MEng.User.CQC.Drivers.SageTCP.SageMedia.DriverImpl_Dev.645, API Failed/Data Format
    A macro parse event occured
    Overrides must have identical parameters, return, and visibility as the overriden method
}
05/06 22:52:54-cqc-server, CQCServer, CQCDrv_smedia_Thread11
{
    CQCKit, MEng.User.CQC.Drivers.SageTCP.SageMedia.DriverImpl_Dev.653, API Failed/Data Format
    A macro parse event occured
    Expected a method call, object reference, or flow control statement here
}
05/06 22:52:54-cqc-server, CQCServer, CQCDrv_smedia_Thread11
{
    CIDMacroEng, CIDMacroEng_Parser.cpp.2184, Status/App Status, Error: 6505/0/0
    An unrecoverable error occured while parsing
}

I think maybe this is those breaking changes Dean talked about for the QueryVal thing? Maybe?


Sage Media Server driver (beta) - Fonceur - 05-06-2009

beelzerob Wrote:I think maybe this is those breaking changes Dean talked about for the QueryVal thing? Maybe?
Yes, he replaced a Card4 by a String, so the latest version won't work on the .40+ beta. I'll probably be updating my CQC version next week or so, so I can update the driver then.


Sage Media Server driver (beta) - Fonceur - 05-11-2009

beelzerob Wrote:I think maybe this is those breaking changes Dean talked about for the QueryVal thing? Maybe?
Version .90 (and up) now requires CQC beta 2.4.40 and up...


Sage Media Server driver (beta) - Shildrak - 05-30-2009

Hello all. First, I really want to thank everybody for so many nice development efforts and helpfull forum threads. I have just purchased cqc for my automation purposes and it has really helped me get started.

So now I have got the sageplayer/sagerepo drivers running and deliver its magic to 2 HD200 extenders, serving movies from the mymovies repo. All working wonderfully.

My question is now regarding extending this setup to also use sage as the audioplayer head. Would this be possible in any way? All my music is in the JRMC repo, and it seems to me it should be possible to do something similar to what we do when starting movies from mymovies repo However, I think I am missing an "enqueueSong" and "playSong" field where I could paste an UNC path to an mp3 and have it play in sage?

I hope this could be possible as it would somewhat replace the need to have separate hardware for audioplayback (ignoring sync problems etc).


Sage Media Server driver (beta) - Fonceur - 05-30-2009

Shildrak Wrote:However, I think I am missing an "enqueueSong" and "playSong" field where I could paste an UNC path to an mp3 and have it play in sage?
Have you tried using the same WatchShowPath field? As long as you can pass the full filename, it shouldn't matter if it's audio or video... As far as playlist are concerned, I don't think the driver handles them, but the underlying SageTCPServer.jar can definitely do it...


Sage Media Server driver (beta) - Shildrak - 05-30-2009

You're right. WatchShowPath will handle the audio as well, as long as the files are also imported into sagetv's own media repository. (I only had the music in JRMC and the exported xml into cqc when I first tried it). So now I'm up to synchronizing my music in 4 repositories: jrmc, cqc, squeezecenter and sagetv, but it works :-)

Thanks for the pointer.


Sage Media Server driver (beta) - SamVimes2 - 05-30-2009

Fonceur,

I think I am running the latest version of the driver (downloaded .9 from the head of this thread, but it says .8.9 in the field once loaded).

When I write a number, say '5', into the 'SelectedChannelIndex' field, the driver disconnects. I also don't have anything populated in the ChannelNames, ChannelNumbers, ChannelNetworks fields.

Am I missing something about how these fields work?

Thanks!


Sage Media Server driver (beta) - Fonceur - 05-30-2009

SamVimes2 Wrote:Am I missing something about how these fields work?
Make sure you also have the latest XML and SageTCPServer files... The empty channel fields would indeed be consistent with a mismatched version...