Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - Fonceur - 10-12-2009

Updated version and simple demo template.


Sage Media Server driver (beta) - Fonceur - 10-12-2009

SamVimes2 Wrote:As I mentioned in the email, I cannot set the verbose mode to 'high' because it crashes the driver, so no CQC logging to be had.
The "minimal log" of that crash in itself would have been a start... Wink

Quote:Do you have any thoughts on the player driver question?
Well, the MediaChannel should tell you if it's a TV show, the MediaArtist might tell you if it's music, but there isn't really a direct method otherwise...

Quote:What is your setup like in terms of channels and lineups?
Analog lineup with 40ish channels and digital lineup with 300ish channels.


Sage Media Server driver (beta) - royalj7 - 10-12-2009

Fonceur,

I installed the latest version of the drivers and the MediaPosition problem is gone, it now tracks position after skipping, FF, etc. Thanks.

However, the Rewind command does not seem to do anything now. Before it would skip back, but now nothing happens when I press the button linked to it.

--Jamie


Sage Media Server driver (beta) - Fonceur - 10-12-2009

royalj7 Wrote:However, the Rewind command does not seem to do anything now. Before it would skip back, but now nothing happens when I press the button linked to it.
Right, as mentioned with the release: "The old Transport.Rewind is now Transport.SkipBack and Transport.Rewind should now work as expected on an extender, and possibly for dvd playback on a windows system..."


Sage Media Server driver (beta) - SamVimes2 - 10-12-2009

Fonceur Wrote:Updated version and simple demo template.

This version also fails for me, pegging the CPU immediately on loading and unable to set verbosity:
[Image: sagefail.jpg]


There is nothing related to the driver (except the failure to set the verbosity) in the CQC logs:
[Image: nologs.jpg]


In the sage log, it looks to be getting stuck on upcoming shows (had to snip this, I sent you the full XML in email)
Code:
Tue 10/13 3:21:50.480 [Ministry@1d5a9bd] Ministry is waiting for 180 sec
Tue 10/13 3:22:22.326 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Connected to client, waiting for messages...
Tue 10/13 3:22:22.826 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: There is 1 message to be sent.
Tue 10/13 3:22:22.827 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: VER:1.0.0 (beta 274)
Tue 10/13 3:22:22.827 [Thread-4@fa706b] [[SageTCPServer-MessageType]]: Found match with MOD
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Message received: MOD:Media
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Now 1 incoming message(s) in list.
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) There is now 1 incoming message.
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: The following UI context are available: 001d6a4cf4d2, 001d6a4c01aa,
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) MOD:Media
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: There is 1 message to be sent.
Tue 10/13 3:22:22.828 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: MOD:OK
Tue 10/13 3:22:22.829 [Thread-4@fa706b] [[SageTCPServer-MessageType]]: Found match with ANS
Tue 10/13 3:22:22.829 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Message received: ANS:XML
Tue 10/13 3:22:22.829 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Now 1 incoming message(s) in list.
Tue 10/13 3:22:22.829 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) There is now 1 incoming message.
Tue 10/13 3:22:22.830 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: The following UI context are available: 001d6a4cf4d2, 001d6a4c01aa,
Tue 10/13 3:22:22.830 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) ANS:XML
Tue 10/13 3:22:22.830 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: There is 1 message to be sent.
Tue 10/13 3:22:22.830 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: ANS:OK
Tue 10/13 3:22:22.830 [Thread-4@fa706b] [[SageTCPServer-MessageType]]: Found match with MAX
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Message received: MAX:250
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Now 1 incoming message(s) in list.
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) There is now 1 incoming message.
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: The following UI context are available: 001d6a4cf4d2, 001d6a4c01aa,
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) MAX:250
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: There is 1 message to be sent.
Tue 10/13 3:22:22.831 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: MAX:OK
Tue 10/13 3:22:22.832 [Thread-4@fa706b] [[SageTCPServer-MessageType]]: Found match with INI
Tue 10/13 3:22:22.832 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Message received: INI
Tue 10/13 3:22:22.832 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Now 1 incoming message(s) in list.
Tue 10/13 3:22:22.832 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) There is now 1 incoming message.
Tue 10/13 3:22:22.833 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: The following UI context are available: 001d6a4cf4d2, 001d6a4c01aa,
Tue 10/13 3:22:22.833 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: (Processing messages) INI
Tue 10/13 3:22:23.000 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Finding all upcoming recordings.....
Tue 10/13 3:22:23.001 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: 9 scheduled recordings found.
Tue 10/13 3:22:23.003 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Finding all the listings for: IsTVFile
Tue 10/13 3:22:23.009 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: 124 files found.
Tue 10/13 3:22:23.010 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Done filling toDelete...
Tue 10/13 3:22:23.037 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Finding all the manual recordings...
Tue 10/13 3:22:23.118 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: 0 manual recording(s) found.
Tue 10/13 3:22:23.119 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Finding all the favorites...
Tue 10/13 3:22:23.119 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: 19 favorites found.
Tue 10/13 3:22:23.120 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: There are 7 messages to be sent.
Tue 10/13 3:22:23.120 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: INI:OK
Tue 10/13 3:22:23.120 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: CRF:1
Tue 10/13 3:22:23.120 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: VDS:472206|4630
Tue 10/13 3:22:23.121 [Thread-4@fa706b] [[SageTCPServer-SageServer(local:9250)]]: Sending data: URL:<?xml version="1.0" encoding="utf-8"?><Collection><List Name="Upcoming"><Program><Modifier>Add</Modifier><ID>2895121</ID><Title>Clash of the Gods</Title><Episode>Thor</Episode><Category>History</Category><StartTime>12554172</StartTime><EndTime>12554209</EndTime><IsWatched>false</IsWatched><Description>In ancient Norse mythology, Thor, god of thunder, protects against evil ogres and battles a giant serpent bent on destroying mankind.</Description>***SNIP***<FirstRun>true</FirstRun><OriginalAirDate>12556512</OriginalAirDate><Channel>704</Channel><StationName>WNBCDT (WNBC-DT) New York</StationName><Credits>Tina Fey, Lorne Michaels, Jo Ann Alfano, David Miner, Marci Klein</Credits><IsHD>true</IsHD></Program></List></Collection>
Tue 10/13 3:24:50.489 [Ministry@1d5a9bd] Ministry is waiting for 180 sec
Tue 10/13 3:26:08.418 [Seeker@184db0d] Seeker awoken



Sage Media Server driver (beta) - Fonceur - 10-13-2009

SamVimes2 Wrote:This version also fails for me, pegging the CPU immediately on loading and unable to set verbosity:
Not being able to set the verbose mode to high kinda sound like a CQC bug... Try setting it to low...


Sage Media Server driver (beta) - SamVimes2 - 10-13-2009

Fonceur Wrote:Not being able to set the verbose mode to high kinda sound like a CQC bug... Try setting it to low...

I can change the verbosity on other drivers, but I can't change Sage at all. I don't think it's a CQC bug, I think the driver is thrashing/crashing and can't be communicated with. The pegging of the CPU is the same thing I think.

Maybe something it's receiving from Sage (funny character in a show title maybe?) is killing it? What CQC version are you testing with? I am on 3.0.11.


Sage Media Server driver (beta) - royalj7 - 10-13-2009

Fonceur Wrote:Right, as mentioned with the release: "The old Transport.Rewind is now Transport.SkipBack and Transport.Rewind should now work as expected on an extender, and possibly for dvd playback on a windows system..."

Okey...so Transport.Rewind now should smoothly rewind the video right? Right now, the Transport.Rewind command isn't doing anything for me...the Transport.SkipBack still works. If I'm missing something I apologize.

Thanks,
--Jamie


Sage Media Server driver (beta) - Fonceur - 10-13-2009

royalj7 Wrote:Okey...so Transport.Rewind now should smoothly rewind the video right?
Are you using it on an HD Extender playing back a DVD and does the HD Extender remote's rewind button work on it?


Sage Media Server driver (beta) - Fonceur - 10-13-2009

SamVimes2 Wrote:I can change the verbosity on other drivers, but I can't change Sage at all.
OK, I added some recording jobs and I'm now able to reproduce that issue.