Charmed Quark Systems, Ltd. - Support Forums and Community
Sage Media Server driver (beta) - Printable Version

+- Charmed Quark Systems, Ltd. - Support Forums and Community (https://www.charmedquark.com/vb_forums)
+-- Forum: General Discussion (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=3)
+--- Forum: Driver Development (https://www.charmedquark.com/vb_forums/forumdisplay.php?fid=13)
+--- Thread: Sage Media Server driver (beta) (/showthread.php?tid=5497)



Sage Media Server driver (beta) - Fonceur - 10-07-2009

royalj7 Wrote:1. The MediaPosition doesn't seem to work well in my setup. It will start ticking away as the movie starts, but if I fast forward or skip forward it just stops counting and stays where it was.
I did look into it before, but didn't find anything obvious... I'll check again.

Quote:2. The Rewind command does not seem to act like it does on the remote. When I invoke it from the driver it skips back 10 seconds instantly, as opposed to playing backwards at 2X speed. I thought maybe it was labeled Previous in the driver, but that skips back 30 seconds.
Right, probably got the mapping of commands wrong. Any others not acting as expected?

EDIT: I've just double checked the server's UI, and the behavior is the same as the the driver... I guess they might have done it differently for the extender's remote...


Sage Media Server driver (beta) - sic0048 - 10-07-2009

The extender remotes have three options each for FFW or Rewind. You have the large and small "jumps" (usually programmed as 30 sec and 10 second jumps) and then you have the smooth ff/rwd option.

I'm not sure there is a corresponding option for the "Smooth FF" and "Smooth RWD" remote buttons in the driver currently.

The HD-220 manual has the remote control layout diagram on page 11.


Sage Media Server driver (beta) - Fonceur - 10-07-2009

sic0048 Wrote:The extender remotes have three options each for FFW or Rewind.
OK, I see it in the HD200 manual, but the rewind is nowhere to be found in the API documentation... So I'll ask on the SageTV forum.

Quote:I'm not sure there is a corresponding option for the "Smooth FF" and "Smooth RWD" remote buttons in the driver currently.
There is a PlayFaster (FF) as well as a PlaySlower, but indeed the Rewind = SkipBackward and Previous = SkipBackward2 as in the server/client UI.


Sage Media Server driver (beta) - Fonceur - 10-07-2009

The old Transport.Rewind is now Transport.SkipBack and Transport.Rewind should now work as expected on an extender, and possibly for dvd playback on a windows system...


Sage Media Server driver (beta) - beelzerob - 10-07-2009

Ya, I think I remember looking in the API for those normal "fast forward" type of commands and not seeing them. I wonder if it's because, unlike a skip, that type of transport would require a "press" and a "release" mechanism, and perhaps that's unsuited for remote application controls. *shrug*


Sage Media Server driver (beta) - Fonceur - 10-07-2009

The command "Smooth RW" and "Smooth FF" should work for that, but it is codec dependent... So I guess the one in the HD200 always work... Wink


Sage Media Server driver (beta) - SamVimes2 - 10-12-2009

With this latest round (updated TCP Server + CQC Server driver) I do not get any shows/channels/upcomings/lineups at all. Trying to set the driver to verbose mode high crashes the driver. Fonceur, I have sent you mail as such.

On another note, how do you guys problematically tell whether TV, DVD, Bluray, or Video is playing in the player driver? I'd like to load different 'now playing' screens based on that.


Sage Media Server driver (beta) - Fonceur - 10-12-2009

SamVimes2 Wrote:Fonceur, I have sent you mail as such.
Right, but I was expecting a follow up with the actual logs (SageTV/CQC) or something, as it's working fine on my end...


Sage Media Server driver (beta) - SamVimes2 - 10-12-2009

As I mentioned in the email, I cannot set the verbose mode to 'high' because it crashes the driver, so no CQC logging to be had.

The Sage logs look just like they always do (giant hunks of XML) but I will look again.

I had assumed it would be easy to zero in on the changes you had made.

Do you have any thoughts on the player driver question?


Sage Media Server driver (beta) - SamVimes2 - 10-12-2009

Fonceur Wrote:Right, but I was expecting a follow up with the actual logs (SageTV/CQC) or something, as it's working fine on my end...

What is your setup like in terms of channels and lineups?